




SAFETY PRECAUTIONS
                         (Always read these instructions before using this product.)

Before using this product, thoroughly read this manual and the relevant manuals introduced in this manual 
and pay careful attention to safety and handle the products properly.
The precautions given in this manual are concerned with this product. For the safety precautions of the 
programmable controller system, refer to the User’s Manual for the CPU module.
In this manual, the safety precautions are ranked as "DANGER" and "CAUTION".

Note that the CAUTION level may lead to serious consequences according to the circumstances.
Always follow the precautions of both levels because they are important for personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Instructions] 

[Startup/Maintenance Instructions]

 DANGER
● When data change, program change, or status control is performed from a personal computer to a running 

programmable controller, create an interlock circuit outside the programmable controller to ensure that the whole 
system always operates safely. 
Furthermore, for the online operations performed from a personal computer to a programmable controller CPU, the 
corrective actions against a communication error due to such as a cable connection fault should be predetermined as 
a system.

CAUTION
● The online operations performed from a personal computer to a running programmable controller CPU (Program 

change when a programmable controller CPU is RUN, operating status change such as RUN-STOP switching, and 
remote control operation) have to be executed after the manual has been carefully read and the safety has been 
ensured.
When changing a program while a programmable controller CPU is RUN, it may cause a program corruption in some 
operating conditions. Fully understand the precautions described in GX Works2 Version1 Operating Manual 
(Common) before use.

DANGER

CAUTION

Indicates that incorrect handling may cause hazardous conditions, resulting in 

death or severe injury.

Indicates that incorrect handling may cause hazardous conditions, resulting in 

minor or moderate injury or property damage.
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■ MANUALS

Related manuals are separately issued according to the purpose of their functions in GX Works2.

● Related manuals
The manuals related to this product are shown below.
Refer to the following tables when ordering required manuals.

1) Operation of GX Works2

2) Structured Programming

Manual name Manual number
(Model code)

GX Works2 Version1 Operating Manual (Common)
Explains the system configuration of GX Works2 and the functions common to a Simple project and 
Structured project such as parameter setting, operation method for the online function.

(Sold separately)

SH-080779ENG
(13JU63)

GX Works2 Version1 Operating Manual (Structured Project)
Explains operation methods such as creating and monitoring programs in Structured project of GX 
Works2.

(Sold separately)

SH-080781ENG
(13JU65)

GX Works2 Beginner's Manual (Simple Project)
Explains fundamental operation methods such as creating, editing, and monitoring programs in Simple 
project for users inexperienced with GX Works2. 

(Sold separately)

SH-080787ENG
(13JZ22)

GX Works2 Beginner's Manual (Structured Project)
Explains fundamental operation methods such as creating, editing, and monitoring programs in 
Structured project for users inexperienced with GX Works2. 

(Sold separately)

SH-080788ENG
(13JZ23)

Manual name Manual number
(Model code)

QCPU Structured Programming Manual (Fundamentals)
Explains the programming methods, types of programming languages, and other information required to 
create structured programs.

(Sold separately)

SH-080782ENG
(13JW06)

QCPU Structured Programming Manual (Common Instructions)
Explains the specifications and functions of sequence instructions, basic instructions, and application 
instructions that can be used in structured programs.

(Sold separately)

SH-080783ENG
(13JW07)

QCPU Structured Programming Manual (Application Functions)
Explains the specifications and functions of application functions that can be used in structured 
programs.

(Sold separately)

SH-080784ENG
(13JW08)

QCPU Structured Programming Manual (Special Instructions) 
Explains the specifications and functions of instructions for network modules, intelligent function 
modules, and PID control functions that can be used in structured programs.

(Sold separately)

SH-080785ENG
(13JW09)

The Operating Manual is included in the CD-ROM with the software package.
Manuals in printed form are sold separately for single purchase. Order a manual by quoting the manual 
number (model code) listed in the table above.
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● Purpose of this manual
This manual explains the operations for creating sequence programs in Simple project using the 
functions supported with GX Works2.
Manuals for reference are listed in the following table according to their purpose. 
For information such as the contents and number of each manual, refer to the list of 'Related 
manuals'.

1) Operation of GX Works2

Purpose

GX Works2 
Installation 
Instructions

GX Works2
Beginner's Manual

GX Works2 Version1
Operating Manual

−
Simple 
Project

Structured 
Project Common Simple

Project
Structured 

Project

Installation
Learning the operating 
environment and 
installation method

Operation of Simple 
project

Learning the basic 
operations and 
operating procedures

Learning the functions 
and operation methods 
for programming

Learning all functions 
and operation methods 
except for 
programming

Operation of Structured 
project

Learning the basic 
operations and 
operating procedures

Learning the functions 
and operation methods 
for programming

Learning all functions 
and operation methods 
except for 
programming

Details

Details

Outline Outline

Outline

Details

Details

Details

Outline Outline

Outline

Details Details

Details
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2) Programming

Purpose

QCPU Structured Programming Manual QCPU(Q mode)/QnACPU 
Programming Manual

User's Manual for 
intelligent 

function module/ 
Reference 
Manual for 

network module

Fundamentals Common 
Instructions

Special 
Instructions

Application 
Functions

Common 
Instructions

PID Control 
Instructions −

Programming 
in Simple 
project

Learning the 
types and details 
of common 
instructions, 
descriptions of 
error codes,  
special relays, 
and special 
registers

Learning the 
types and details 
of instructions for 
intelligent function 
modules

Learning the 
types and details 
of instructions for 
network modules

Learning the 
types and details 
of instructions for 
the PID control 
function

Programming 
in Structured 
project

Learning the 
fundamentals for 
creating a 
structured 
program for the 
first time

Learning the 
types and details 
of common 
instructions

Learning the 
types and details 
of instructions for 
intelligent function 
modules

Learning the 
types and details 
of instructions for 
network modules

Learning the 
types and details 
of instructions for 
the PID control 
function

Learning the 
descriptions of 
error codes, 
special relays, 
and special 
registers

Learning the 
types and details 
of application 
functions

Details

Details

Details

Details

Details

Details

Details Details

Details Details

Details Details

Details

Details
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● How to read this manual

Supported CPU

Supported programmable 

controller CPUs are shown in 

icons under the section title.

Screen display

Describes the screen display 

procedure.

Follow the     and select 

[(menu)] to open the screen.

*Screen display may depend on 

the CPU.

In that case, typical example is 

described.

Display contents

Describes the display contents 

in the screen.

Operating procedure

Describes the operating 

procedure of the function.

Section title

Clarifies the section of currently 

open page.

Chapter heading

Index on the right of the page 

number clarifies the chapter of 

currently open page.

Reference location

leads to the reference 

location and reference manual.

Screen button

Describes the buttons in the 

screen.
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This manual also uses the following columns:

This explains notes requiring attention or useful functions relating to the information given on the 
same page.

This explains restrictions relating to the information given on the same page.

● Symbols used in this manual
The following shows the symbols used in this manual with descriptions and examples.

Restrictions

No. Symbol Description Example

[       ] Menu name on a menu bar [Project]

Toolbar icon

(Underline) Screen name Q Parameter Setting screen

<<       >> Tab name in a screen <<PLC System>>

"      " Item name in a screen "Timer Limit Setting" 

Button on a screen  button

− Keyboard key

1

2

4

5

6

3

1

2

3

4

5

6
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■ GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL

This manual uses the generic terms and abbreviations listed in the following table to discuss the  
software packages and programmable controller CPUs. Corresponding module models are also listed if 
needed.

Generic term and 
abbreviation Description

GX Works2 Generic product name for the SWnDNC-GXW2-E
(n: version)

GX Developer
Generic product name for the SWnD5C-GPPW-E, SWnD5C-GPPW-EA, SWnD5C-GPPW-EV, and 
SWnD5C-GPPW-EVA
(n: version)

Personal computer Generic term for personal computers on which Windows® operates
High Performance model 
QCPU Generic term for the Q02, Q02H, Q06H, Q12H, and Q25H

Universal model QCPU Generic term for the Q02U, Q03UD, Q03UDE, Q04UDH, Q04UDEH, Q06UDH, Q06UDEH, 
Q13UDH, Q13UDEH, Q26UDH, and Q26UDEH

Built-in Ethernet port 
QCPU Generic term for the Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and Q26UDEH

QCPU (Q mode) Generic term for the High Performance model QCPU and the Universal model QCPU
Simple project Generic term for projects created by using the ladder/SFC language
Structured project Generic term for projects created by using the ladder/SFC/ST/structured ladder language

Project without labels Generic term for the Simple projects that do not use labels
(Projects created without selecting "Use Labels" when creating new projects.)

Project with labels Generic term for the Simple projects and Structured projects that use labels
(Projects created with selecting "Use Labels" when creating new projects.)

Project with security Generic term for the projects whose securities are set
Common instruction Generic term for the sequence instructions, basic instructions, and application instructions
Special instruction Generic term for the PID control instructions and module dedicated instructions
A - 24
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1 OVERVIEW
This manual describes the programming method using Simple project and the operation method of the related 
functions.
For the features and functions of GX Works2, refer to the following manual.

GX Works2 Version1 Operating Manual (Common)
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1.1    What is Simple Project? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2
1.2    Features of Simple Project . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2
1.3    List of Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-3
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1 OVERVIEW
GX Works2
1.1 What is Simple Project?
The Simple project is used to create sequence programs using instructions for Mitsubishi programmable 
controller CPUs.
Programs in Simple project can be created in a similar way with the existing GX Developer.

1.2 Features of Simple Project
The features of the Simple project are as follows.

■ Inheritance of operational performances and enhanced use of program assets

GX Works2 inherits excellent operational performances from the existing GX Developer.

Therefore, GX Works2 can edit the sequence 
programs created by the existing GX 
Developer, making it possible to reuse program 
assets effectively.

■ Programming using labels

Execution programs can be created by associating label names with actual devices when the 
equipment configurations (equipment names) are finalized.

Therefore, programs can be created with 
flexibility that can respond to conditions such 
as changing equipment configurations 
(equipment names).

Whether labels are used or not can be 
selected when creating a new project.

■ Program components using function blocks

The function blocks can be used to convert and register ladder 
blocks that are used repeatedly as components.
Therefore, registered ladder blocks can be easily reused when 
creating sequence programs.

Function blocks can be used only for a project that uses labels.

GX Works2

GX Developer
1 - 2  
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1.3 List of Functions
1.3 List of Functions
This section shows the list of functions of GX Works2.
The functions are divided into common functions available (Project, Online, Debug, Diagnostics, Tools, 
Window, and Help) and functions used for each editing and setting target (Edit, Find/Replace, Convert/
Compile, and View).
For (Common) and (Structured) indicated in the Reference column, refer to the following manuals 
respectively:
(Common) .............GX Works2 Version1 Operating Manual (Common)
(Structured) ...........GX Works2 Version1 Operating Manual (Structured Project)

1.3.1 List of functions common to Simple project and Structured 
project

This section explains the functions common to a Simple project and a Structured project.

■ List of common functions

The following tables show functions that are always available regardless of the type of editing or setting 
target.

Project (common function) Reference
New Creates a new project.

(Common)

Open Opens an existing project.
Close Closes an open project.
Save Saves a project.
Save As Names and saves a project.
Delete Deletes an existing project.
Verify Verifies between two project data.
Project Revision −

Revision Entry Registers the project change history. 

(Common)
Revision List Displays the list of project change history.

Change PLC Type Changes the programmable controller CPU type.

Change Project Type Changes the project type from a Simple project to a 
Structured project.

Object −

New Adds data to a project.

(Common)

Rename Renames the selected data.
Delete Deletes the selected data.
Data Copy Copies the selected data.
Data Paste Pastes the copied data.

Set as Default Connection Specifies data in selected connection target as a connection
target for regular use.

Property Displays the selected data properties.
Intelligent Function Module −

Add New Module Adds new intelligent function module data.

(Common)
Delete Module Deletes intelligent function module data.
Property Displays properties of an intelligent function module data.
Intelligent Function Module Parameter 
List

Shows a list of set/unset parameters of an intelligent function 
module.
1.3.1 List of functions common to Simple project and Structured project 1 - 3
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1 OVERVIEW
GX Works2
 

Open Other Data −

Open Other Project Opens a project created with GX Developer.

(Common)
Read GX IEC Developer Data Reads a project created with GX IEC Developer.
Read GX Configurator-QP Data Reads a project created with GX Configurator-QP.

Export to GX Developer Format File Saves an open project in GX Developer format.
Library

(Structured)

Create Creates a new library.
Install Installs a created library to the project.
Deinstall Deletes a library from the project.
Update Library Updates the library imported to the project.
Rename Renames a library.
Open Enables editing of a library.
Close Disables editing of a library.
Change Password Sets a password for a library.
Save as Names and saves a project.
Save Saves a library file.
Delete Deletes a library file.
Help Displays help information of the library.

Security Level −

Change Password Changes the password of the current login user.

(Common)

User Management Manages user information of the project.
Adds/deletes a user or changes the user information.

Data Security Setting Sets the access authorization of each user related to
reading/writing data.

Print Window Prints the open screen.
Print Window Preview Displays the print preview of the open screen.
Printer Setup Changes the printer settings.

The Latest File Displays the recently used GX Works2 project paths and 
opens the selected project.

Quit Exits GX Works2.

Edit (common function) Reference
Cut Cuts the selected data.

−
Copy Copies the selected data.
Paste Pastes the cut or copied data at the cursor position.
Delete Deletes the selected data.

Find/Replace (common function) Reference
Find Searches for a character string.

(Common)
Replace Replaces the character string.
Cross Reference Displays the usage of selected device or label.
List of Used Device Displays the usage of devices.

Convert/Compile (common function) Reference
Build Compiles (converts) a program being edited.   Section 8.5 

Compile + Online Change Writes a sequence program to the programmable controller 
CPU after compilation. Section 8.7

Rebuild All Compiles (converts) all programs in the project.   Section 8.4 
Change SFC All Converts all SFC programs in the project. Section 8.2

Project (common function) Reference
1 - 4 1.3.1 List of functions common to Simple project and Structured project
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1.3 List of Functions
View (common function) Reference
Toolbar −

Toolbar name Displays/hides the tool bar.

(Common)Statusbar Displays/hides the status bar.

Colors Sets the display color such as labels, device comments on 
the work window.

Docking Window −

Project Window
Displays/hides the Project window.
In the Project window, the data in the open project is 
displayed in a list.

(Common)

Function Block Selection Window
Displays/hides the Function Block Selection window.
Select a part such as FB on the window for utilizing it to a 
program.

  Section 
5.1.3 

Output Window
Displays/hides the Output window.
In the Output window, the conversion (compilation) result is 
displayed.

 Chapter 8 

Cross Reference Window
Displays/hides the Cross Reference window.
In the Cross Reference window, devices/labels used in the 
project are displayed.

(Common)
List of Used Device Window

Displays/hides the List of Used Device window.
In the List of Used Device window, the usage of selected 
device is displayed.

Watch Window 1 to 4 Displays/hides the Watch window.
In the Watch window, the monitoring result is displayed.

Find/Replace Window
Displays/hides the Find/Replace window.
In the Find/Replace window, the search/replace result is 
displayed.

Online (common function) Reference
Read from PLC Reads data from the programmable controller CPU.

Section 9.1
Write to PLC Writes data to the programmable controller CPU.

Verify with PLC Verifies a project being edited against the data in the 
programmable controller CPU.

(Common)
Start/Stop PLC Remotely controls RUN/PAUSE/STOP of the programmable 

controller CPU from GX Works2.
PLC Keyword −

New Sets a password to the programmable controller CPU.

(Common)

Delete Cancels the password set to the programmable controller CPU.

Disable Temporarily unlocks the password set to the programmable 
controller CPU.

PLC Memory Operation Formats, arranges, and clears the memory of the 
programmable controller CPU.

Format PLC Memory Formats the programmable controller CPU memory.
Clear PLC Memory Clears the programmable controller CPU memory.
Arrange PLC Memory Arranges the programmable controller CPU memory.

Delete PLC Data Deletes data in the programmable controller CPU.
PLC User Data −

PLC User Data Read Reads the programmable controller CPU user data.
(Common)PLC User Data Write Writes the programmable controller CPU user data.

PLC User Data Delete Deletes the programmable controller CPU user data.

Export to ROM Format Copies the program memory data in the programmable 
controller CPU to ROM.

Program Memory Batch Download Transfers the contents of program cashe memory to 
program memory in a batch.

Latch Data Backup −

Backup Backs up device memory/file register/error history data in the 
Universal model QCPU to the standard ROM.

(Common)Delete Backup Data Deletes the backup data in the Universal model QCPU.
Set Clock Sets the clock in the programmable controller CPU.
1.3.1 List of functions common to Simple project and Structured project 1 - 5
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1 OVERVIEW
GX Works2
Monitor −

Start Monitoring (All Windows) Starts monitoring of all open windows.
(Common)

Stop Monitoring (All Windows) Stops monitoring of all open windows.
Start Monitoring Starts monitoring of the open window. Section 

10.1Stop Monitoring Stops monitoring of the open window.

Start Watch Starts monitoring the current values of registered devices/
labels.

(Common)
Stop Watch Stops monitoring the current values of registered devices/

labels.

Change Value Format (Decimal) Displays the current device value in decimal in program 
monitoring. Section 

10.3.1
Change Value Format (Hexadecimal) Displays the current device value in hexadecimal in program 

monitoring.
Device/Buffer Memory Batch Monitor Monitors device/buffer memory in a batch. (Common)

Change Instance (Function Block) Selects an instance of the function block to be monitored. Section 
10.2

SFC All Block Batch Monitor Batch monitors all blocks in the SFC program. Section 
10.5.4

Register to Watch Window Registers the selected devices to the Watch window. (Common)

Modify Value Changes the ON/OFF status and values of devices and 
labels used in the program. (Common)

Debug (common function) Reference
Start/Stop Simulation Starts/stops simulation.

(Common)
Show Restricted Instructions Displays a list of the instructions and devices used in the 

program unsupported for the simulation function.
Sampling Trace −

Open Sampling Trace Executes sampling trace. (Common)

Diagnostics (common function) Reference

PLC Diagnostics Diagnoses the operating status of the programmable 
controller CPU.

(Common)

Ethernet Diagnostics Diagnoses the Ethernet.
CC-Link IE Control Diagnostics Diagnoses the CC-Link IE controller network.
MELSECNET Diagnostics Diagnoses the MELSECNET/10(H).
CC-Link / CC-Link/LT Diagnostics Diagnoses the CC-Link and CC-link/LT.

System Monitor Monitors the system status of the programmable controller 
CPU.

Tools (common function) Reference
IC Card −

Read IC Card Reads data from the IC memory card. 
(Common)

Write IC Card Writes data to the IC memory card.
Program Check Checks programs and displays errors. Section 8.3
Parameter Check Checks parameters and displays errors. (Common)

Options Sets various options. Chapter
11

System Label Setting Sets device range to be automatically assigned to a label. Section 4.7
Block Password Sets a block password to data. (Common)
Intelligent Function Module Parameter Check −

Auto Refresh Duplication Check Checks the duplication of devices set in the Auto refresh 
function and displays the result. (Common)

Online (common function) Reference
1 - 6 1.3.1 List of functions common to Simple project and Structured project
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1.3 List of Functions
■ List of functions for setting labels

The following table shows the functions available for setting and editing labels.

Window (common function) Reference
Cascade Tiles windows in overlapping display.

(Common)

Tile Vertically Tiles windows vertically.
Tile Horizontally Tiles windows horizontally.
Arrange Icons Arranges the icons at the bottom of the window.
Close All Closes all open windows.
(Switch to Other Window) Displays the open window.

Window Displays a list of open windows.
Also opens or arranges specified windows.

Help (common function) Reference
PLC Error Displays the explanation for each CPU error code.

(Common)Special Relay/Register Displays the explanation for each special relay and special 
register.

Changes from GX Developer Displays the changes from GX Developer to GX Works2.
Operating Manual

GX Works2 Beginner's Manual (Simple 
Project)

Displays the operating manuals.
(Common)

GX Works2 Beginner's Manual 
(Structured Project)
GX Works2 Operating Manual 
(Common)
GX Works2 Operating Manual (Simple 
Project)
GX Works2 Operating Manual 
(Structured Project)

Connect to MELFANSweb Connects to the MELFANSweb website.
About GX Works2 Displays product information such as the version.

Edit (function for label setting) Reference
Select All Selects all items.

Section 
4.5.2

Expand Declaration Expands the collapsed items.
Collapse Declaration Collapses the expanded items.
New Declaration (Before) Adds a line above the cursor position.
New Declaration (After) Adds a line below the cursor position.
Delete Line Deletes a line at the cursor position.
1.3.1 List of functions common to Simple project and Structured project 1 - 7
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1 OVERVIEW
GX Works2
■ List of functions for editing device comments

The following table shows functions available for editing device comments.

■ List of functions for setting device memory

The following tables show the functions available for setting device memory.

Edit (function for editing device comments) Reference
Undo Restores the previous processing status.

(Common)

Redo Restores the processing deleted with [Undo].
Select All Selects all data being displayed.
Import from Sample Comment

Special Relay/Register Utilizes sample comments of SM/SD.

Intelligent Function Module Utilizes sample comments of intelligent function module 
device.

Clear All Deletes all device comment data.

Edit (function for setting device memory) Reference
Paste Text Enters a character string.

(Common)Insert Row Inserts a row at the cursor position.
Insert Device Enters a device.

Find/Replace (function for setting device memory) Reference
Find Device Searches for a device. (Common)

View (function for setting device memory) Reference
Display Mode −

Binary Displays data in binary.

(Common)

Octal Displays data in octal.
Decimal Displays data in decimal.
Hexadecimal Displays data in hexadecimal.
Float Displays data in real number.
ASCII Displays data in character string.

Register −

16-bit Displays data in units of words.

(Common)
32-bit Displays data in units of double words.
64-bit Displays data in units of 64 bits.

Setup Changes the editor size.

Tools (function for setting device memory) Reference

Upload Device Memory from PLC Reads device memory data from the programmable 
controller CPU.

(Common)Download Device Memory to PLC Writes device memory data to the programmable controller 
CPU.

Import from Excel File Reads data from an Excel file.
Export to Excel File Writes data to an Excel file.
1 - 8 1.3.1 List of functions common to Simple project and Structured project
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1.3 List of Functions
■ List of functions for executing sampling trace

The following tables show the functions available for executing sampling trace.

View (function for executing sampling trace) Reference
Result Display Position

(Common)
Move to Trigger Position Displays the trigger position.

Switching Display Items −

Device

Display/hides the display item titles. (Common)
Address
Comment
Data Types
Radix

Timing Chart Scale −

Narrow Scale
Changes the display width of the timing chart scale. (Common)

Wide Scale
Trend Graph Scale

Narrow Scale
Changes the display width of the trend graph scale. (Common)Wide Scale

Initial Display
Additional Information −

Past Time
Display/hides the additional information. (Common)

Program Name

Debug (function for executing sampling trace) Reference
Sampling Trace −

Trace Settings Displays the screen on which the sampling trace conditions 
are set.

(Common)

Start Trace Starts sampling trace.
Stop Trace Suspends sampling trace.
Execute Manual Trigger Generates a trigger at any given timing.

Register Trace

Writes trace settings to the programmable controller CPU.
Execute this to control the sampling trace start by a 
sequence program.
Sampling trace starts when the Trace start command 
(SM801) is executed after executing "Register Trace".

Forced Execution Registration Valid Enables to execute the sampling trace from the peripherals 
for the Universal model QCPUs.

Display Trace Buffer Condition Displays trace data storage status.

Export CSV Data Saves the trace data (trace settings + results) to a personal 
computer in CSV file format.

Upload from PLC Writes the sampling trace data (trace settings + results) to 
the programmable controller CPU.

Download to PLC Reads the trace data (trace settings + results) from the 
programmable controller CPU.

Delete All Data
Deletes all information including the device data registered 
and the sampling trace result displayed on the Sampling 
Trace screen.
1.3.1 List of functions common to Simple project and Structured project 1 - 9
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1 OVERVIEW
GX Works2
1.3.2 List of functions for editing in ladder language

The following tables show the functions available for editing with the ladder editor.

Edit (function for editing in ladder language) Reference

Undo Restores the previous processing status. Section 
5.1.10

Restore after ladder conversion Returns a ladder being edited to the last converted status. Section 
5.1.11

Insert Row Inserts a row at the cursor position.

Section 5.1.7
Delete Row Deletes a row at the cursor position.
Insert Column Inserts a column at the cursor position.
Delete Column Deletes the column at the cursor position.
NOP Batch Insert Inserts an NOP in front of the ladder block at the cursor position.

Section 5.1.8
NOP Batch Delete Batch-deletes NOPs in the program being edited.
Edit Line Enters a line at the cursor position. Section 5.1.4
Delete Line Deletes a line at the cursor position. Section 5.1.6
Ladder Symbol −

Open Contact Inserts  at the cursor position. 

Section 5.1.2

Close Contact Inserts  at the cursor position. 

Open Branch Inserts  at the cursor position. 

Close Branch Inserts  at the cursor position. 

Coil Inserts  at the cursor position. 

Application Instruction Inserts  at the cursor position. 

Vertical Line Inserts  at the cursor position. 
Section 5.1.4

Horizontal Line Inserts  at the cursor position. 

Delete Vertical Line Inserts  at the cursor position. 
Section 5.1.6

Delete Horizontal Line Inserts  at the cursor position. 

Rising Pulse Inserts  at the cursor position. 

Section 5.1.2

Falling Pulse Inserts  at the cursor position. 

Rising Pulse Branch Inserts  at the cursor position. 

Falling Pulse Branch Inserts  at the cursor position. 

Invert Operation Results Inserts  at the cursor position. 

Operation Result Rising Pulse Inserts  at the cursor position. 

Operation Result Falling Pulse Inserts  at the cursor position. 
Edit FB Instance Renames an FB instance name. Section 5.1.3
Documentation −

Device Comment Edits device comments. (Common)
Statement Edits statements.

Section 7.2
Note Edits notes.
Statement/Note Batch Edit Batch-edits the statements/notes in the program. Section 7.3

Find/Replace (function for editing in ladder language) Reference
Jump Moves the cursor to the specified step position. Section 6.1.4
Find Device Searches for a device. Section 6.1.1
Find Instruction Searches for an instruction. Section 6.1.2
1 - 10 1.3.2 List of functions for editing in ladder language
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1.3 List of Functions
1.3.3 List of functions for editing SFC diagrams

The following tables show the functions available for editing SFC diagrams.

Replace Device Replaces a device. Section 6.1.1
Replace Instruction Replaces an instruction. Section 6.1.2
Find Contact or Coil Searches for a contact or coil corresponds to the selected device. Section 6.1.3
Device Batch Replace Batch-replaces multiple devices. Section 6.1.1
Change Open/Close Contact Replaces an open contact with a close contact, and vice versa. Section 6.1.5

Change Module Start I/O No. Replaces the start module I/O number of the buffer memory address 
instruction. Section 6.1.6

Switch Statement/Note Type Changes the type (PLC/Peripheral) of a statement/note. Section 7.4

Convert/Compile (function for editing in ladder language) Reference
Ladder Conversion Converts a program being edited. Section 8.1
Ladder Conversion (Online Change) Converts a program and writes it online. (Common)

View (function for editing in ladder language) Reference
Comment Displays device comments.

Section 2.2.4Statement Displays statements.
Note Displays notes.
Address Display Displays the device assigned by compilation. Section 2.2.7
Zoom Changes the display magnification of the ladder. Section 2.2.2
Text Size −

Bigger Enlarges the text display size on the editing screen.
Section 2.2.3

Smaller Reduces the text display size on the editing screen.
Open Zoom Source SFC Block Displays the SFC diagram of the Zoom screen. Section 5.2.8
Open Header Opens the setting screen for the label set for a program being edited. Section 5.1.2

Edit (function for editing SFC diagrams) Reference
Undo Restores the previous processing status. −

Review SFC Redisplays the SFC diagram. Section 5.2.7
Insert Row Inserts a row at the cursor position.

Section 5.2.2
Delete Row Deletes a row at the cursor position.
Insert Column Inserts a column at the cursor position.
Delete Column Deletes a column at the cursor position.
Edit Line −

Vertical Line Inserts  at the cursor position.

Section 5.2.2

Selection Divergence Inserts  at the cursor position.

Simultaneous Divergence Inserts  at the cursor position.

Selection Convergence Inserts  at the cursor position.

Simultaneous Convergence Inserts  at the cursor position.
Delete Line Deletes a line at the cursor position.

Find/Replace (function for editing in ladder language) Reference
1.3.3 List of functions for editing SFC diagrams 1 - 11
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SFC Step Attribute −

Normal Sets the step attribute to Normal.

Section 5.2.4

Coil Saving Sets the step attribute to Stored Coil.
Action Saving - with no 
transition check Sets the step attribute to Stored Operation (SE).

Action Saving - with transition 
check Sets the step attribute to Stored Operation (ST).

Reset Resets the step attribute.
SFC Symbol −

Step Inserts  at the cursor position.

Section 5.2.2

Block START Step - with END 
check Inserts  at the cursor position.

Block START Step - with no 
END check Inserts  at the cursor position.

Jump Inserts  at the cursor position.

END Step Inserts  at the cursor position.

Dummy Step Inserts  at the cursor position.

Transition Inserts  at the cursor position.

Selection Divergence Inserts  at the cursor position.

Simultaneous Divergence Inserts  at the cursor position.

Selection Convergence Inserts  at the cursor position.

Simultaneous Convergence Inserts  at the cursor position.

Vertical Line Inserts  at the cursor position.
SFC Step No. Sort Sorts the SFC step/transition numbers. Section 5.2.6
Documentation −

SFC Step/Edit Step Comment Changes to the SFC step/transition comment entry mode. Section 7.6

Find/Replace (function for editing SFC diagrams) Reference
Jump Moves the cursor to the specified position. Section 6.2
Replace SFC Step No. Replaces the SFC step number. Section 6.2.3

View (function for editing SFC diagrams) Reference
SFC Step/Display Step Comment Displays the SFC step/transition comments. Section 2.3.3
Zoom Changes the display magnification ratio of the SFC diagram. Section 2.3.2
Row of SFC Sets the number of row of SFC diagram. Section 2.3.4
Open SFC Block List Displays the SFC block list screen. Section 5.2.10
Open Zoom/START Destination 
SFC Block Displays the Zoom screen or the start destination block. Section 5.2.8

Open START Source SFC Block Displays the SFC block of the start source. Section 5.2.8
Open Header Opens the setting screen of labels set for the program being edited. Section 5.2

Online (function for editing SFC diagrams) Reference
Monitor −

SFC Auto Scroll Monitor Scrolls the screen to display active steps automatically when they are out 
of the screen during monitoring Section 10.5.1

Edit (function for editing SFC diagrams) Reference
1 - 12 1.3.3 List of functions for editing SFC diagrams
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1.3 List of Functions
1.3.4 List of functions for editing SFC block list

The following tables show the functions available for editing SFC block list.
  

1.3.5 List of functions for Structured project

For the functions available for editing in the ST/structured ladder language, refer to the following 
manual.

 GX Works2 Version 1 Operating Manual (Structured Project)

Find/Replace (function for editing SFC block list) Reference
Jump Moves the cursor to the specified block number. Section 6.2.4
Find Device Searches for a device. Section 6.2.5

View (function for editing SFC block list) Reference
Display SFC Block List Comment Displays comments of the SFC block list.

Section 5.2.10
Address Display Displays devices.
Open SFC Opens the SFC diagram.
Open Header Displays the label setting screen.
1.3.4 List of functions for editing SFC block list 1 - 13
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2 SCREEN CONFIGURATION
This chapter explains the screen configuration of GX Works2.
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2 SCREEN CONFIGURATION
GX Works2
2.1 Overview of Screen Configuration

This section explains the main frame (basic screen) of GX Works2 that is displayed when it is started up.
The following shows the configuration of the main frame.

Screen display

Display contents

Name Description Reference
Title bar Displays a project name. −

Menu bar Displays menu options for executing each function. −

Toolbar Displays tool buttons for executing each function. Appendix 1

Work window A main screen used for operations such as programming, 
parameter setting, and monitoring. GX Works2 Version1

Operating Manual 
(Common)Docking window A sub screen to support operations performed on a work 

window. 
Project window Displays contents of a project in tree format.

Function Block Selection window Displays a list of functions (such as function blocks) used for 
programming. Section 5.1.3

Output window Displays compilation and check results (errors and warnings). Section 8.4
Cross Reference window Displays cross reference results.

GX Works2 Version1
Operating Manual 

(Common)

List of Used Device window Displays the device usage list.

Watch window 1 to 4 A screen used for monitoring and changing current device 
values.

Find/Replace window A screen used for searching and replacing character strings in 
the project.

Status bar Displays information about a project being edited.

QCPU

Q

Title bar

Menu bar

Toolbar

Function Block 

Selection window
Project 

window

Status bar

Work 

window

Docking window
2 - 2 2.1 Overview of Screen Configuration
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2.2 Ladder Editor
2.2 Ladder Editor
This section explains the screen display of the GX Works2 ladder editor and its basic operations.

2.2.1 Editing screen

This section explains the editing screen used for creating ladders.

Screen display

Select Project window ⇒ "Program_Pool" ⇒ "(Program file)".

Display contents

Name Description
Title bar Displays a name, status and other information of the open project.
Step number Displays a start step number of the ladder block.
Cursor Data at the cursor position are edited.
Left base line

Base lines of ladder programs.
Right base line

END line Indicates the end of a ladder program.
Programs cannot be created beyond the END line.

QCPU

Q

Title bar

Step number

Left base line Right base line

END line

Cursor
2.1 Overview of Screen Configuration 2 - 3
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GX Works2
2.2.2 Changing display size of editing screen

This section explains the method for changing the display size of the editing screen.

Screen display

Select [View] ⇒ [Zoom] (  ).

Display contents

2.2.3 Changing text size on editing screen

This section explains the method for changing the text size displayed on the editing screen.

Operating procedure

• Select [View] ⇒ [Text Size] ⇒ [Bigger]/[Smaller].
The text size is changed one step at each setting within the range of 10 steps.

Item Description
150%, 100%, 75%, 50% Changes the display size according to the selected zoom ratio.
Specify Changes the display size according to the specified zoom ratio.
Auto Adjusts the width of the ladder automatically to display the entire ladder.

QCPU

Q

QCPU

Q

2 - 4 2.1 Overview of Screen Configuration
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2.2 Ladder Editor
2.2.4 Displaying/hiding comments

This section explains the method for displaying/hiding device comments (label comments), notes, and 
statements.

Operating procedure

• Select [View] ⇒ [Comment]/[Statement]/[Note].

● Displaying/hiding comments
Comments also can be displayed/hidden by the following operation.
Select [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder" ⇒ "Comment".

QCPU

Q

2.1 Overview of Screen Configuration 2 - 5
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GX Works2
2.2.5 Setting number of rows and columns for displaying comments

The following shows the method for setting the number of rows and columns for displaying a device 
comment using the option setting.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder" ⇒ "Comment".

Operating procedure

• Set the items on the screen.

Examples)

2.2.6 Setting number of contacts to be displayed in ladder programs

The following shows the method for setting the number of contacts to be displayed in a single row using 
the option setting.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder" ⇒ "Ladder Diagram".

Operating procedure

• Set the items on the screen.

Item Description
Row Set the number of display rows in the range from 1 to 4 rows.
Column Set the number of display columns to 5 or 8 columns.

Item Description
Display Connection of Ladder 
Diagram Set the number of contacts (9 or 11 contacts) to be displayed in a single row.

QCPU

Q

4 rows × 8 columns 2 rows × 5 columns

QCPU

Q

2 - 6 2.1 Overview of Screen Configuration
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2.2 Ladder Editor
2.2.7 Switching display between label names and devices

The following explains the method for switching the display of a program that uses labels between label 
name display and device display.
If label comments or device comments are set, the corresponding comments are displayed.
Devices assigned by the compilation can be checked by switching the program display from label name 
display to device display.

Operating procedure

• Select [View] ⇒ [Address Display] (  ).
Example)

● Displaying/hiding label comments and device comments
To check the set label comments and device comments, set the setting to display comments. (  Section 2.2.4)

QCPU

Q

Device displayLabel name display
2.1 Overview of Screen Configuration 2 - 7
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GX Works2
2.3 SFC Editor
This section explains the screen display of the SFC editor and its basic operations.

2.3.1 Editing screen

This section explains the editing screen used for creating SFC diagrams.

Screen display

Select Project window ⇒ "Program_Pool" ⇒ "(SFC program file)".

QCPU

Q

Column number

SFC step comment

Row number

Reset destination step number

Jump destination step number

SFC step number

Transition comment

Start destination block number

Transition number
2 - 8 2.1 Overview of Screen Configuration
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2.3 SFC Editor
Display contents

2.3.2 Changing display size of editing screen

This section explains the method for changing the display size of the editing screen.

Screen display

Select [View] ⇒ [Zoom] (  ).

Display contents

Item Description
Row number Displays row numbers in the SFC diagram.
Column number Displays column numbers in the SFC diagram.
SFC step number Displays SFC step numbers for each step.
Transition number Displays transition numbers for each transition.
Start destination block number Displays start destination block numbers for the block start step.
Reset destination step number Displays reset destination step numbers for the reset step.
Jump destination step number Displays jump destination step numbers for the jump step.
SFC step comment Displays comments for each SFC step.
Transition comment Displays comments for each transition.

Item Description
150% 100% 75% 50% Changes the display size according to the selected zoom ratio. 
Specify Changes the display size according to the specified zoom ratio.
Auto Changes the display size according to the specified number of columns.

QCPU

Q

2.1 Overview of Screen Configuration 2 - 9
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GX Works2
2.3.3 Displaying/hiding SFC step/transition comments

This section explains the method for displaying/hiding SFC step/transition comments in the created 
SFC diagram.

Operating procedure

• Select [View] ⇒ [SFC Step/Display Step Comment] (  + ).
Select the menu again to hide SFC step/transition comments.

2.3.4 Setting number of columns for SFC diagram display

This section explains the method for setting the number of divergences that can be edited and 
displayed for the SFC diagram.

Screen display

Select [View] ⇒ [Row of SFC].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The SFC diagram is displayed according to the specified number of columns.

Item Description
Coil Number Enter the number of columns. 

Line Number Displays the number of rows.
The value is changed automatically according to the specified number of columns.

 

2 - 10 2.3.3 Displaying/hiding SFC step/transition comments
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3 PROGRAMMING 
PROCEDURE

This chapter explains the method for creating programs in Simple project.
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3 PROGRAMMING PROCEDURE
GX Works2
3.1 Creating Programs

This section explains the general operating steps from the creation of a program in Simple project to the 
execution of the created program in the programmable controller CPU.

1. Creating a new project

2. Setting parameters

3. Setting labels (when using labels)

4. Editing and converting/compiling programs (for ladder programs)

(To the next page)

Procedure Reference
Start up GX Works2. GX Works2 Version1

Operating Manual
(Common)

Create a new Simple project.
To reuse an existing Simple project, open that Simple project.

Procedure Reference
Set parameters. GX Works2 Version1

Operating Manual
(Common)Check parameters.

Procedure Reference
Define global labels. 

Chapter 4
Define local labels. 

Procedure Reference
Edit ladder programs and convert ladders. Section 5.1
Check programs.

Chapter 8
Compile all programs. (when using labels)

QCPU

Q

3 - 2 3.1 Creating Programs
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3.1 Creating Programs
(From the previous page)

5. Editing and converting/compiling programs (for SFC programs)

6. Connecting a personal computer to the programmable controller CPU

7. Writing data to the programmable controller CPU

8. Checking the operation

9. Ending the project

Procedure Reference
Edit SFC diagrams.

Chapter 5
Edit operation output programs and convert ladders.
Edit transition condition programs and convert ladders.
Set properties of SFC programs and SFC blocks.
Convert SFC diagrams. (when not using labels)

Chapter 8Check programs. (when not using labels)
Compile all programs. (when using labels)

Procedure Reference
Connect a personal computer to the programmable controller CPU. GX Works2 Version1

Operating Manual
(Common)Set the connection target.

Procedure Reference
Write parameters to the programmable controller CPU.

Chapter 9
Write sequence programs to the programmable controller CPU.

Procedure Reference
Monitor the execution status of sequence programs. Chapter 10

Procedure Reference
Save the project. GX Works2 Version1

Operating Manual
(Common)Exit GX Works2.
3.1 Creating Programs 3 - 3
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4 SETTING LABELS
This chapter explains the method for setting labels.
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4 SETTING LABLS
GX Works2
4.1 Label Setting Screens

This section shows label setting screens.
When "Use Labels" is selected on the New Project screen, labels are created as shown below.
Labels are set on each screen according to the type of label.

QCPU

Q

Structured Data Setting screen

Global Label Setting screen

Defines structured data types to be used in the label 

setting. 

Defines labels that can be used for all sequence programs 

in the project.

Function/FB Label Setting screen

Defines labels that can be used only for function blocks in 

the project. 

Local Label Setting screen

Defines labels that can be used only for each specified 

sequence program in the project.

(  Section 4.6.1)

(  Section 4.2)

(  Section 4.4)

(  Section 4.3)
4 - 2 4.1 Label Setting Screens
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4.2 Setting Global Labels
4.2 Setting Global Labels

This section explains the method for setting global labels.

Screen display
Select Project window ⇒ "Global Label" ⇒ "(Global label)".

Operating procedure

• Set the items on the screen.

Item Description Number of 
characters

Class

Select a class name of label from the list displayed by clicking .

−

Label Name Enter a desired label name. 0 to 32 characters

Data Type
Enter the data type of label which can be set on the Type Selection 
screen displayed by clicking . (  Section 4.5.1)

0 to 128 characters

Constant
Displays the constant value of the selected data type.
When "VAR_GLOBAL_CONSTANT" is selected for "Class" and 
simple type is selected for "Data Type", the constant value can be set.

0 to 128 characters

Device

Set a device name to be assigned.
• When "VAR_GLOBAL" is selected for "Class", the cell is left 

blank.
• When the data type is Structure, click the "Detail Setting" cell and 

set devices on the Structured Data Device Setting screen. 
(  Section 4.6.3)

0 to 50 characters

Comment

Enter comments.

A new line can be inserted in a cell by pressing the  + 

 keys.
To display comments on the program editor, select "Device Comment" 
in "Comment Display Items". 
(  Section 2.2.4)

0 to 1024 characters

Remark

Enter supplementary information for comments.

A new line can be inserted in a cell by pressing the  + 

 keys.

0 to 1024 characters

QCPU

Q

Class Description

VAR_GLOBAL A common label that can be used for programs 
and function blocks.

VAR_GLOBAL_
CONSTANT

A common constant that can be used for 
programs and function blocks.
4.2 Setting Global Labels 4 - 3
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4 SETTING LABLS
GX Works2
● Characters that can be used for label names
The maximum number of characters that can be used for a label name is 32.
Note that any of the following label names causes an error at compilation.
• A label name that includes a space.
• A label name that begins with a numeral.
• A label name which is same as the one used for devices.
For characters that cannot be used for label names, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)
● Specifying devices/addresses

The digit specification for bit devices (K4M0) or bit specification for word devices (D0.1) can be specified for 
devices/addresses.
4 - 4 4.2 Setting Global Labels
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4.3 Setting Local Labels for Programs
4.3 Setting Local Labels for Programs

This section explains the method for setting local labels used for each program.

Screen display

Select Project window ⇒ "Program_Pool" ⇒ "(Program)" ⇒ "Labels".

Operating procedure

• Set the items on the screen.

Item Description Number of 
characters

Class

Select a class name of label from the list displayed by clicking .

−

Label Name Enter a desired label name. 0 to 32 characters

Data Type
Enter the data type of label which can be set on the Type Selection 
screen displayed by clicking . (  Section 4.5.1)

0 to 128 characters

Constant
Displays the constant value of the selected data type.
When "VAR_CONSTANT" is selected for "Class" and simple type is 
selected for "Data Type", the constant value can be set.

0 to 128 characters

Device
When the data type is Structure, click the "Detail Setting" cell and set 
devices on the Structured Data Device Setting screen. 
(  Section 4.6.3)

−

Comment

Enter comments.

A new line can be inserted in a cell by pressing the  +  
keys.
To display comments on the program editor, select "Device Comment" 
in "Comment Display Items". 
(  Section 2.2.4)

0 to 1024 characters

QCPU

Q

Class Description

VAR
A label that can be used within the range of 
declared programs.
Cannot be used for other programs.

VAR_ 
CONSTANT

A constant that can be used within the range of 
declared programs.
Cannot be used for other programs.

VAR_RETAIN
A latch type label that can be used within the 
range of declared POUs.
Cannot be used for other POUs.
4.3 Setting Local Labels for Programs 4 - 5
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4 SETTING LABLS
GX Works2
● Assigning devices automatically
Devices are automatically assigned to labels when a program is compiled. The device assignment range can be 
changed on the System Label Setting screen. (  Section 4.7)

● Characters that can be used for label names
The maximum number of characters that can be used for a label name is 32.
Note that any of the following label names causes an error at compilation.
• A label name that includes a space.
• A label name that begins with a numeral.
• A label name which is same as the one used for devices.
For characters that cannot be used for label names, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)
● Confirming devices on the editing screen

The assigned devices can be confirmed by selecting [Address Display]. (  Section 2.2.7)
4 - 6 4.3 Setting Local Labels for Programs
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4.4 Setting Local Labels for Function Blocks
4.4 Setting Local Labels for Function Blocks

This section explains the method for setting local labels for each function block.
Create a new function block in advance.
For the method for creating new function blocks, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)

Screen display

Select Project window ⇒ "FB_Pool" ⇒ "(Function block)" ⇒ "Labels".

Operating procedure
• Set the items on the screen.

Item Description Number of 
characters

Class

Select a class name of label from the list displayed by clicking .

−

Label Name Enter a desired label name. 0 to 32 characters

Data Type
Enter the data type of label which can be set on the Type Selection screen 
displayed by clicking . (  Section 4.5.1)

0 to 128 characters

Constant
Displays the constant value of the selected data type.
When "VAR_CONSTANT" is selected for "Class" and simple type is selected 
for "Data Type", the constant value can be set.

0 to 128 characters

Comment

Enter comments.

A new line can be inserted in a cell by pressing the  +  keys.
To display comments on the program editor, select "Device Comment" in 
"Comment Display Item". (  Section 2.2.4)

0 to 1024 characters

QCPU

Q

Class Description

VAR
A label that can be used within the range of declared 
function blocks.
Cannot be used for other function blocks.

VAR_ 
CONSTANT

A constant that can be used within the range of declared 
function blocks.
Cannot be used for other function blocks.

VAR_INPUT A label that receives a value.
Cannot be changed in a function block.

VAR_OUTPUT A label that outputs data from a function block.

VAR_IN_OUT
A label that receives a value and outputs data from a 
function block.
Can be changed in a function block.

VAR_RETAIN
A latch type label that can be used within the range of 
declared POUs.
Cannot be used for other POUs.
4.4 Setting Local Labels for Function Blocks 4 - 7
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4 SETTING LABLS
GX Works2
● Maximum number of labels
1 to 24 labels can be set for inputs (input variables and I/O variables), and 1 to 24 labels can be set for outputs 
(output variables and I/O variables). The I/O variable is counted as '1 input + 1 output'.

● Assigning devices automatically
Devices are automatically assigned to labels when a program is compiled. The device assignment range can be 
changed on the System Label Setting screen. (  Section 4.7)

● Characters that can be used for label names
The maximum number of characters that can be used for a label name is 32.
Note that any of the following label names causes an error at compilation.
• A label name that includes a space.
• A label name that begins with a numeral.
• A label name which is same as the one used for devices.
For characters that cannot be used for label names, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)
4 - 8 4.4 Setting Local Labels for Function Blocks
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4.5 Common Operations for Setting Labels
4.5 Common Operations for Setting Labels

This section explains the common operations for each label setting screen.

4.5.1 Selecting data types

To define a label, a data type must be specified by directly entering the type in text or selecting it on the 
Type Selection screen.

Screen display

Click  in the data type entry field on each label setting screen.

Operating procedure

1. Select a type in the "Type Class". 

2. In the "Libraries" field, select the reference source such as the defined structure 
that is used as the data type.  

3. In the "Types" field, select the data type, structure or function block name.

4. Click the  button when the setting is completed.
The settings are displayed in the "Data Type" column on the label setting screen.

Item Description
Simple Types Specify this to select a data type from basic types such as bit and word.
Structured Data Types Specify this to select a data type from the defined structures.

Function Blocks Specify this to select a data type from the defined function blocks.
(Not displayed for the FB label settings)

Item Description

<ALL>
Browses data types and structures/function blocks defined in the project, and all libraries.

<Project>

QCPU

Q

4.5 Common Operations for Setting Labels 4 - 9
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4 SETTING LABLS
GX Works2
■ Setting arrays for data type

The following explains the method for defining a data type as an array.
To define a data type as an array, set the items in the "Array Element" field on the Type Selection 
screen.

Operation

1. Click  in the data type entry field on 
each label setting screen.

2. Check the check box in the "Array 
Element" field.

3. Enter the number of elements in the 
"Element" field.

4. Set the data type of the array element in 
the same manner as setting the normal 
data type.

● To change the offset
To change the offset ([Array start value]..[Array end value]) to a value other than 0, edit the offset 
value by directly entering the array type declaration in text on each label setting screen.

● To change the array to a two- or three-dimensional array
Edit two- or three-dimensional array by directly entering the array type declaration in text on each 
label setting screen.

● Method for displaying the Type Selection screen
The Type Selection screen can be opened by any of the following operations when  is in the selected status.

• Press the  key.

• Press the  key.

• Press the  key.
4 - 10 4.5.1 Selecting data types
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4.5 Common Operations for Setting Labels
■ Setting data length of character string data type

The following explains the method for setting the data length of the character string data type.
To change the data length of the character string data type, directly edit the data length on each label 
setting screen.
The data length of the character string data type is set in the option setting.

Operation

• Select [Tools] ⇒ [Options] ⇒ "Label Setting Editor" ⇒ "Default Length of String Date Type", 
and set the data length. 

● When a constant type is set for Class
For labels whose classes are set as VAR_CONSTANT or VAR_GLOBAL_CONSTANT, arrays cannot be set for the 
data type. If they are set, an error occurs at compilation.

● Offset values
Minus values can be set for offset values.
4.5.1 Selecting data types 4 - 11
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4 SETTING LABLS
GX Works2
4.5.2 Editing lines

This section explains the method for editing lines on the label setting screen.

■ Adding lines

The following explains the method for adding a line on the label setting screen.
● New Declaration (Before)

This function inserts a line above the selected line.

Operation

• Select [Edit] ⇒ [New Declaration (Before)] (  ).

● New Declaration (After)
This function inserts a line below the selected line.

Operation

• Select [Edit] ⇒ [New Declaration (After)] (  ).

■ Deleting lines

The following shows the method for deleting a line on the label setting screen.

Operation

• Select [Edit] ⇒ [Delete Line].

● Adding lines
When using the New Declaration (After) function, label names, data types or other attributes can be set 
automatically to the added lines.
Select [Tools] ⇒ [Option] ⇒ "Label Setting Editor".
4 - 12 4.5.2 Editing lines
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4.5 Common Operations for Setting Labels
■ Displaying comments and remarks of the first line only or all lines

For the "Comment" and "Remark" columns, data can be entered in multiple lines. The expand 
declaration and collapse declaration functions are provided to select whether to display all lines or only 
the first line by double clicking " + " or " - ".

■ Selecting all lines

All lines can be selected by the following operation.

Operation

• Select [Edit] ⇒ [Select All].

All lines are displayed.

Only the first line is displayed.
4.5.2 Editing lines 4 - 13
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4 SETTING LABLS
GX Works2
4.6 Setting Structured Data Type Labels

This section explains the method for setting structured data type labels.

4.6.1 Setting data type of structure

Set the elements of the structure on the Structured Data Setting screen.

Screen display

Select Project window ⇒ "Structured Data Types" ⇒ "(Structure)".

Operating procedure

• Set the items on the screen.

Item Description Number of 
characters

Label Name Enter a desired label name. 0 to 32 characters

Data Type
Enter the data type of label which can be set on the Type Selection 
screen displayed by clicking . (  Section 4.5.1)

0 to 128 characters

Constant Displays the constant value of the selected type. 0 to 128 characters

Comment

Enter comments.

A new line can be inserted in a cell by pressing the  +  
keys.
To display comments on the program editor, select "Device Comment" 
in "Comment Display Item". (  Section 2.2.4)

0 to 1024 characters

● Creating new structured data
Create structured data using the Project window.
(  GX Works2 Version1 Operation Manual (Common))

QCPU

Q

4 - 14 4.6 Setting Structured Data Type Labels
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4.6 Setting Structured Data Type Labels
4.6.2 Setting data type as structure

To define the data type of label as a structure, set a structure in the data type entry field on each label 
setting screen. In addition to direct text entry, a structure can be selected on the Type Selection screen 
(  Section 4.5.1).

4.6.3 Assigning devices to structured data type labels

Devices of the structured data type global labels are set on the Structured Data Device Setting screen.
If the structure is set for data type on the Global Label Setting screen, "Detail Setting" is displayed in the 
"Device" column. Click "Detail Setting" to display the Structured Data Device Setting screen.

Screen display

Click "Detail Setting" on the label setting screen.

Operating procedure

• Set the items on the screen.

Item Description
Label Name Displays label names defined as structure.
Data Type Displays data types set to data names.
Device Set device names to be assigned.

Automatic Filling Check this to set devices automatically to cells in which devices are not set with the 
same data type.

Use Bit Designation Check this to enter bit devices automatically by using bit specification for word 
devices.

● Display on the Local Label Setting screen
For the Structured Data Device Setting screen, the read-only screen is displayed.
4.6.2 Setting data type as structure 4 - 15
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■ Entering device names automatically

The Automatic filling function can be used when setting series of devices for the same data type data 
on the Structured Data Device Setting screen.
When using the Automatic filling function, whether to use bit specification for word devices can be 
selected.

Operation

1. Click "Detail Setting" on the label setting screen.
The Structured Data Device Setting screen is displayed.

2. Enter the device name to the "Device" column.
Series of devices are automatically set in the cells following the one entered, skipping the 
cells where devices are already set.

● When using bit specification

● When not using bit specification

● When not using bit specification
When the bit specification is not used, uncheck the "Use Bit Designation" item on the Structured Data Device 
Setting screen.

Enter "D1"

Automatically 

set data

Enter "D1"

Automatically 

set data
4 - 16 4.6.3 Assigning devices to structured data type labels
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4.6 Setting Structured Data Type Labels
4.6.4 Assigning devices to structured array type labels

This section explains the method for setting the devices for structured array type global labels on the 
Structured Data Device Setting screen.
When VAR_GLOBAL is set for "Class" and the structured array is set for "Data Type" on the Global 
Label Setting screen, "Detail Setting" is displayed in the "Device" column. Click "Detail Setting" to 
display the Structured Data Device Setting screen.

Screen display

Click "Detail Setting" on the label setting screen.

Operating procedure

• Set the items on the screen.

Item Description

Structured Data Array
Displays elements of the structured array in tree format.
The device setting of the element selected in the tree is displayed in the right 
area of the screen.

Label Name Displays label names defined as structure.
Data Type Displays data types set to data names.

Device

Set device names to be assigned.
Device names can be entered for the start array element only.
For the subsequent array elements, device names offset from the device number 
set for the start element are automatically set.

Offset Value

Word Device/Bit 
Device

Specify the device offset value to be set to the same data type cells in the array 
element.

Use Bit 
Designation

Check this to enter bit devices automatically by using bit specification for word 
devices.

● Display on the Local Label Setting screen
For the Structured Data Device Setting screen, the read-only screen is displayed.
4.6.4 Assigning devices to structured array type labels 4 - 17
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■ Entering device names automatically by setting offset values

On the Structured Data Device Setting screen, device numbers to be entered automatically can be set 
in fixed spacing for each array element of the structured array. Specify the difference in device numbers 
between the array elements as an offset value for the start device of the same data type.

Operation

1. Click "Detail Setting" on the label setting screen.
The Structured Data Device Setting screen is displayed.

2. Set the "Offset Value".

3. Set the device name for the start element data of the array.
Devices are set to the same data type of the array elements in the screen.

 

Enter "D1"

Offset value is not specified.

<Array [1]>

<Array [0]>

Devices starting  

from "D7" are  

assigned.

Enter "D1"

Offset value is 10.

<Array [1]>

<Array [0]>

Devices starting 

from "D11" are 

assigned.
4 - 18 4.6.4 Assigning devices to structured array type labels
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4.6 Setting Structured Data Type Labels
● Using bit specification
Devices can be set using the bit specification for word devices when entering devices 
automatically.

Operation

1. Click "Detail Setting" on the label setting screen.
The Structured Data Device Setting screen is displayed.

2. Check the "Use Bit Designation" item.

3. Set the device name for the start element data of the array.
Devices are set to the same data type or bit device data type.

● Data for which device name can be entered
For the structured array type, a device name can be entered only for the start element of array.
For the subsequent array elements, device names offset from the device number set for the start element are 
automatically set.

● Offset values
• An expression such as '1\2' can be specified for an incremental value of device such as U0\G0.
• When 0 is specified for the incremental value, the device number same as the data set to the start of devices is 

set to all data in the array.
4.6.4 Assigning devices to structured array type labels 4 - 19
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4 - 20 4.7 Setting Ranges for Devices Assigned Automatically

4 SETTING LABLS
GX Works2

4.7 Setting Ranges for Devices Assigned Automatically

This section explains the method for setting the ranges for devices that are automatically assigned to local 
labels.

Screen display

Select [Tools] ⇒ [System Label Setting].

Operating procedure

• Select the device type, and set the start and end addresses to be assigned.

● Device types
The types of automatically assigned devices differ by the type of CPU.

● Setting ranges
The setting ranges depend on the number of device points set in PLC parameter.
For details of PLC parameter, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)
● Assigning devices automatically

Word devices, bit devices, and timer/counter devices are automatically assigned in the order from larger device 
number within the device range set on the System Label Setting screen.

● Confirming devices on the editing screen
The assigned devices can be confirmed by selecting [Address Display]. (  Section 2.2.7)

QCPU

Q
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5 EDITING PROGRAMS
This chapter explains the functions of the program editor for editing sequence programs.
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5 EDITING PROGRAMS
GX Works2
5.1 Editing Ladder Programs
This section explains the methods for operating the ladder editor.

5.1.1 Creating ladders

This section explains the method for creating ladders and related functions.

■ Overwrite mode and insert mode

When creating ladders, either 'Overwrite mode' or 'Insert mode' can be selected. Select the appropriate 
mode for the operation.
The operation procedures in this chapter are explained under the 'Overwrite mode' as the basic setting.

Operating procedure

• Press the  key.
The mode switches alternately between 'Overwrite' and 'Insert' each time the key is pressed. The 
color of the cursor on the editing screen changes according to the active mode.

● In the 'Overwrite mode', contacts, coils, or application instructions newly input at the cursor 
position overwrite the existing ones.

Example) Changing X20 to a horizontal line in the 'Overwrite mode'.

QCPU

Q

Cursor position
5 - 2 5.1.1 Creating ladders
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5.1 Editing Ladder Programs
In the 'Insert mode', contacts, coils, or application instructions newly input at the cursor position are 
inserted in front of the cursor.
Example) Inserting X15 in front of X20 in the 'Insert mode'.

Cursor position
5.1.1 Creating ladders 5 - 3
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5 EDITING PROGRAMS
GX Works2
■ Instruction help

The following explains the help function that supports entering ladder symbols. The help function can 
be used on the ladder editor only.

Operating procedure

1. Click the  button on the Enter 
Symbol screen.
The <<Instruction Selection>> tab on the 
Instruction Help screen is displayed.

2. Select the instruction type in the "Type 
List".
The instructions of the selected type are 
displayed in the "Instruction List".
(For details of the <<Find Instruction>> tab, refer to 
the Point.)

3. Select an instruction from the "Instruction 
List".
The information of the selected instruction 
is displayed in the instruction detail field.

4. Click the  button.
The Detail Instruction Help screen is 
displayed.

5. Set the items on the screen.

6. Click the  button on the Detail Instruction Help screen.
The instruction is entered at the cursor position.

Item Description

Pulse Form Check this item to convert the 
instruction into pulse.

Input 
Device

Enter devices.
Indication of the symbols:
" * ": Settable
" - ": Not settable

Instruction

detail
5 - 4 5.1.1 Creating ladders
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5.1 Editing Ladder Programs
● Instruction help function
The Instruction help function has the <<Instruction Selection>> and <<Find Instruction>> tabs.
The <<Instruction Selection>> tab is displayed when no instruction is entered in the device instruction entry field, 
and the <<Find Instruction>> tab is displayed when an instruction is entered in the device instruction entry field.

● Instruction retrieval function
If the instruction is entered incompletely or the entered instruction is not supported, the <<Find Instruction>> tab is 
displayed on the Instruction Help screen when the "Display Instruction Help at symbol error occurrence" item is 
checked in the option setting.
If the starting characters of the instructions match with the entered characters, the corresponding instructions are 
displayed in the "Corresponding Instruction" field.
Search method can be switched by clicking the  or  buttons.
Option settings (  Section 11.2)
5.1.1 Creating ladders 5 - 5
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5 EDITING PROGRAMS
GX Works2
5.1.2 Entering contacts, coils, and application instructions

This section explains the method for entering contacts, coils, and application instructions.
Contacts, coils, and application instructions are entered by using the Enter Symbol screen.

Operating procedure

1. Move the cursor to the position where a ladder symbol is entered.

2. Select [Edit] ⇒ [Ladder Symbol] ⇒ [(Ladder symbol)].
The Enter Symbol screen is displayed.

The following table shows the display contents of the screen.

Item Toolbar Shortcut key

Ladder 
Symbol

Open Contact

Open Branch  + 

Close Contact

Close Branch  + 

Coil

Application Instruction

Rising Pulse  + 

Falling Pulse  + 

Rising Pulse Branch  + 

Falling Pulse Branch  + 

Operation Result Rising Pulse  + 

Operation Result Falling Pulse  +  + 

Invert Operation Results  +  + 

Name Description

Consecutive entry icon
Allows consecutive entry of ladder symbols by changing the status.

 Consecutive entry ON  Consecutive entry OFF

Ladder symbol selection 
field

Allows changing the setting of ladder symbols.

Clicking the  button displays the list of ladder symbols.
Device instruction entry field Enter a device and/or instruction.

QCPU

Q

Consecutive entry icon Device instruction entry field

Ladder symbol selection field
5 - 6 5.1.2 Entering contacts, coils, and application instructions
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5.1 Editing Ladder Programs
3. Enter a device and/or instruction.

4. Click the  button.
The entered ladder symbol is displayed on the editing screen.

● Allowable number of lines for creating ladders
• The maximum number of lines that can be used for one ladder block is 24 lines.
• The maximum number of lines that can be processed in a single ladder conversion operation is 48 lines.

Perform ladder conversion appropriately during editing so that the number of ladder lines that has not been 
converted does not exceed over 48 lines.

● Wrapping a row
The maximum number of contacts that can be created in a single row is 11 contacts + 1 coil or 9 contacts + 1 coil 
(varies depending on the option setting).
If this limit is exceeded, the wrapping source symbol ( ) and the wrapping destination symbol ( ) are 
automatically created and the ladder is wrapped.
The same numbers (serial numbers) are assigned to the wrapping source symbol ( ) and the wrapping 
destination symbol ( ) that are created in pairs.

● Changing the cursor position on the editing screen while the Enter Symbol screen is displayed

Use the  key +     keys to change the cursor position on the editing screen.

● Displaying the Instruction Help screen at the occurrence of ladder symbol entry error
The Instruction Help screen can be displayed automatically by the following setting.
Select [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder" ⇒ "Ladder Diagram", and check the "Display 
Instruction Help at symbol error occurrence" item.

Wrapping source symbol (->)

Wrapping destination symbol (>-)

 +Ctrl
5.1.2 Entering contacts, coils, and application instructions 5 - 7
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5 EDITING PROGRAMS
GX Works2
■ Selecting the duplicated coil check function

The following explains the method for selecting whether the duplicated-coil check function is used by 
the option setting.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder" ⇒ "Device".

Operating procedure

• Check the "Check double coil" item.
When a coil is entered, duplicated coils are checked for the converted ladder.

Table 5.1.2-1 Duplicated coil check availability

: Available  ×: Not available

Device
Instruction

DELTA EGP
EGF FF MC OUT SET SFT PLS PLF

Q series

Y, M, L, B, F, SM, SB × ×

D, SD, W, SW, R, ZR × ×

DY ×

T, C × × × × × × × ×

V × × × × × × × ×

BL × × × × × × × ×
5 - 8 5.1.2 Entering contacts, coils, and application instructions
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5.1 Editing Ladder Programs
■ Entering device comments

The following explains the method for entering a device comment following the entry of a contact, coil, 
or application instruction.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder" ⇒ "Device".

Operating procedure

• Check the "Enter device comment" item.

 The Input Device Comment screen is displayed by clicking the  button after entering a contact, coil 
or application instruction.

For the method for entering device comments, refer to the following manual.
 GX Works2 Version1 Operating Manual (Common) 
5.1.2 Entering contacts, coils, and application instructions 5 - 9
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5 EDITING PROGRAMS
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■ Entering pointer numbers and interrupt pointer numbers

The following explains the method for entering a pointer number or an interrupt pointer number.
Pointer numbers or interrupt pointer numbers are entered by using the Enter Symbol screen.

Operating procedure

1. Move the cursor to the position where a pointer number or an interrupt pointer 
number is entered.
Enter a pointer number or an interrupt pointer number at the position where a step number is 
displayed.

2. Press the  key.
The Enter Symbol screen is displayed.

3. Enter a pointer number or an interrupt pointer number.

4. Click the  button.
The entered pointer number or interrupt pointer number is displayed on the editing screen.
5 - 10 5.1.2 Entering contacts, coils, and application instructions
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5.1 Editing Ladder Programs
■ Opening label setting screen for the program being edited

The following explains the method for opening the label setting screen for the program being edited.

Operating procedure

• Select [View] ⇒ [Open Header].

■ Creating wrapping rows

Wrapping symbols are automatically created if wrapping of a row is required when creating a ladder 
block. However, wrapping symbols can be entered manually as desired. The following explains the 
method for wrapping rows by manually entering wrapping symbols.

Operating procedure

1. Move the cursor to the position where a wrapping source symbol ( ) is entered.
When entering a wrapping source symbol ( ), move the cursor to the second or subsequent 
columns.

2. Select [Edit] ⇒ [Ladder Symbol] ⇒ [Horizontal Line] ( ).
The Enter Horizontal Line screen is displayed.

3. Enter 'K (+ desired number)'.
5.1.2 Entering contacts, coils, and application instructions 5 - 11
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5 EDITING PROGRAMS
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4. Click the  button.
The wrapping source symbol ( ) is entered and the row is wrapped.

5. Move the cursor to the position where a wrapping destination symbol ( ) is 
entered.
When entering a wrapping destination symbol ( ), move the cursor to the first column.

6. Select [Edit] ⇒ [Ladder Symbol] ⇒ [Horizontal Line] ( ).
The Enter Horizontal Line screen is displayed.

7. Enter 'K (+ number input in step 3)'.
A wrapping source symbol ( ) and a wrapping destination symbol ( ) are used in pairs for 
wrapping symbols.
Enter the same number for the paired wrapping symbols.

8. Click the  button.
The wrapping destination symbol ( ) is entered.

● Changing the number of contacts displayed in a ladder program
The number of contacts displayed in a single row can be changed to 9 contacts or 11 contacts. 
(  Section 2.2.6)

Wrapping source symbol (->)

Wrapping destination symbol (>-)
5 - 12 5.1.2 Entering contacts, coils, and application instructions
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5.1 Editing Ladder Programs
5.1.3 Using function blocks

This section explains the method for utilizing function blocks as components in sequence programs.
To use function blocks, select "Use Labels" when creating a new project.

■ Creating function blocks

The following explains the method for creating a function block.

Operating procedure

1. Create a new function block.
For the procedure for adding new data in a project, refer to the following manual.

GX Works2 Version1 Operating Manual (Common)

The function block program file and the function block label setting file are added to the project.

2. Set the function block label.
The created function block can be used as a component.
(  Section 4.4)

3. Edit the function block ladder.
The same procedure as for creating a ladder can be used to edit a function block ladder.
Created function blocks are displayed in the Function Block Selection window and can be used as 
function blocks.

QCPU

Q

Function/FB label 

setting file

Function block program file
5.1.3 Using function blocks 5 - 13
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■ Pasting function blocks to sequence programs

The following explains the method for pasting a function block to the sequence program.

Operating procedure

1. Select a function block from the Function Block Selection window and locate it to 
the pasting position using the drag and drop operation.
The Input FB Instance Name screen is displayed.

2. Select the registering destination of the function block to be pasted from the local 
or global label. 
In the sequence program, the function block is automatically entered to the selected label. 

3. Enter the FB instance name.
In the sequence program, the entered FB instance name is automatically entered to "Label Name".

Drag and drop
5 - 14 5.1.3 Using function blocks
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5.1 Editing Ladder Programs
4. Click the  button.
The function block is pasted on the editing screen.

● Pasting function blocks
The following methods can also be used to paste function blocks.
• On the editing screen, move the cursor to the pasting position and double click the function block on the 

Function Block Selection window.
• On the editing screen, move the cursor to the pasting position and select a function block on the Function Block 

Selection window, and press the  key.
● Display of pasted function blocks

In the pasted function block, label names of I/O variables and their corresponding data types are displayed.

The followings are the representation of data types.
• B: Bit
• W: Word (signed)
• D: Double word (signed)
• E: Single-precision real
• L: Double-precision real
• S: String

Data type
Label name

Data type
Label name

FB instance name
5.1.3 Using function blocks 5 - 15
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■ Creating input and output ladder parts of function blocks

The following explains the method for creating input and output ladder parts of a function block.

Operating procedure

1. Move the cursor to the position where an 
input ladder part is created.

2. Enter the ladder symbol of the input 
ladder part.
Enter the ladder symbols in the same 
manner as creating ladders.
Create the ladder meeting the data type of 
input variable.

3. Enter the output ladder part in the 
same manner as entering the input 
ladder part.

If the data type of input variable is not a bit 
type, enter the device directly on the Enter 
Symbol screen

Input ladder part Output ladder part

<Bit type>

<Other than bit type>
5 - 16 5.1.3 Using function blocks
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5.1 Editing Ladder Programs
■ Changing FB instance names of pasted function blocks

The following explains the method for changing a FB instance name of the pasted function block.

Operating procedure

1. Move the cursor to the function block whose FB instance name is to be changed.

2. Select [Edit] ⇒ [Edit FB Instance].
The Enter FB Instance Name screen is displayed. 
The current FB instance name is displayed in the entry field.

3. Enter a new FB instance name.

4. Click the  button.
The function block is displayed on the editing screen with the changed FB instance name.

● Changing FB instance of the same name 
When the same FB instance name is set to the FB instances created from the same function block, changing one 
of the FB instance name causes to change all FB instances of the same name in the program. However, note that 
FB instance names are case-sensitive.

FB instance name

FB instance name
5.1.3 Using function blocks 5 - 17
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■ Precautions on using function blocks

The following explains the precautions on using function blocks.

1) One function block can be pasted to a single ladder block.
When connecting function blocks, use a coil to initially receive the function block outputs.
Paste the function block to be connected to another ladder block and connect it with the input.

2) The wrapping rows cannot be created in the input and output ladder parts.
Insert a coil to receive the output and use the contact of the coil as the target instruction condition.

3) The device type of the input or output ladder part of the function block, and the device type of the 
contact/coil/application instruction to be connected must be the same.
Using different device types at the connection causes an error at compilation.
The followings are the six device types for function blocks.
• Bit: Data expressed by ON/OFF
• Word (signed): Data expressed in 16 bits
• Double word (signed): Data expressed in 32 bits
• Single-precision real: Floating-point data expressed in 32 bits
• Double-precision real: Floating-point data expressed in 64 bits
• String: Character string data expressed in ASCII code

● Checking duplicated coils in the ladder programs 
When the same devices are used in the source ladder program and the target function block, and "Check double 
coil" is selected under "Program Editor" ⇒ "Ladder" ⇒ "Device" in the option setting, the duplicated coils are not 
detected. Check the duplicated coils in the source ladder program and the target function block by the Cross 
reference function.
For the projects without labels, the duplicated coils can be checked by unchecking the item in "Execution of 
Program Check" under [Tools] ⇒ [Options] ⇒ "Compile" ⇒ "Basic Setting".
5 - 18 5.1.3 Using function blocks
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5.1 Editing Ladder Programs
5.1.4 Drawing lines

This section explains the method for drawing lines.

■ Drawing lines

The following explains the method for drawing vertical and horizontal lines consecutively.

Operating procedure

1. Move the cursor to the position where a vertical line is drawn.
A line is drawn taking the left edge of the cursor as a base point.

2. Select [Edit] ⇒ [Edit Line] ( ).

3. Drag the cursor in the line drawing direction.

4. The line is drawn upon completion of dragging.

5. To end the line drawing function, select [Edit] ⇒ [Edit Line] ( ) again.
The edit line mode is disabled.

Item Toolbar Shortcut key

Edit Line

Vertical Line  + 

Horizontal Line

QCPU

Q

Drag
5.1.4 Drawing lines 5 - 19
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■ Entering vertical or horizontal lines

The following explains the method for entering a vertical or horizontal line.

Operating procedure

1. Move the cursor to the position where a vertical or horizontal line is entered.
A vertical line is entered taking the left edge of the cursor as a base point.

2. Select [Edit] ⇒ [Ladder Symbol] ⇒ [Vertical Line] ( ).
The Enter Vertical Line screen is displayed.
To enter a horizontal line, select [Edit] ⇒ [Ladder Symbol] ⇒ [Horizontal Line] ( ).

3. Set the items on the screen.

4. Click the  button.
The entered vertical line or horizontal line is displayed on the editing screen.

Name Description

Consecutive entry icon
Allows consecutive entry of vertical or horizontal lines by changing the status.

 Consecutive entry ON  Consecutive entry OFF
Number of rows or columns 
entry field

Enter the number of rows or columns to be entered.
If no value is entered, one row of vertical line or one column of horizontal line is entered.

● Changing the cursor position on the editing screen while the Enter Vertical Line or Enter Horizontal Line 
screen is displayed

Use the  key +     keys to change the cursor position on the editing screen.

Consecutive entry

icon

Number of rows or columns 

entry field

+Ctrl
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5.1 Editing Ladder Programs
5.1.5 Deleting contacts, coils, and application instructions

This section explains the method for deleting contacts, coils, and application instructions.

■ Deleting contacts, coils, and application instructions in unit of instruction

The following explains the method for deleting a contact, coil or application instruction in unit of 
instruction.

Operating procedure

1. Move the cursor to the position where the instruction is deleted.

2. Press the  key.
The instruction is deleted.

● Deletion in the 'Insert mode'
If the instruction is deleted in the 'Insert mode', the instructions that follow the deleted instruction are 
shifted forward.
With wrapping lines, the instructions are shifted when the ladder is converted.

QCPU

Q
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■ Deleting contacts, coils, and application instructions by setting a range

The following explains the method for deleting contacts, coils, and/or application instructions by setting 
a range.

Operating procedure

1. Set the range by dragging the cursor from the start position of deletion.

2. Press the  key.
The instructions in the set range are deleted.

● The range can be set by pressing the  key +     key.

Drag

+Shift
5 - 22 5.1.5 Deleting contacts, coils, and application instructions
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5.1 Editing Ladder Programs
■ Deleting a ladder block

The following explains the method for deleting one ladder block at a time.

Operating procedure

1. Place the cursor at the start position of deletion and drag it up or down to set the 
range.
Specify the range of a ladder block at the position where step numbers are displayed.

2. Press the  key.
The ladder block is deleted.

Restrictions

This operation is applicable only to the converted data.

Drag
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5.1.6 Deleting lines

This section explains the method for deleting lines.

■ Deleting lines

The following explains the method for deleting vertical and horizontal lines consecutively.

Operating procedure

1. Move the cursor to the position where the lines are deleted.
The vertical line is deleted taking the left edge of the cursor as a base point.

2. Select [Edit] ⇒ [Delete Line] ( ).

3. Drag the cursor in the direction for line deletion.
The selected lines are displayed in yellow.

4. The lines are deleted upon completion of dragging.

5. To end the Delete Line function, select [Edit] ⇒ [Delete Line] ( ) again.
The line deletion mode is disabled.

Item Toolbar Shortcut key

Delete Line  + 

Delete Vertical Line  + 

Delete Horizontal Line  + 

QCPU

Q

Drag
5 - 24 5.1.6 Deleting lines
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5.1 Editing Ladder Programs
■ Deleting vertical or horizontal lines

The following explains the method for deleting a vertical or horizontal line.

Operating procedure

1. Move the cursor to the start of the vertical or horizontal line to be deleted.
The vertical line is deleted taking the left edge of the cursor as a base point.

2. Select [Edit] ⇒ [Ladder Symbol] ⇒ [Delete Vertical Line] ( ).
The Delete Vertical Line screen is displayed.
To delete a horizontal line, select [Edit] ⇒ [Ladder Symbol] ⇒ [Delete Horizontal Line] ( ).

3. Set the items on the screen.

4. Click the  button.
Vertical lines are deleted.

Name Description

Consecutive entry icon
Allows consecutive deletion of vertical lines by changing the status.

 Consecutive entry ON  Consecutive entry OFF
Number of rows or columns 
entry field

Enter the number of rows or columns to be deleted.
If no value is entered, one row of vertical line or one column of horizontal line is deleted.

Consecutive entry 

icon

Number of rows 

or columns entry field
5.1.6 Deleting lines 5 - 25

C P



5 EDITING PROGRAMS
GX Works2
● Changing the cursor position on the editing screen while the Delete Vertical Line screen or Delete 
Horizontal Line screen is displayed

Use the  key +     keys to change the cursor position on the editing screen.

Ctrl +
5 - 26 5.1.6 Deleting lines
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5.1 Editing Ladder Programs
5.1.7 Inserting and deleting rows and columns

This section explains the method for inserting and deleting rows and columns.

■ Inserting rows

The following explains the method for inserting rows.

Operating procedure

1. Move the cursor to the position where a row is inserted.

2. To insert multiple rows, drag the cursor and set the range corresponding to the 
number of rows to be inserted.
The rows in the set range are inserted.
To insert a single row, it is not necessary to set the range.
In the screen image below, the range for inserting three rows is set.

Item Shortcut key

Insert Row  + 

Delete Row  + 

Insert Column  + 

Delete Column  + 

QCPU

Q

Drag
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3. Select [Edit] ⇒ [Insert Row].
A space is inserted above the cursor position.
The screen image below shows insertion of a space for three rows.

■ Deleting rows

The following explains the method for deleting rows.

Operating procedure

1. Move the cursor to the position where the row is deleted.

2. To delete multiple rows, drag the cursor and set the range corresponding to the 
number of rows to be deleted.
The rows in the set range are deleted.
To delete a single row, it is not necessary to set the range. The row at the cursor position is 
deleted.

Drag
5 - 28 5.1.7 Inserting and deleting rows and columns
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5.1 Editing Ladder Programs
3. Select [Edit] ⇒ [Delete Row].
The rows are deleted.

■ Inserting columns

The following explains the method for inserting columns. Columns are inserted through the whole rows 
of ladder block.

Operating procedure

1. Move the cursor to the position where a column is inserted.
A column is inserted in front of the cursor position.

2. To insert multiple columns, drag the cursor and set the range corresponding to the 
number of columns to be inserted.
The columns in the set range are inserted.
In the screen image below, the range for inserting three columns is set.

3. Select [Edit] ⇒ [Insert Column].
The columns are inserted. The screen image below shows the insertion of three columns.

Drag
5.1.7 Inserting and deleting rows and columns 5 - 29
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■ Deleting columns

The following explains the method for deleting columns. Columns are deleted within the ladder block.

Operating procedure

1. Move the cursor to the position where the column is deleted.

2. To delete multiple columns, drag the cursor to set the range corresponding to the 
number of columns to be deleted.
The columns in the set range are deleted.
To delete a single column, it is not necessary to set the range. The column at the cursor position is 
deleted.

3. Select [Edit] ⇒ [Delete Column].
The columns are deleted. The screen image below shows the deletion of three columns.

Drag
5 - 30 5.1.7 Inserting and deleting rows and columns
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5.1 Editing Ladder Programs
5.1.8 Batch inserting and deleting NOP instructions

This section explains the method for batch inserting and deleting NOP instructions.

■ Batch inserting NOP instructions

Step numbers of the program can be adjusted by batch inserting NOP instructions.

Operating procedure

1. Move the cursor to the position where NOP instructions are inserted.
NOP instructions are inserted in front of the cursor position.

2. Select [Edit] ⇒ [NOP Batch Insert].
The NOP Batch Insert screen is displayed.

3. Set the items on the screen.S

4. Click the  button.
The set number of NOP instructions is inserted in the program.

Restrictions

This operation is applicable only to the converted data.

Item Description
Number of Insert NOPs Set the number of NOP instructions to be inserted.
Maximum Number of Insert 
NOPs Displays the maximum number of NOP instructions that can be inserted.

QCPU

Q

The step number 

is changed.
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■ Batch deleting NOP instructions

The following explains the method for batch deleting NOP instructions in the program.

Operating procedure

1. Select [Edit] ⇒ [NOP Batch Delete].
The confirmation message is displayed.

2. Click the  button.
All NOP instructions in the program are deleted.

The step number 

is changed.
5 - 32 5.1.8 Batch inserting and deleting NOP instructions
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5.1 Editing Ladder Programs
5.1.9 Cutting, copying, and pasting ladders

This section explains the method for cutting, copying, and pasting existing ladders.

■ Pasting the cut or copied ladders in unit of instruction

The following explains the method for pasting a cut or copied ladder in unit of instruction.

Operating procedure

1. Move the cursor to the position where the instruction is cut or copied.

2. Select [Edit] ⇒ [Cut] ( ) or [Copy] ( ).
When [Cut] ( ) is selected, the instruction at the cursor position is deleted.

3. Move the cursor to the position where the cut or copied instruction is pasted.

Item Toolbar Shortcut key

Cut  + 

Copy  + 

Paste  + 

Restrictions

Cutting and copying in unit of instruction are applicable to contacts, coils, application instructions, device 
comments, and notes. Cutting and copying are not applicable to line statements, P and I statements, and 
END instructions.

QCPU

Q
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4. Select [Edit] ⇒ [Paste] ( ).
The instruction is pasted.

● Pasting in the 'Insert mode'
A row is inserted at the cursor position and the instruction is pasted there.

Pasting position
5 - 34 5.1.9 Cutting, copying, and pasting ladders
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5.1 Editing Ladder Programs
■ Pasting cut or copied ladders by setting a range

The following explains the method for pasting cut or copied ladders by setting a range.

Operating procedure

1. Set the range by dragging the cursor from the start position of cut or copy.

2. Select [Edit] ⇒ [Cut] ( ) or [Copy] ( ).
When [Cut] ( ) is selected, the ladders in the set range are deleted.

3. Move the cursor to the position where the cut or copied ladders are pasted.

4. Select [Edit] ⇒ [Paste] ( ).
The ladders are pasted.

Drag
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■ Pasting cut or copied ladder block

The following explains the method for pasting a cut or copied ladder block.

Operating procedure

1. Set the range by dragging the cursor up or down from the start position of cut or 
copy.
Specify the range of a ladder block at the position where step numbers are displayed.

2. Select [Edit] ⇒ [Cut] ( ) or [Copy] ( ).

When [Cut] ( ) is selected, the ladder block in the set range is deleted.

3. Move the cursor to the position where the cut or copied ladder block is pasted.

Restrictions

This operation is applicable only to the converted data.

Drag
5 - 36 5.1.9 Cutting, copying, and pasting ladders
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5.1 Editing Ladder Programs
4. Select [Edit] ⇒ [Paste] ( ).
The ladder block is pasted.
5.1.9 Cutting, copying, and pasting ladders 5 - 37
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● The range can be set by pressing the  key +     key.

● Pasting in the 'Insert mode'
The ladder block is inserted above the cursor position.

● If the ladders shown below are selected by setting a range, the vertical line on the right side cannot be 
copied or pasted.

In such a case, set the range as shown below to copy or paste the ladders.

+Shift

[Cut] or [Copy]

Pasting position

[Paste]

Vertical line on the right side 

is not pasted.
5 - 38 5.1.9 Cutting, copying, and pasting ladders
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5.1 Editing Ladder Programs
5.1.10 Canceling the previous operation

This section explains the method for canceling the previous operation to restore the previous status.

Operating procedure

• Select [Edit] ⇒ [Undo] ( ) immediately after editing a ladder.
The processing status just before the last operation is restored.

■ Operation applicability

The following table shows the operation applicability of the Undo function.

Table 5.1.10-1 Operation applicability of the Undo function

Item Toolbar Shortcut key

Undo  + 

Operation applicability of the Undo function Reference

Creating and deleting contacts, coils, and application instructions Section 5.1.2
Section 5.1.5

Inserting and deleting rows Section 5.1.7
Inserting and deleting columns Section 5.1.7

Editing and deleting lines Section 5.1.4
Section 5.1.6

Entering and deleting vertical lines Section 5.1.4
Section 5.1.6

Entering and deleting horizontal lines Section 5.1.4
Section 5.1.6

Cutting and pasting by setting ranges Section 5.1.9

QCPU

Q
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5.1.11 Restoring ladders to the status of after conversion

This section explains the method for restoring the currently edited ladder to the status of immediately 
after the ladder conversion.

Operating procedure

1. Select [Edit] ⇒ [Restore after ladder conversion].
The confirmation message is displayed.

2. Click the  button.
The ladder is restored to the status before editing the ladder.

● Converted ladder cannot be restored to the status before conversion.

QCPU

Q

Status after ladder conversion

Edit the ladder.

Execute [Restore after ladder conversion].
5 - 40 5.1.11 Restoring ladders to the status of after conversion
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5.1 Editing Ladder Programs
5.1.12 Precautions on editing ladders

The following explains the precautions on editing ladders.

1) For a ladder with a ladder block consisting of two or more rows, if one instruction cannot be fitted in 
a single row, create wrapping symbols and create the instruction in the next row as shown below.

Example)
To enter the following instruction:
ECALL "abcdefghijklmnopqrstuvw" P1000 ZR111111 ZR222222 ZR333333 ZR444444 
ZR555555

An instruction that does not fit in a row cannot be entered in the row ➀.
If attempted, the error message "Edit position is incorrect" is displayed.

Wrapping the row ➀ by creating the wrapping symbols.

Enter the instruction in the row ➁.

QCPU

Q

1

Create a wrapping destination symbol (>-). Create a wrapping source symbol (->).

1

2
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2) If wrapping occurs due to the insertion of a contact in the first column, a contact cannot be inserted.
In this case, move the instruction to the next row and insert the contact in the first column after 
connecting the contact with the wrapping symbols.

Example)

A contact can not be inserted in the first column since there is

no space in the row.

Move the instruction to the next row.

Create a wrapping destination symbol (>-). Create a wrapping source symbol (->).

Insert a contact.
5 - 42 5.1.12 Precautions on editing ladders
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5.1 Editing Ladder Programs
3) When there are two or more wrapping rows, an instruction that causes more wrapping can not be 
created.
In this case, insert a new row below the existing rows and enter the instruction in that row. Then, 
adjust the wrapping symbol numbers.

Example)
To enter the following instruction:
ECALL "abcdefg" P1000 ZR1000000 ZR1000001 ZR1000002 ZR1000003 ZR1000004

An instruction that does not fit in a row cannot be created in the row ➀.
If attempted, the error message is displayed.

In this case, insert a new row and enter the instruction.

Create the wrapping source symbol ( ) in the row ➁, and create the wrapping destination 
symbol ( ) in the row ➂.

1

Instruction

2

Create a wrapping destination symbol (->). Create a wrapping source symbol (->).

3
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4) If the ladder is edited (such as insertion or deletion of columns) in the middle step of a wrapped 
ladder, the ladder may not be wrapped correctly, which causes the conversion impossible.
If this happens, make corrections so that the wrapping source symbol ( ) number and the 
wrapping destination symbol ( ) number match correctly.

Example)
A column is inserted in front of [X0F] 

Wrapping source symbol ( ) K4 and wrapping destination symbol ( ) K4 are automatically 
created.
This causes matching failure between the wrapping source symbol ( ) K1 and the wrapping 
destination symbol ( ) K1.

Column inserting 

position

Last step

Middle step

Head step

Last step

Middle step

Head step
5 - 44 5.1.12 Precautions on editing ladders
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5.1 Editing Ladder Programs
In this case, a correction needs to be made to the ladder so that the wrapping destination symbol 
( ) K1 corresponds to the wrapping source symbol ( ) K1.

Move row ➀ below row ➁.

Insert a new row to ➂, and create the wrapping source symbol ( ) with K5 and wrapping 
destination symbol ( ) with K3.

Last step

Middle step

Head step

1

2

3
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Change the wrapping symbol of ➃ to K5.

With the corrections above, correspondence between the wrapping source symbols ( ) and the 
wrapping destination symbols ( ) is secured.

5) A contact or a column cannot be inserted in the middle of an instruction statement.
If attempted, the error message is displayed.

Example)

4

Neither a contact nor a column can be inserted in front of 'X1' 

and ' X2', since it cuts in the middle of the instruction above.
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5.1 Editing Ladder Programs
6) When the ladder block is displayed in yellow, it indicates that the ladder block cannot be displayed 
properly or an error exists in the program. In this case, perform the program check or compilation 
to check the error, and correct the program.

Example)
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5.2 Editing SFC Programs
This section explains the methods for operating the SFC editor.

5.2.1 List of SFC symbols

The following tables show the list of symbols used in SFC programs.

Table 5.2.1-1 List of SFC symbols for Q series (1/2)

Category Name Symbol Number of symbols

SFC step

Initial step

SFC step 0 Any one of these 
steps in a single block

Dummy initial step

Coil saving initial step

Action saving - with no transition check 
initial step
Action saving - with transition check 
initial step

Reset initial step

Initial step

Initial step other than 
SFC step 0

Up to the total of 31 
steps in a single block

Dummy initial step

Coil saving initial step

Action saving - with no transition check 
initial step
Action saving - with transition check 
initial step

Reset initial step

Step

Other than initial step

Including initial steps, 
up to 512 steps in a 
single block

Dummy step

Coil saving initial step

Action saving - with no transition check 
initial step
Action saving - with transition check 
initial step

Reset step

Block start step - with END check

Block start step - with no END check

End step
Multiple steps can be 
applied in a single 
block

QCPU

Q
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5.2 Editing SFC Programs
Table 5.2.1-2 List of SFC symbols for Q series(2/2)

Category Name Symbol Number of symbols

Transition

Series transition

Selection divergence

Selection divergence - simultaneous 
divergence

Selection convergence

Selection convergence - simultaneous 
divergence

Simultaneous divergence

Simultaneous convergence

Simultaneous convergence - 
simultaneous divergence

Simultaneous convergence - selection 
divergence 

Simultaneous convergence - selection 
convergence

Jump

a

a b n

a b

a b

a b

a

a

a

a b

a
b

j

j

a
Jump destination
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5.2.2 Creating SFC diagrams

This section explains the method for creating SFC diagrams.
SFC symbols are entered by using the Enter SFC Symbol screen.

SFC symbols also can be entered by using the toolbar and shortcut keys. The following table shows the 
toolbar icons and the corresponding shortcut keys.

Item Toolbar Shortcut key

SFC 
Symbol

Step

Block START Step - with END check

Block START Step - with no END check  + 

Jump

END Step

Dummy Step  + 

Transition

Selection Divergence

Simultaneous Divergence

Selection Convergence

Simultaneous Convergence

Vertical Line  + 

SFC Step 
Attribute

Normal  + 

Coil Saving  + 

Action Saving - with no transition check  + 

Action Saving - with transition check  + 

Reset  + 

Edit Line

Vertical Line  + 

Selection Divergence  + 

Simultaneous Divergence  + 

Selection Convergence  + 

Simultaneous Convergence  + 

Delete Line  + 

Documentation SFC Step/Edit Step Comment

SFC Step No. Sort

Monitor
SFC All Block Batch Monitor

SFC Auto Scroll Monitor

View Zoom

QCPU

Q
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5.2 Editing SFC Programs
■ Entering SFC steps ( )/( )/( )

The following explains the method for entering a SFC step.

Operating procedure

1. Move the cursor to the position where a SFC step is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Step]/[Dummy Step].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered SFC step symbol is displayed.

<Overwrite mode>

Item Description

Symbol
Select "STEP" or "DUMMY".
Dummy steps are changed to the SFC step display automatically when the 
operation output program is created.

SFC step number Enter a SFC step number. 

Step Attribute Select the SFC step attribute.
This setting can be set when "STEP" is selected for "Symbol".

Block/Reset Enter a reset destination step number when the reset step "R" is selected for 
"Step Attribute".

Comment
Enter SFC step comments. Up to 32 characters can be entered. The created 
comments can be displayed by selecting [View] ⇒ [SFC Step/Display Step 
Comment].

SFC step number

Enter SFC step 1
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<Insert mode>

● Changing the SFC step attributes
The SFC step attributes of created SFC steps can be changed by selecting [View] ⇒ [SFC Step Attribute] ⇒ [(SFC 
step attribute)]. (  Section 5.2.6)

Enter SFC step 3

A vertical line is inserted 

automatically to the other 

divergence
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5.2 Editing SFC Programs
■ Entering block start steps ( )/( )

The following explains the method for entering a block start step.

Operating procedure

1. Move the cursor to the position where a block start step is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Block START Step - with END check]/[Block START 
Step - with no END check].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered block start step symbol is displayed.

<Overwrite mode>

Item Description
Symbol Select "BLOCK" or "BLOCK-S".
SFC step number Enter a SFC step number. 
Step Attribute (This setting is not required.)
Block Enter a start destination block number.
Comment Enter SFC step comments. Up to 32 characters can be entered. 

SFC step number

Enter block start step 1
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<Insert mode>

Enter block start step 3

A vertical line is inserted 

automatically to the 

other divergence
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5.2 Editing SFC Programs
■ Entering series transitions ( )

The following explains the method for entering a series transition.

Operating procedure

1. Move the cursor to the position where a series transition is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Transition].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered series transition symbol is displayed.

<Overwrite mode>

Item Description
Symbol Select "TR".
Transition number Enter a transition number. 
Step Attribute (This setting is not required.)
Block (This setting is not required.)
Comment Enter transition comments. Up to 32 characters can be entered. 

Transition number

Enter transition 1
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<Insert mode>

Enter transition 3

A vertical line is inserted 

automatically to the 

other divergence
5 - 56 5.2.2 Creating SFC diagrams



1

O
V

E
R

VI
EW

2

SC
R

EE
N

 
C

O
N

FI
G

U
R

AT
IO

N

3

P
R

O
G

R
A

M
M

IN
G

 
P

R
O

C
ED

U
R

E

4

S
E

TT
IN

G
 L

A
B

LS

5

ED
IT

IN
G

 
PR

O
G

R
A

M
S

6

SE
A

R
C

H
 A

N
D

 
R

EP
LA

C
E

7

ED
IT

IN
G

 T
EX

TS

8

O
N

V
ER

TI
N

G
 

R
O

G
R

A
M

S

5.2 Editing SFC Programs
■ Entering selection divergences ( )

The following explains the method for entering a selection divergence.

Operating procedure

1. Move the cursor to the position where a selection divergence is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Selection Divergence].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered selection divergence symbol is displayed.

<Overwrite mode>

<Insert mode>

Item Description
Symbol Select "--D".
Number of divergences Enter a number of columns of divergence line. 
Step Attribute (This setting is not required.)
Block (This setting is not required.)
Comment (This setting is not required.)

Number of divergences

Enter a selection 

divergence

Enter a selection 

divergence
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■ Entering simultaneous divergences ( )

The following explains the method for entering a simultaneous divergence.

Operating procedure

1. Move the cursor to the position where a simultaneous divergence is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Simultaneous Divergence].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered simultaneous divergence symbol is displayed.

<Overwrite mode>

<Insert mode>

Item Description
Symbol Select "==D".
Number of divergences Enter a number of columns of divergence line. 
Step Attribute (This setting is not required.)
Block (This setting is not required.)
Comment (This setting is not required.)

Number of divergences

Enter a simultaneous 

divergence

Enter a simultaneous 

divergence
5 - 58 5.2.2 Creating SFC diagrams



1

O
V

E
R

VI
EW

2

SC
R

EE
N

 
C

O
N

FI
G

U
R

AT
IO

N

3

P
R

O
G

R
A

M
M

IN
G

 
P

R
O

C
ED

U
R

E

4

S
E

TT
IN

G
 L

A
B

LS

5

ED
IT

IN
G

 
PR

O
G

R
A

M
S

6

SE
A

R
C

H
 A

N
D

 
R

EP
LA

C
E

7

ED
IT

IN
G

 T
EX

TS

8

O
N

V
ER

TI
N

G
 

R
O

G
R

A
M

S

5.2 Editing SFC Programs
■ Entering selection convergences ( )

The following explains the method for entering a selection convergence.

Operating procedure

1. Move the cursor to the position where a selection convergence is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Selection Convergence].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered selection convergence symbol is displayed.

<Overwrite mode>

Item Description
Symbol Select "--C".
Number of convergences Enter a number of columns of convergence line. 
Step Attribute (This setting is not required.)
Block (This setting is not required.)
Comment (This setting is not required.)

Number of convergences

Enter a selction 

convergence
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<Insert mode>

Enter a selction 

convergence
5 - 60 5.2.2 Creating SFC diagrams
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5.2 Editing SFC Programs
■ Entering simultaneous convergences ( )

The following explains the method for entering a simultaneous convergence.

Operating procedure

1. Move the cursor to the position where a simultaneous convergence is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Simultaneous Convergence].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered simultaneous convergence symbol is displayed.

<Overwrite mode>

Item Description
Symbol Select "==C".
Number of convergences Enter a number of columns of convergence line. 
Step Attribute (This setting is not required.)
Block (This setting is not required.)
Comment (This setting is not required.)

Number of convergences

Enter a simultaneous 

convergence
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<Insert mode>

Enter a simultaneous 

convergence
5 - 62 5.2.2 Creating SFC diagrams
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5.2 Editing SFC Programs
● Entering method when a divergence and a convergence overlap in a single transition
Reserve the area for one step using " " (vertical line), then enter a divergence or convergence symbol. A vertical 
line can be inserted by selecting [Edit] ⇒ [Insert Row]. (  Inserting/deleting rows and columns)

● Number of divergences/convergences when entering divergence/convergence lines
To create a divergence/convergence line at the left of the cursor position, enter '-n' for the number of divergences/
convergences.

● Inserting divergences/convergences
Inserting divergences/convergences may cause the SFC diagram to become a program that cannot be converted. 
Edit the SFC diagram to be normal and convert the program.

Area for 1 step

Exmple1)

Area for 1 step

Exmple2)
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■ Entering jump transitions ( )

The following explains the method for entering a jump transition.

Operating procedure

1. Move the cursor to the position where a jump transition is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [Jump].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered jump transition symbol is displayed.

Item Description
Symbol Select "JUMP".
Jump destination step number Enter a jump destination step number. 
Step Attribute (This setting is not required.)
Block (This setting is not required.)
Comment (This setting is not required.)

Jump destination step number

Enter a jump transition
5 - 64 5.2.2 Creating SFC diagrams
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5.2 Editing SFC Programs
■ Entering end steps ( )

The following explains the method for entering an end step.

Operating procedure

1. Move the cursor to the position where an end step is entered.

2. Select [Edit] ⇒ [SFC Symbol] ⇒ [END Step].
The Enter SFC Symbol screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The entered end step symbol is displayed.

Item Description
Symbol Select "END".
SFC step number (This setting is not required.)
Step Attribute (This setting is not required.)
Block (This setting is not required.)
Comment (This setting is not required.)

SFC step number

Enter an end step
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■ Drawing lines

The following explains the method for drawing a divergence line and a convergence line by dragging 
the mouse.

Operating procedure

1. Select [Edit] ⇒ [Edit Line] ⇒ [Vertical Line]/[Selection Divergence]/[Simultaneous 
Divergence]/[Selection Convergence]/[Simultaneous Convergence].

2. Drag the cursor from the start position for entering lines to the end position.

● Overwriting lines
Even when lines are overwritten to the created SFC steps/transitions, SFC steps/transitions and sequence 
programs in the operation outputs/transition conditions are not deleted.

Drag the mouse to 

the end position
5 - 66 5.2.2 Creating SFC diagrams
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5.2 Editing SFC Programs
■ Inserting/deleting rows and columns

The following explains the method for inserting/deleting a row and a column.

Operating procedure

1. Move the cursor to the position where a row or column is inserted/deleted.

2. Execute each operation as shown below.
<Inserting a row>

<Inserting a column>

[Edit] ⇒ [Insert Row]

[Edit] ⇒ [Insert Column]
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<Deleting a row>

<Deleting a column>

[Edit] ⇒ [Delete Row]

[Edit] ⇒ [Delete Column]
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5.2 Editing SFC Programs
5.2.3 Deleting SFC diagrams

This section explains the methods for deleting entered SFC symbols.

■ Deleting SFC symbols by setting a range

The following explains the method for deleting SFC symbols by setting a range.

Operating procedure

1. Specify the range to be deleted by dragging the cursor.

2. Select [Edit] ⇒ [Delete].

● Selecting a range

The range can be selected by pressing the  key +  key.
● Deleting symbols

Symbols can be deleted by pressing the  key, or by selecting [Edit] ⇒ [Cut].
● Canceling the previous operation

After deleting symbols, the editing status before the deletion is restored by selecting [Edit] ⇒ [Undo].

QCPU

Q

Drag 
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■ Deleting only divergence/convergence/vertical lines

The following explains the method for deleting a divergence/convergence/vertical line.

Operating procedure

1. Select [Edit] ⇒ [Delete Line].

2. Specify the range to be deleted by dragging the cursor.
After dragging, the lines in the specified range are deleted.

Drag 
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5.2 Editing SFC Programs
5.2.4 Changing SFC step attributes

This section explains the method for changing the SFC step attribute.

Operating procedure

1. Move the cursor to the SFC step whose attribute is to be changed.

2. Select [Edit] ⇒ [SFC Step Attribute] ⇒ [Normal]/[Coil Saving]/[Action Saving - with 
no transition check]/[Action Saving - with transition check]/[Reset].

● Operation output sequence program after the SFC step attribute is changed
Even when the SFC step attribute is changed, the operation output sequence program already created remains as 
it is.

QCPU

Q

[Edit] ⇒
[SFC Step Attribute] ⇒
[Coil Saving]
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5.2.5 Cutting, copying, and pasting SFC diagrams

This section explains the method for cutting, copying, and pasting the SFC diagram.

Operating procedure

1. Specify the range to be cut or copied.

2.  Select [Edit] ⇒ [Cut]/[Copy], and cut or copy the SFC diagram in the specified 
range.

3. Move the cursor to the position where the cut/copied SFC diagram is pasted.

4. Select [Edit] ⇒ [Paste].
The Paste Data screen is displayed.

QCPU

Q

5 - 72 5.2.5 Cutting, copying, and pasting SFC diagrams



1

O
V

E
R

VI
EW

2

SC
R

EE
N

 
C

O
N

FI
G

U
R

AT
IO

N

3

P
R

O
G

R
A

M
M

IN
G

 
P

R
O

C
ED

U
R

E

4

S
E

TT
IN

G
 L

A
B

LS

5

ED
IT

IN
G

 
PR

O
G

R
A

M
S

6

SE
A

R
C

H
 A

N
D

 
R

EP
LA

C
E

7

ED
IT

IN
G

 T
EX

TS

8

O
N

V
ER

TI
N

G
 

R
O

G
R

A
M

S

5.2 Editing SFC Programs
5. Set the items on the screen.

6. Click the  button.
The cut/copied SFC diagram is pasted.
Note that the conversion error occurs when the divergence or convergence line is not correct after 
pasting data. Edit the SFC diagram and convert the program again.

Item Description

Action/Transition Check this to paste the cut/copied data including operation output/transition 
condition sequence programs. 

Step and TR Comments Check this to paste the cut/copied data including SFC step/transition comments.

● Pasting position
If the start position of the cut/copied SFC diagram is a SFC step, it cannot be pasted at the position of transition, 
and if the start position is a transition, it cannot be pasted at the position of SFC step. Change the pasting position 
one row up or down, and paste the data again.

● Operation output/transition condition programs to be pasted
Paste operation output/transition condition programs within approximate 2K steps.
For details of maximum number of sequence steps that can be created, refer to the following manual.

 QCPU (Q Mode)/QnACPU Programming Manual (SFC)
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5.2.6 Sorting SFC step/transition numbers of SFC diagram

This section explains the method for sorting SFC step/transition numbers of created SFC diagram.

Screen display

Select [Edit] ⇒ [SFC Step No. Sort].

 

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The sorting of SFC step/transition numbers is executed according to the set contents. 

Item Description
Sorting Order Select whether to sort SFC step/transition numbers in ascending or descending order.
Change START 
Block Number Check this to change the start block number.

Set START Block 
Number

When the "Change" is selected, set the start destination block number of the block start step 
that is changed when sorting SFC step/transition numbers.

● Difference of sorting result according to the sorting order
The following figures show the sorting results in ascending and descending order. 

• The "Undo" operation can be performed only once immediately after the sort execution.
• The initial step is always set to '0' for either ascending or descending order.

● SFC devices at the sorting operation
SFC devices used for operation outputs/transition conditions (such as BLm\Sn, BLm\TRn) are not sorted.
Change them using the device replacing function.

QCPU
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5.2 Editing SFC Programs
5.2.7 Redisplaying SFC diagrams

This section explains the method for deleting unused vertical/divergence/convergence lines in the 
converted SFC diagram.
If the unconverted SFC diagram is redisplayed, the unconverted SFC diagram is discarded and the 
latest converted status is restored.

Operating procedure

• Select [Edit] ⇒ [Review SFC].
<Deleting a row section>

<Deleting a column section>

QCPU

Q

[Edit] ⇒
[Review SFC]

[Edit] ⇒
[Review SFC]
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5.2.8 Creating operation outputs and transition conditions

This section explains the method for creating operation output and transition condition programs.

Operating procedure

1. Move the cursor to the SFC step/transition where the program is created. 

2. Select [View] ⇒ [Open Zoom/START Destination SFC Block].
The editing operations on the Zoom screen are same as those of creating ladder programs. 
(Section 5.1)

● Opening the Zoom screen

To open the Zoom screen, hold the  key and double click the SFC step/transition, or press the  and 

 keys.

To return to the SFC diagram, press the  and  keys.
● Instructions that can be used in the Zoom screen

For details of unavailable instructions for operation outputs/transition conditions, refer to the following manual.
 QCPU (Q Mode)/QnACPU Programming Manual (SFC)

Statements and pointers cannot be entered. For transition conditions, notes cannot be entered as well.
● Entering a dummy coil to transition conditions

Only one dummy coil ( ) for the coil instruction can be entered.

To enter a dummy coil, select [Edit] ⇒ [Ladder Symbol] ⇒ [Coil], and clicking the  button enters a dummy 
coil automatically.

● When the cursor is placed at the block start step
If [View] ⇒ [Open Zoom/START Destination SFC Block] is selected when the cursor is placed at the block start 
step, the SFC diagram of the start destination block is displayed.

● Using function blocks in the Zoom screen
Only function blocks created in the ladder language can be used for operation outputs. Function blocks cannot be 
used for transition conditions. 

● Cutting/copying/pasting data
Data can be cut, copied, and pasted between the ladder program and the program in the Zoom screen. However, 
data containing instructions, statements, and pointers that cannot be used in the Zoom screen cannot be pasted. 
The ladder containing TRAN can be pasted to transition conditions only.

QCPU

Q

[View] ⇒ [Open Zoom/START Destination SFC Block]
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5.2 Editing SFC Programs
5.2.9 Setting block information

This section explains the method for setting block information.
Block information is set on the Property screen of SFC block.
Select the SFC block to be set in the Project window in advance.

Screen display

Select [Project] ⇒ [Object] ⇒ [Property] ⇒ <<Detail>>.

Operating procedure

• Set the items related to the block information on the screen.

Item Description
Title Enter the title of the SFC block. (The number of settable characters is 32.)
Block No. Specify the SFC block number. (0 to 319. 0 to 127 for Q02UCPU.)

Block Information Enter devices/labels to the required items as block information devices. (The number of 
settable characters is 32.)

● Title of SFC block (projects without labels)
The set block title is stored as a device comment of device BLm. A block title can be created/changed by entering 
"BLm" for the device name in the device comment editor. When setting block titles for each program, create 
comments by program.
For creating and editing device comments, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)
● Title of SFC block (projects with labels)

When the block title is set, the confirmation message asking whether to copy the block title to the device comment 
of device BLm is displayed. Creating device comment for the device set as BLm in the device comment editor is 
not applied to the block title. 

● Block information
• For details of functions and operations of each item, refer to the following manual.

 QCPU (Q Mode)/QnACPU Programming Manual (SFC)
• When the block information is changed in the project with labels, the program becomes uncompiled status.  

QCPU

Q
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5.2.10 Displaying SFC block list

This section explains the method for displaying the list of the SFC program block information including 
the SFC diagram being edited.
Open the screen of the SFC diagram in advance.

Screen display

Select [View] ⇒ [Open SFC Block List].

Display contents

■ Displaying comments on SFC block list

The following explains the method for displaying device/label comments on the SFC block list.

Operating procedure
Select [View] ⇒ [Display SFC Block List Comment].

 

Item Description

No. Displays "Block No." set on the Property screen of SFC block.

Data Name Displays the block name.

Title Displays "Title" set on the Property screen of SFC block.

Block START Displays "Block START/END Bit" set on the Property screen of SFC block.

Step Transition Displays "Step Transition Bit" set on the Property screen of SFC block.

Block PAUSE/RESTART Displays "Block PAUSE/RESTART Bit" set on the Property screen of SFC block.

Pause Mode Displays "Pause Mode Bit" set on the Property screen of SFC block.

Number of Active Steps Displays "Number of Active Steps Register" set on the Property screen of SFC block.

Continuous Transition Bit Displays "Continuous Transition Bit" set on the Property screen of SFC block.

Comment Displays "Comment" set on the Property screen of SFC block.

QCPU

Q
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5.2 Editing SFC Programs
■ Displaying devices on SFC block list

The following explains the method for displaying devices assigned to labels on the SFC block list.
This function is available after the compilation of the SFC program.

Operating procedure
Select [View] ⇒ [Address Display].

■ Displaying SFC diagram from SFC block list

The following explains the method for displaying the SFC diagram of the block at the cursor position on 
the SFC block list.

Operating procedure

1. Move the cursor to the block to be displayed.

2. Select [View] ⇒ [Open SFC], or double click the block to be displayed. 

● Displaying comments on the SFC block list
Comments also can be displayed on the SFC block list by the following operation.
Select [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ "SFC" ⇒ "Comment".

 

● When SFC program becomes uncompiled status
When the SFC program becomes uncompiled status, the device display is disabled.

● Displayed comments
When [Display SFC Block List Comment] is selected, displayed comments are changed from label comments to 
device comments.
5.2.10 Displaying SFC block list 5 - 79
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■ Displaying Local Label Setting screen from SFC block list

The following explains the method for displaying the Local Label Setting screen of the block at the 
cursor position on the SFC block list.

Operating procedure

1. Move the cursor to the block to be displayed.

2. Select [View] ⇒ [Open Header]. 
5 - 80 5.2.10 Displaying SFC block list
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5.2 Editing SFC Programs
5.2.11 Setting parameters for SFC programs

This section explains the method for setting parameters for SFC programs among the parameter 
settings for operating the programmable controller CPU.

■ SFC settings in PLC parameter

The following explains the method for setting parameters for SFC programs in PLC parameter. 

Screen display

Select Project window ⇒ "Parameter" ⇒ "PLC Parameter" ⇒ <<SFC>>.

 

Operating procedure

• Set the items on the screen.

Item Description

SFC Program Start Mode Select to initial start or resume start the SFC program.

Start Conditions Select whether to autostart block 0 at the initial start of the SFC program.

Output Mode When the Block is 
Stopped

Select to stop the program by turning OFF the coil outputs that are turned ON by 
the OUT instruction, or to stop the program while they are remained ON, when the 
stop operation is requested to each block.

QCPU

Q
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■ Setting the property of SFC programs

The following explains the method for setting the property of SFC programs.

Screen display

Select [Project] ⇒ [Object] ⇒ [Property] ⇒ <<Detail>>.

 

Operating procedure

• Set the items on the screen.

Item Description

Title Enter the title of the SFC program. (The number of settable characters is 32.)

SFC Program Type 
Setting

Select the "Normal SFC type" or "Control SFC type".
"Control SFC type" can be selected for High Performance model QCPU.

Periodic Execution 
Block

All blocks following the set block number become periodic execution blocks. To process all blocks 
in every scan, leave this field blank.
The execution interval is entered within the range of 1 to 65535ms in unit of 1ms.

Act at Block Multi-
Activated

When the blocks in the specified range is active, and the start operation is requested from another 
block, an error occurs and the operation of the programmable controller CPU stops.
The operating mode at the multiple activation for blocks out of the specified range becomes 
'standby'.
To set the operating mode to 'standby' for all blocks, leave the start and end fields blank.

Act at Step Multi-
Activated

When the multiple activation of SFC steps occurs, the SFC steps in the range specified for the 
"Waiting Blocks" are set in standby status until the corresponding SFC steps become inactive.
When the multiple activation of SFC steps occurs, the SFC steps in the range specified for the 
"Stop Blocks" become error and the operation of the programmable controller CPU stops.
When the multiple activation of SFC steps occurs, the SFC steps out of the specified range are 
forcibly transited.
5 - 82 5.2.11 Setting parameters for SFC programs
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5.2 Editing SFC Programs
● Applicable range for the set data
The data set in the property of SFC program are commonly applied to all blocks in SFC programs. Specific data 
cannot be set for each block.

● Control SFC type program
An SFC diagram can be created for the block 0 only in the control SFC type program.
If a block start step is entered to the block 0, an error occurs and the programmable controller CPU stops when the 
program is executed.
5.2.11 Setting parameters for SFC programs 5 - 83
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6 SEARCH AND REPLACE
This chapter explains basic operations of search, replace and batch-replace functions.
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6.1 Searching for and Replacing Data in Ladder Programs

This section explains the method for searching for and replacing the specified device, instruction, and step 
number.
The search/replace function is applicable only to the converted data.

6.1.1 Searching for, replacing, and batch replacing devices
This section explains the method for searching for, replacing, and batch replacing devices in the 
program.

■ Searching for devices

The following explains the method for searching for devices.

Screen display

Select [Find/Replace] ⇒ [Find Device] (  ).

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched device.

Item Description

Device
Enter a device to be searched for.

Click  to select from the list of ten devices entered previously.

Find Direction

Down from Head Select this to execute a search in the downward direction from the 
start of the program regardless of the current cursor position.

Down from Cursor Select this to execute a search in the downward direction from the 
cursor position to END.

Up from Cursor Select this to execute a search in the upward direction from the 
cursor position to step 0.

Find Option

None Select this to execute a search for the entered device only.

Digit Select this to execute a search for the entered device and digit 
specification for bit devices that include the entered device.

Double Word
Select this to execute a search for the entered device and the 
double-word format (double word/real number/indirect specification) 
word devices that include the entered device.

QCPU

Q
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6.1 Searching for and Replacing Data in Ladder Programs
■ Examples of device search

The following tables show examples of specification for device search operations.

Table 6.1.1-1 Example of the device search (Find option: None)

Table 6.1.1-2 Example of the device search (Find option: Digit)

Table 6.1.1-3 Example of the device search (Find option: Double word)

Device specification Search result
M0 M0, K4M0, M0Z0, K4M0Z0
K4M0 K4M0, K4M0Z0

D0 D0, D0Z0, D0.1*1

D0.1 D0.1

J1\B0 J1\B0, J1\B0Z0, J1Z0\B0, J1Z0\B0Z0, J1\K4B0, J1\K4B0Z0, J1Z0\K4B0, 
J1Z0\K4B0Z0

Device specification Search result
X0 to X3 K1X0
X0 to X0F K4X0
X0 to X1F K8X0

Device specification Search result
D0 to D1 DMOV K1 D0, EMOV E1 D0, MOV K1 @D0
D0 to D9 BMOV K1 D0 D100 10
6.1.1 Searching for, replacing, and batch replacing devices 6 - 3
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■ Replacing devices

The following explains the method for searching for devices and replacing them with the specified 
device.

Screen display

Select [Find/Replace] ⇒ [Replace Device].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched old device.

3. Click the  or  button.
The old devices are replaced with the new devices, and the search for the old devices continues.

If the  button is clicked, all searched old devices are batch replaced with the new 
devices.

Item Description

Old Device
Enter a device to be replaced.

Click  to select from the list of ten devices entered previously.

New Device
Enter a replacing device.

Click  to select from the list of ten devices entered previously.

Substitute Points

Enter a number of points to be replaced, counted from the device 
specified for the "Old Device".

Click  to select either decimal or hexadecimal for the value to be 
entered.

Example) When X50 for "Old Device", X100 for "New Device", 3 for 
"Substitute Points", and "DEC" for entered value are set, the devices 
are replaced as shown below:
X50 X100, X51 X101, X52 X102

Move with Device Comment Check this to move the device comments of the "Old Device" to the 
"New Device".

Find Direction

Down from Head Select this to execute a search in the downward direction from the 
start of the program regardless of the current cursor position.

Down from Cursor Select this to execute a search in the downward direction from the 
cursor position.

Specified Range Select this to execute a search in the range set by the entered step 
numbers.

→ → →
6 - 4 6.1.1 Searching for, replacing, and batch replacing devices
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6.1 Searching for and Replacing Data in Ladder Programs
■ Batch replacing devices

The following explains the method for batch replacing devices with the specified device.

Screen display

Select [Find/Replace] ⇒ [Device Batch Replace].

 

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The old devices are batch replaced with the new devices.

Item Description
Old Device Enter a device to be replaced.
New Device Enter a replacing device.
Points Points: Enter a number of points to be replaced, counted from the 

device specified for the "Old Device".

Point format: Click  to select either decimal or hexadecimal for the 
value entered for the "Points".

Example) When X0 for "Old Device", X1 for "New Device", 5 for 
"Points", and "Decimal" for "Point Format" are set, the devices are 
replaced as shown below:
X0 X1, X1 X2, X2 X3, X3 X4, X4 X5

Point Format

Move with Device Comment
Comment for label cannot be moved.

Check this to move the device comments of the "Old Device" to the 
"New Device".

→ → → → →
6.1.1 Searching for, replacing, and batch replacing devices 6 - 5
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■ Devices that can be replaced or batch replaced

The following table shows the devices that can be replaced or batch replaced.

Table 6.1.1-4 Devices that can be replaced or batch replaced

New device

Bit device
(M0, J1\B0)

Digit specification for 
bit devices

(K4M0, J1\K4B)

Word device
(D0, J1\W0)

Bit specification for 
word devices

(D0.1, J1\W0.1)

E
ar

lie
r d

ev
ic

e

Bit device
(M0, J1\B0) × ×

Digit specification for bit 
devices

(K4M0, J1\K4B)
× × × ×

Word device
(D0, J1\W0) × × ×

Bit specification for 
word devices

(D0.1, J1\W0.1)
× ×
6 - 6 6.1.1 Searching for, replacing, and batch replacing devices
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6.1 Searching for and Replacing Data in Ladder Programs
6.1.2 Searching for and replacing instructions

This section explains the method for searching for and replacing instructions.

■ Searching for instructions

The following explains the method for searching for instructions.

Screen display

Select [Find/Replace] ⇒ [Find Instruction] (  ).

 

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched instruction.

Item Description

Search Instruction

Set a ladder symbol to be searched for.

Click  to select a ladder symbol from the list.
Enter an instruction or device to be searched for.

Click  to select from the list of ten devices or instructions entered 
previously.

Find Direction

Down from Head Select this to execute a search in the downward direction from the 
start of the program regardless of the current cursor position.

Down from Cursor Select this to execute a search in the downward direction from the 
cursor position.

UP from Cursor Select this to execute a search in the upward direction from the 
cursor position.
6.1.2 Searching for and replacing instructions 6 - 7
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■ Examples of instruction search

The following table shows the examples of instruction search.

Table 6.1.2-1 Example of instruction search

Instruction 
specification Search result

MOV MOV, MOVP
MOVP MOVP

MOV D0 K4Y0 MOV D0 K4Y0, MOVP D0Z1 K4Y0,
MOV D0 K4Y0Z1, MOVP D0Z1 K4Y0Z1

MOVP D0 J1\W0 MOVP D0 J1\W0, MOVP D0Z1 J1\W0, 
MOVP D0 J1Z1\W0Z1, MOVP D0Z1 J1Z1\W0Z1
6 - 8 6.1.2 Searching for and replacing instructions
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6.1 Searching for and Replacing Data in Ladder Programs
■ Replacing instructions

The following explains the method for searching for instructions and replacing them with the specified 
instruction.

Screen display

Select [Find/Replace] ⇒ [Replace Instruction].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched old instruction.

3. Click the  or  button.
The old instructions are replaced with the new instructions, and the search for the old instructions 
continues.

If the  button is clicked, all searched old instructions are batch replaced with the new 
instructions.

Item Description

Old Instruction

Set a ladder symbol to be replaced.

Click  to select a ladder symbol from the list.
Enter a device and instruction or instruction only to be replaced.

Click  to select from the list of ten devices and/or instructions 
entered previously.

New Instruction

Set a new ladder symbol.

Click  to select a ladder symbol from the list.
Enter a new device and instruction or instruction only.

Click  to select from the list of ten devices and/or instructions 
entered previously.

Find Direction

Down from Head Select this to execute a search in the downward direction from the 
start of the program regardless of the current cursor position.

Down from Cursor Select this to execute a search in the downward direction from the 
cursor position.

Specified Range Select this to execute a search in the range set by the entered step 
numbers.
6.1.2 Searching for and replacing instructions 6 - 9

C P



6 SEARCH AND REPLACE
GX Works2
■ Precautions on replacing instructions

The following explains the precautions on replacing instructions.

● Replacing a 16-bit (word) instruction with a 32-bit (double word) instruction
When a 16-bit (word) instruction is replaced with a 32-bit (double word) instruction, and if a 
constant is set for the device, the constant value is not sign-extended to a value in 32 bits.

When a 32-bit instruction is replaced with a 16-bit instruction, and if a constant is set for the device, 
upper 16 bits are discarded.

6.1.3 Searching for contacts and coils

This section explains the method for searching for contacts and coils that correspond to the device at 
the cursor position.

Screen display

Select [Find/Replace] ⇒ [Find Contact or Coil] ( ).

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The contacts or coils that use the specified device are searched from the start of the program in the 
order of step number.

Item Description
Contact/coil selection field Select "Contact" or "Coil".

Device entry field Enter the device to be searched.
Specify a bit device, bit specification for word devices or label.

The value is not sign-extended 

to -1(H0FFFFFFFF).

Example)

(-1)

[MOV H0FFFF D0] Replace MOV to DMOV

(+32767)

[MOV H0FFFF D0]

Example)

Replace DMOV to MOV
[DMOV K150000 D0]

[DMOV H0FFFFFFFF D0]

[MOV K18928 D0]

[MOV H0FFFF D0]

Contact/coil selection field Device entry field
6 - 10 6.1.3 Searching for contacts and coils
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6.1 Searching for and Replacing Data in Ladder Programs
6.1.4 Jumping to the specified step number

This section explains the method for moving to the specified step number.

Screen display

Select [Find/Replace] ⇒ [Jump].

Operating procedure

1. Enter the jump destination step number.

2. Click the  button.
The cursor moves to the specified step number.

● Devices to be searched
Only devices in the currently opened program can be searched.

Item Description

Step No.
Enter a program step number for the jump destination.

Click  to select from the list of ten step numbers entered 
previously.

● Jump function
On the programming screen, pressing a numeric key on the keyboard enables to display the Jump screen.
6.1.4 Jumping to the specified step number 6 - 11
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6.1.5 Changing contacts between open contact and close contact

This section explains the method for searching for devices and changing their contact types from open 
contact to close contact, and conversely, from close contact to open contact.

Screen display

Select [Find/Replace] ⇒ [Change Open/Close Contact].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched device.

3. Click the  or  button to change the contact type.
The contact types are changed from open to close contact and from close to open contact, and the 
search for the next target devices continues.

If the  button is clicked, contact types of all searched devices are batch changed from 
open to close contact and from close to open contact.

Item Description

Device
Enter a device to be changed.

Click  to select from the list of ten devices entered previously.

Change Points

Enter a number of points to be changed, counted from the device 
entered in the "Device" field.

Click  to select either decimal or hexadecimal for the value to be 
entered.

Example) When X100 for "Device", 3 for "Change Points" and "DEC 
for entered value are set, the contact type is replaced between open 
contact and close contact at X100, X101 and X102.

Find Direction

Down from Head Select this to execute a search in the downward direction from the 
start of the program regardless of the current cursor position.

Down from Cursor Select this to execute a search in the downward direction from the cursor 
position.

Specified Range Select this to execute a search in the range set by the entered step 
numbers.
6 - 12 6.1.5 Changing contacts between open contact and close contact
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6.1 Searching for and Replacing Data in Ladder Programs
● Operation applicability of the changing open/close contact function
The following table shows the contacts whose contact types can be changed.

Table 6.1.5-1 Contacts whose contact types can be changed

Replace Example
6.1.5 Changing contacts between open contact and close contact 6 - 13
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6.1.6 Changing the module start I/O numbers
This section explains the method for changing the start I/O number of the FROM(P), TO(P), DFRO(P), 
DTO(P), RFRP, and RTOP instructions.

Screen display

Select [Find/Replace] ⇒ [Change Module Start I/O No.].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched old module I/O number.

3. Click the  or  button change the I/O number.
The old module I/O numbers are replaced with the new module I/O numbers, and the search for 
the old module I/O numbers continues.

If the  button is clicked, all searched old module I/O numbers are batch replaced with 
the new module I/O numbers.

4. Click the  button to end the batch-replace function.

Item Description

Old Module I/O No. Range 
(HEX)

Start
Enter a module start I/O number in the range to be changed.

Click  to select from the list of ten module I/O numbers entered 
previously.

End
Enter a last module I/O number in the range to be changed.

Click  to select from the list of ten module I/O numbers entered 
previously.

New Module Start Address (HEX)

Enter a replaced module I/O number that corresponds to the module 
I/O number entered for the "Start".

Click  to select from the list of ten module I/O numbers entered 
previously.

Find Direction

Down from Head Select this to execute a search in the downward direction from the 
start of the program regardless of the current cursor position.

Down from Cursor Select this to execute a search in the downward direction from the 
cursor position.

Specified Range Select this to execute a search in the range set by the entered step 
numbers.
6 - 14 6.1.6 Changing the module start I/O numbers
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6.1 Searching for and Replacing Data in Ladder Programs
■ Precautions on replacing module start I/O numbers (QCPU)

The following explains the precautions on replacing module start I/O numbers.

● Specification of the module I/O number
• When specifying a module I/O number, specify the actual module I/O number.

Example)

● Replacing module I/O numbers of intelligent function module devices
Use the device replacing function to replace the module I/O numbers of intelligent function module 
devices. (  Section 6.1.1)
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6.2 Searching for and Replacing Data in SFC Programs

This section explains the method for jumping to the specified SFC step number or block number using the 
SFC diagram or SFC block list of the SFC program.
The operations of device search/replace, instruction search/replace, and open/close contact change functions 
are same as the search/replace function of ladder program. (  Section 6.1) 

6.2.1 Jumping to specified SFC step number/transition number on 
SFC diagram

This section explains the method for jumping to the SFC step number/transition number in the specified 
block when the cursor is placed on the SFC diagram.

Screen display

Select [Find/Replace] ⇒ [Jump].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor jumps to the SFC step number/transition number of the specified block. 

Item Description
Data Name Select the block data name.
Block No. Displays the block number corresponds to the "Data Name".
Step/Transition Set the jump destination of the SFC step number/transition number.

Step No. Select this to jump to the specified SFC step number.
Transition No. Select this to jump to the specified transition number.

QCPU

Q

6 - 16 6.2 Searching for and Replacing Data in SFC Programs
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6.2 Searching for and Replacing Data in SFC Programs
6.2.2 Jumping to specified SFC step number/block number on 
SFC diagram

This section explains the method for jumping to the SFC step number/block number when the cursor is 
placed on the SFC diagram.

Operating procedure

1. Press the numeric key when the cursor is placed on the SFC diagram.

2. Set the items on the screen.

3. Click the  button.
When the "Step No." is selected, the cursor moves to the specified SFC step number in the block 
being edited. 
When the "Block No." is selected, the SFC diagram of the specified block number is displayed.

Item Description

Entry field Displays the number that is entered on the SFC diagram.
Enter an SFC step number or block number of the jump destination.

Step No. Select this to jump to the specified SFC step number.
Block No. Select this to jump to the specified block number.

Entry field
6.2.2 Jumping to specified SFC step number/block number on SFC diagram 6 - 17
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6.2.3 Replacing SFC step number on SFC diagram

This section explains the method for replacing a jump destination step number or reset destination step 
number in each block.

Screen display

Select [Find/Replace] ⇒ [Replace SFC Step No.].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched SFC step number.

3. Click the  or  button.

When the  button is selected, the old step number at the cursor position is replaced with 
the new step number. When the cursor is not at the old step number, it moves to the next searched 
step number. 

When the  button is selected, all old step numbers in the specified block are replaced 
with the new step number.

Item Description
Data Name Select the block data name.
Block No. Displays the block number corresponds to the "Data Name".

Jump Destination Step Enter old and new SFC step numbers when replacing the jump destination SFC step 
number.

Old Step No. Enter an old SFC step number.
New Step No. Enter a new SFC step number.

Reset Destination Step Enter old and new SFC step numbers when replacing the reset destination SFC step 
number.

Old Step No. Enter an old SFC step number.
New Step No. Enter a new SFC step number.

● Conversion/compilation status after replacing step numbers
After replacing step numbers, the program becomes unconverted/uncompiled status. Convert or compile the 
program.
6 - 18 6.2.3 Replacing SFC step number on SFC diagram
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6.2 Searching for and Replacing Data in SFC Programs
6.2.4 Searching for blocks on SFC block list

This section explains the method for searching for a block or block title on the SFC block list.

Screen display

Select [Find/Replace] ⇒ [Jump].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the specified block.

Item Description

Block No.
Select this to jump to the specified block number.
When the "Data Name" is selected, the block number corresponds to the "Data Name" 
is displayed.

Data Name
Select this to jump to the specified data name.
When the "Block No." is selected, the data name corresponds to the "Block No." is 
displayed.
6.2.4 Searching for blocks on SFC block list 6 - 19
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6.2.5 Searching for devices on SFC block list

This section explains the method for searching for devices on the SFC block list.

Screen display

Select [Find/Replace] ⇒ [Find Device]. ( )

Operating procedure

1. Set the items on the screen.

2.  Click the  button.
The cursor moves to the searched device.

Item Description

Find Device
Enter a device to be searched for.

Click  to select from the list of ten devices entered 
previously.

Find Direction

Head
Select this to search for devices in the downward direction from 
the start of the program regardless of the current cursor 
position.

Down Select this to search for devices in the downward direction from 
the cursor position.

Up Select this to search for devices in the upward direction from 
the cursor position.

Find Range
Displayed Data Only Select this to search for devices only within the data that are 

being displayed.

Include Assigned Data Select this to search for devices including those assigned to 
labels.
6 - 20 6.2.5 Searching for devices on SFC block list
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7 EDITING TEXTS
This chapter explains basic operation for editing device comments, statements, and notes.
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7.1 Editing Device Comments
For the method for editing device comments and the related functions, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)

7.2 Editing Statements and Notes

This section explains the method for editing statements and notes, and the related functions.

7.2.1 Statements and notes

The following explains the overview of statements and notes, and the precautions on editing.

Screen display

QCPU

Q

Line statement

P statement

I statement

Note

Line statement

P statement

I statement

Note
7 - 2 7.2 Editing Statements and Notes
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7.2 Editing Statements and Notes
■ What is a statement?

A statement is a comment that is appended to a ladder block.
Appending statements makes the processing flow easy to understand.
Statements include line statements, P statements and I statements.

• Line statement : A comment appended to a ladder block as a whole.
• P statement : A comment appended to a pointer number.
• I statement : A comment appended to an interrupt pointer number.

■ What is a note?

A note is a comment that is appended to a coil and application instruction.
Appending notes makes the details of coils and application instructions easy to understand.

■ Number of characters that can be entered

The following table shows the number of characters that can be entered for a statement or note.

Table 7.2.1-1 Number of characters that can be entered for a statement or note

■ Types of statement and note

'PLC' and 'Peripheral' are the types of statement and note.

Name Number of characters
Line statement 64 characters
P statement

64 characters
I statement
Note 32 characters

Name Applicable 
model Function

PLC

Line statement
P statement
I statement QCPU

(Q mode)

• Statements and notes can be stored in the programmable 
controller CPU.

• PLC statement uses the following number of steps.

2 +  steps (Decimal fraction is rounded up)Note

Peripheral

Line statement
P statement
I statement QCPU

(Q mode)

• Statements and notes cannot be stored in the programmable 
controller CPU. (Only the position information can be stored.) 
Statements and notes must be saved in a peripheral equipment.

• One statement or note line uses one step.
• A * symbol is prefixed to the entered text automatically.Note

2

Number of characters
7.2.1 Statements and notes 7 - 3
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7.2.2 Entering statements

This section explains the method for entering line statements, P statements, and I statements.

■ Entering line statements

The following explains the method for entering a line statement.

Operating procedure
 

1. Select [Edit] ⇒ [Documentation] ⇒ [Statement] (  ).
The statement entry mode is established.

2. Move the cursor to the left end of the ladder block where a line statement is  
entered.

3. Press the  key.
The Enter Line Statement screen is displayed.

4. Select the statement type ("In PLC" or "In 
Peripheral").

5. Enter a line statement.

6. Click the  button.
The entered line statement is displayed on the editing screen.
When "In Peripheral" is selected, '*' is automatically prefixed to the line statement.

7. To disable the line statement entry mode, select [Edit] ⇒ [Documentation] ⇒ 
[Statement] ( ) again.
The statement entry mode is disabled.

Item Toolbar

Statement
7 - 4 7.2.2 Entering statements
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7.2 Editing Statements and Notes
● Line statements can be entered on the Enter Symbol screen.
Move the cursor to the left end of the ladder block where a line statement is entered and press the  key.
The Enter Symbol screen is displayed. Enter a line statement as shown below.

● Displaying statements on the editing screen.
Display/hide of statements can be switched by selecting [View] ⇒ [Statement]. (  Section 2.2.4)

First, enter ';' for 'PLC' 

and ';*' for 'Peripheral', 

and then enter a line 

statement.
7.2.2 Entering statements 7 - 5
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■ Entering P statements and I statements

The following explains the method for entering a P statement or I statement.

Operating procedure
 

1. Select [Edit] ⇒ [Documentation] ⇒ [Statement]) (  ).
The statement entry mode is established.

2. Move the cursor to the pointer number or interrupt pointer number where a P 
statement or I statement is entered.

3. Press the  key.
The Enter P/I Statement screen is displayed.

4. Select the statement type ("In PLC" or "In 
Peripheral").

5. Enter a P or I statement.

6. Click the  button.
The entered P or I statement is displayed on the editing screen.
P and I statements are enclosed by brackets [ ].

7. To disable the P statement/I statement entry mode, select [Edit] ⇒ [Documentation] 
⇒ [Statement] (  ) again.
The statement entry mode is disabled.
7 - 6 7.2.2 Entering statements
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7.2 Editing Statements and Notes
● P or I statements can be entered on the Enter Symbol screen.
Move the cursor to the pointer number or interrupt pointer number where a P or I statement is entered and 

press the  key.
The Enter Symbol screen is displayed. Enter a line statement as shown below.

● Displaying statements on the editing screen.
Display/hide of statements can be switched by selecting [View] ⇒ [Statement]. (  Section 2.2.4)

Following the already 

entered pointer number 

or interrupt pointer 

number, enter ';' for 

'PLC' and ';*' for 

'Peripheral', and then 

enter a P or I statement.
7.2.2 Entering statements 7 - 7
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7.2.3 Modifying and deleting statements

This section explains the method for modifying and deleting statements.

■ Modifying statements

The following explains the method for modifying a statement.

Operating procedure
 

1. Select [Edit] ⇒ [Documentation] ⇒ [Statement]) (  ).
The statement entry mode is established.

2. Move the cursor to the statement to be modified.

3. Press the  key.
For line statements, the Enter Line Statement 
screen is displayed.

For P and I statements, the Enter P/I Statement 
screen is displayed.

4. Change the type and/or modify the 
statement.

5. Click the  button.
The modified statement is displayed on the editing screen.

6. To disable the statement entry mode, select [Edit] ⇒ [Documentation] ⇒ 
[Statement] (  ) again.
The statement entry mode is disabled.
7 - 8 7.2.3 Modifying and deleting statements
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7.2 Editing Statements and Notes
● Statements can be modified on the Enter Symbol screen.
Move the cursor to the statement to be modified and press the  key.
The Enter Symbol screen is displayed. Modify the statement as shown below. 

● Displaying statements on the editing screen.
Display/hide of statements can be switched by selecting [View] ⇒ [Statement]. (  Section 2.2.4)

Do not delete ';', pointer number or 

interrupt pointer number when modifying 

a statement.

When changing 'PLC' to 'Peripheral', 

enter '*' after ';'.

When changing 'Peripheral' to 'PLC', 

delete '*' postfixed to ';'.

Line statement P statement I statement
7.2.3 Modifying and deleting statements 7 - 9
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■ Deleting statements

The following explains the method for deleting a line statement, P statement or I statement.

Operating procedure

1. Move the cursor to the statement to be deleted.

2. Press the  key.
The statement is deleted.

● Displaying statements on the editing screen
Display/hide of statements can be switched by selecting [View] ⇒ [Statement]. (  Section 2.2.4)
7 - 10 7.2.3 Modifying and deleting statements
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7.2 Editing Statements and Notes
7.2.4 Entering notes

This section explains the method for entering notes in a program.

Operating procedure
 

1. Select [Edit] ⇒ [Documentation] ⇒ [Note] (  ).
The note entry mode is established.

2. Move the cursor to the coil or application instruction to which a note is appended.

3. Press the  key.
The Enter Note screen is displayed.

4. Select the note type ("In PLC" or "In 
Peripheral").

5. Enter a note.

6. Click the  button.
The entered note is displayed on the editing screen.
When "In Peripheral" is selected, '*' is automatically prefixed to the note.

7. To disable the note entry mode, select [Edit] ⇒ [Documentation] ⇒ [Note] (  ) 
again.
The note entry mode is disabled.

Item Toolbar

Note
7.2.4 Entering notes 7 - 11
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● Notes can be entered on the Enter Symbol screen.
Move the cursor to the coil or application instruction to which a note is appended and press the  key.
The Enter Symbol screen is displayed. Enter a note as shown below.

● Displaying notes on the editing screen.
Display/hide of notes can be switched by selecting [View] ⇒ [Note]. (  Section 2.2.4)

Following the already entered 

device/instruction, enter ';' for, 

'PLC' and ';*' for 'Peripheral' first, 

and then enter a note.
7 - 12 7.2.4 Entering notes
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7.2 Editing Statements and Notes
7.2.5 Modifying and deleting notes

This section explains the method for modifying and deleting notes.

■ Modifying notes

The following explains the method for modifying a note.

Operating procedure
 

1. Select [Edit] ⇒ [Documentation] ⇒ [Note] (  ).
The note entry mode is established.

2. Move the cursor to the note to be modified.

3. Press the  key.
The Enter Note screen is displayed.

4. Change the type and/or modify the note.

5. Click the  button.
The modified note is displayed on the editing 
screen.

6. To disable the note entry mode, select [Edit] ⇒ [Documentation] ⇒ [Note] (  ) 
again.
The note entry mode is disabled.
7.2.5 Modifying and deleting notes 7 - 13
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■ Deleting notes

The following explains the method for deleting a note.

Operating procedure
 

1. Move the cursor to the note to be deleted.

2. Press the  key.
The note is deleted.

● Notes can be modified or deleted on the Enter Symbol screen.
Move the cursor to the coil or application instruction whose note is deleted or modified and press the  key.
The Enter Symbol screen is displayed. Modify or delete the note as shown below.

● Displaying notes on the editing screen.
Display/hide of notes can be switched by selecting [View] ⇒ [Note]. (  Section 2.2.4)

Do not delete '; (*)' when modifying a note.

Delete '; (*)' as well when deleting a note.

When changing 'PLC' to 'Peripheral', enter 

'*' after ';'.

When changing 'Peripheral' to 'PLC', delete 

'*' postfixed to ';'.
7 - 14 7.2.5 Modifying and deleting notes
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7.3 Batch Editing Statements and Notes
7.3 Batch Editing Statements and Notes

This section explains the method for batch editing statements and notes.
Note that the setting function related to the PLC and Peripheral types described in this section cannot be 
used.
(For PLC and Peripheral types, refer to the following. (  Section 7.2.1)

Screen display

Select [Edit] ⇒ [Documentation] ⇒ [Statement/Note Batch Edit].

Restrictions

Batch editing of statements and notes cannot be performed when function blocks are used in a program.

QCPU

Q

Batch Edit screen for notes

Batch Edit screen for I statements

Batch Edit screen for P statements

Batch Edit screen for line statements
7.3 Batch Editing Statements and Notes 7 - 15
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Display contents

Screen button

●

Changes the type between 'PLC' and 'Peripheral'.

●

Inserts a line above the selected line statement.

●

Inserts a line below the selected line statement.

●

Deletes a line statement.

●

"Edit" : Moves the statement upward.
"Find" : Executes search in the upward direction from the selected statement or note.

●

"Edit" : Moves the statement downward.
"Find" : Executes a search in the downward direction from the selected statement or note.

●

Moves the cursor to the selected statement or note on the editing screen.

Item Description

Tab

Line Statement Displays the batch-edit screen for line statements.
P Statement Displays the batch-edit screen for P statements.
I Statement Displays the batch-edit screen for I statements.
Note Displays the batch-edit screen for notes.

Step
Line Statement Displays the start step numbers of all ladder blocks in the program.
Note Displays the step numbers of all coils and application instructions in the program.

Pointer
P Statement Displays all pointer numbers in the program.
I Statement Displays all interrupt pointer numbers in the program.
7 - 16 7.3 Batch Editing Statements and Notes
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7.3 Batch Editing Statements and Notes
■ Modifying statements and notes

The following explains the method for modifying a statement or note.

Operating procedure

1. Select a statement or note to be modified.

2. Modify the statement or note.

■ Changing the type of statements and notes

The following explains the method for changing the 'PLC' or 'Peripheral' type of a statement or note.

Operating procedure

1. Select a range in which the type is 
changed.

2. Select the statement/note type ("In 
PLC" or "In Peripheral").

3. Click the  button.
The type is changed.
A * symbol is appended to a statement or note 
set as 'Peripheral'.

Select

Select

Change from 'PLC' to 'Peripheral'
7.3 Batch Editing Statements and Notes 7 - 17
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■ Inserting lines within line statements

The following explains the method for inserting a line within line statements.

Operating procedure

1. Select a statement for which a line is to 
be inserted.

2. Select the statement type ("In PLC" or 
"In Peripheral").

3. Click the  or  button.

: Inserts a blank line above the cursor 
position.

: Inserts a blank line below the cursor position.

4. Select the inserted line and enter a statement.

■ Deleting lines of line statements

The following explains the method for deleting a line of line statements.

Operating procedure

1. Select the line statement to be deleted.

2. Click the  button.
The selected line statement is deleted.

Select

Select
7 - 18 7.3 Batch Editing Statements and Notes
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7.3 Batch Editing Statements and Notes
■ Moving statements or notes

The following explains the method for moving a statement or note.

Operating procedure

1. Select a statement or note to be 
moved.

2. To move a line statement, select the 
type ("Line" or "Ladder").
"Line" : Moves the selected line 

statement in unit of line.
"Ladder" : Moves the selected line 

statement in unit of ladder 
block.

3. Click the  or  button.
 : Moves the selected statement or note upward.
 : Moves the selected statement or note downward.

Select
7.3 Batch Editing Statements and Notes 7 - 19
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Editing examples)

Moving Step 59 upward in unit of line

Select

Select

The line statement one  

above the selected 

statement is deleted, and 

the selected statement 

moves upward.
7 - 20 7.3 Batch Editing Statements and Notes
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7.3 Batch Editing Statements and Notes
Moving Step 59 upward in unit of ladder block

Select

Select

The unit of line 

statements one step 

above the selected 

statement is deleted, and 

the selected statement 

moves one step upward.
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■ Searching for statements and notes

The following explains the method for searching for a statement or note.

Operating procedure

1. Enter a statement or note to be 
searched for in the "Find" field.

2. Click the  or  button.
 : Starts searching in the upward 

direction from the selected 
position.

 : Starts searching in the 
downward direction from the 
selected position.

3. The cursor moves to the searched statement or note.

Enter

Searched statement
7 - 22 7.3 Batch Editing Statements and Notes
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7.3 Batch Editing Statements and Notes
■ Jumping to specified statement and note

The following explains the method for jumping to a specified statement or note.

Operating procedure

1. Select a statement or note for 
the jump target.

2. Click the  button.
The cursor jumps to the selected statement or note on the editing screen. 

Select
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7.4 Changing the Type (PLC/Peripheral) of Statement/Note

This section explains the method for changing the type of statement or note to PLC or Peripheral.

Screen display

Select [Find/Replace] ⇒ [Switch Statement/Note Type].

 

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched statement or note.

3. Click the  or  button to change the type.
The type is changed, and the search for the next statements or notes continues.
If the  button is clicked, the types are batch replaced for all searched statements or 
notes.

Restrictions

This operation is applicable only to the converted data.

Item Description

Object Check this to select the target whose type is changed. Multiple objects can 
be selected.

Type
Change in PLC Select this to change 'Peripheral' to 'PLC'.
Change in Peripheral Select this to change 'PLC' to 'Peripheral'.

Find 
Direction

Down from Head Select this to execute a search in the downward direction from the start of the 
program regardless of the current cursor position.

Down from Cursor Select this to execute a search in the downward direction from the cursor 
position.

Specified Range Select this to execute a search in the range set by the entered step numbers.

QCPU

Q

7 - 24 7.3 Batch Editing Statements and Notes
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7.5 Merge Process when Reading Programs from Programmable Controller CPU
7.5 Merge Process when Reading Programs from Programmable Controller CPU

This section explains the merge process when reading sequence programs contain Peripheral 
statements/notes created in the project without labels from the programmable controller CPU.

7.5.1 Merge process

The character data of Peripheral statements/notes are not written to the programmable controller CPU 
when sequence programs are written to the programmable controller CPU.
By executing the merge process when reading sequence programs from the programmable controller 
CPU, the character data of Peripheral statements/notes saved in the personal computer are merged 
with the sequence programs stored in the programmable controller CPU and displayed in the ladder.

The following table shows the different process status with the execution of the merge process when 
reading programs from the programmable controller CPU.

Table 7.5.1-1 Merge process status of Peripheral statement/note

Setting CPU type Type Process status

Not executing the 
merge process QCPU

Peripheral statement
Character data are not read.

Peripheral note

Executing the merge 
process QCPU

Peripheral statement
Character data are read.

Peripheral note

QCPU

Q

Sequence program data written to the 

programmable controller CPU

Sequence program data saved in the 

personal computer

Write to PLC

Character data of 

Peripheral statements 

and Peripheral notes 

are not written to the 

programmable controller

CPU.

Read from PLC

Merge process is 

performed when data are 

read from the programmable 

controller CPU.

<QUPU>

Character data 

are read.
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7.5.2 Performing merge process

This section explains the method for performing the merge process when reading sequence programs 
from the programmable controller CPU.

Operating procedure

1. Open the sequence program (project) saved in the personal computer.
Open the sequence program (project) which is the same data as the sequence program (project) to 
be read from the programmable controller CPU.
For the method for opening a project, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common) 

2. Select [Online] ⇒ [Read from PLC] (  ).
The Online Data Operation screen is displayed.
The Read from PLC function (  Section 9.1)

3. Check the "Merge Peripheral Statement/Note" item under "Option" on the Program 
Detail Setting screen, and execute the Read from PLC function.

4. Confirm if the statements and/or notes of the read sequence program are entered at 
the correct positions.

● When a statement or note is not entered at the correct position
Correct the statement and note positions by the statement/note batch editing function if the statement or note is not 
entered at the correct position after performing the merge process. (  Section 7.3)
7 - 26 7.5.2 Performing merge process
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7.6 Editing SFC Comments
7.6 Editing SFC Comments

This section explains the method for creating and editing SFC comments.
SFC comment is a generic term for 'SFC step comments' that are appended to SFC steps, and 
'transition comments' that are appended to transitions in the created SFC diagrams.
The following shows the example of entering 'Step comment' at 'Block: 0, SFC step: 1'.

Operating procedure

1. Select [Edit] ⇒ [Documentation] ⇒ [SFC Step/Edit Step Comment]. 
The editing screen changes to the SFC comment editing mode. 

2. Move the cursor to the position where the SFC comment is 
entered.

3. Press the  button.
The Input Device Comment screen is displayed.

4. Enter the SFC comment.
The line wrapping of the SFC comment display can 
be checked when the comment is entered.

5. Click the  button.
The entered SFC step comment is displayed as shown on the right.

● Disabling the SFC comment editing mode
To disable the SFC comment editing mode, select [Edit] ⇒ [Documentation] ⇒ [SFC Step/Edit Step Comment] 
again and uncheck the item.

● Creating SFC comments
SFC comments can be created on the Enter SFC Symbol screen when entering SFC symbols, or by using the 
device comment editor. When creating SFC comments in the device comment editor, specify the device name as 
shown below.
• For QCPU (Q mode)

SFC step comment : BLm\Sn
Transition comment: BLm\TRn
(m: block number, n: SFC step/transition number)

● Saving SFC comments
The created SFC comments are saved in the device comment data.
To recover SFC comments when reading SFC programs from the programmable controller CPU, write/read device 
comments to/from the programmable controller CPU.

QCPU

Q
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This chapter explains the method for converting created programs.
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8.1 Converting Ladder Blocks

This section explains the method for converting a created ladder block.
The ladder conversion confirms edited contents of the ladder block.

Operating procedure

• Select [Convert/Compile] ⇒ [Ladder Conversion].
The unconverted ladder block is converted.
 

● For a project using labels
Perform the compilation after converting ladder blocks. (  Section 8.4, 8.5)

QCPU

Q

Unconverted ladder 

block is displayed 

in gray.
8 - 2 8.1 Converting Ladder Blocks
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8.2 Converting SFC Diagrams
8.2 Converting SFC Diagrams

This section explains the method for converting SFC diagrams created in the project without labels.
For projects with labels, SFC diagrams are converted by the compilation.
(  Section 8.4, 8.5)

Operating procedure

• Select [Convert/Compile] ⇒ [Change SFC All].
The conversion result of the SFC diagrams is displayed in the Output window.
By double clicking the result, the corresponding error location in the program is displayed.

 

● Checking the conversion status
The conversion status can be checked in the Project window. A symbol ( ) is appended to programs in 
unconverted status.

QCPU

Q

Unconverted

Unconverted Converted

Conversion
8.2 Converting SFC Diagrams 8 - 3
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8.3 Checking Programs

This section explains the method for checking errors, such as duplicated coils or device range, in the 
programs created in the project without labels.
The check result is displayed on the Output widow.
For projects with labels, programs are checked by the compilation.
(  Section 8.4, 8.5)

Screen display

Select [Tools] ⇒ [Program Check].

Operating procedure

1. Set the items on the screen.

item Description

Check

Select the item(s) for checking the program.

Check Target −

Target the Whole Program Select this to check all programs in the project.
Target the Current Program Select this to check only the program being displayed.
SFC Check Data −

Target All Blocks Select this to check the SFC block list that includes the SFC blocks being 
displayed.

Current Block Select this to check only SFC blocks being displayed.

QCPU

Q

Check item Description

Instruction Check Checks if the instruction can be used for the CPU 
type of the project being edited.

Ladder Check Checks if the ladder is created properly.

Consistency (pair) 
Check

Checks the program consistency for such case as no 
pointer at the jump destination or no RET instruction 
in the subroutine program.

Double Coil Check Checks the duplicated coils.

Device Check Checks if the device being used is within the range 
set in the parameter. 
8 - 4 8.3 Checking Programs
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8.3 Checking Programs
2. Click the  button.
The program is checked and the result is displayed in the Output window.
By double clicking the result, the corresponding error location in the program is displayed.
8.3 Checking Programs 8 - 5
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8.4 Compiling All Programs

This section explains the method for batch compiling all programs in the project.
Programs are compiled to sequence programs that can be executed on the programmable controller CPU.

Operating procedure

• Select [Convert/Compile] ⇒ [Rebuild All] (  ).
All programs are compiled and the result is displayed in the Output window.

QCPU

Q

Compiles all programs

Rebuild All

Program 2

 

Program 1

Program 3

Sequence 

program 1

Sequence 

program 2

Sequence 

program 3

Output window
8 - 6 8.4 Compiling All Programs
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8.4 Compiling All Programs
● Checking the compilation status
The compilation status can be checked in the Project window. A symbol ( ) is appended to programs in 
uncompiled status.

● Checking errors and warnings when compiling programs
For checking errors and warnings when compiling programs, refer to the following section.
(  Section 8.8)

● Label assignment when compiling all programs
When all programs are compiled, devices are reassigned to labels in all programs.

Uncompiled

Uncompiled

Compilation

Compiled
8.4 Compiling All Programs 8 - 7
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8.5 Compiling Only Modified Programs

This section explains the method for batch compiling the uncompiled programs in the project.
Programs are compiled to sequence programs that can be executed on the programmable controller CPU.
Since this process compiles only uncompiled programs, the compiling time can be reduced.

Operating procedure

• Select [Convert/Compile] ⇒ [Build] (  ).
Programs are compiled and the result is displayed in the Output window.

QCPU

Q

 

Compiles uncompiled programs

Build

 

Program 1

Program 2

Program 3

Sequence 

program 1

Sequence 

program 2

Sequence 

program 3

Output window
8 - 8 8.5 Compiling Only Modified Programs
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8.5 Compiling Only Modified Programs
● Checking the compilation status
The compilation status can be checked in the Project window. A symbol ( ) is appended to programs in 
uncompiled status.

● Checking errors and warnings when compiling programs
For checking errors and warnings when compiling programs, refer to the following section.
(  Section 8.8)

● Label assignment when compiling programs
When programs are compiled, devices are reassigned to labels in uncompiled programs only.

Uncompiled
Uncompiled

Compilation

Compiled
8.5 Compiling Only Modified Programs 8 - 9
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8.6 Precautions on Compilation

● Assigning devices automatically
When a program is compiled or all programs are compiled, the assignment of devices to labels is 
changed.
Therefore, the programmable controller CPU must be reset after writing programs to it.

● Modification of global labels and function blocks
If global labels and/or function blocks are modified, multiple programs become the compile targets. 
Write all program files of the compile targets to the programmable controller CPU to apply the 
modifications.

Example) Compiling programs after modifying Function block 1 in the following program 
configuration.
Function block 1 is compiled and the program files MAIN and SUB1 are modified.

QCPU

Q

Program configuration of the Simple project

Project

FB_Pool

Sequence program

MAIN

Sequence program

SUB1

Function block 2

Function block 1

SUB1

MAIN

Function block 1 is used 

in the program files 

MAIN and SUB1  

Program_Pool
8 - 10 8.6 Precautions on Compilation
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8.7 Executing Online Change Simultaneously with Ladder Conversion/Compilation
8.7 Executing Online Change Simultaneously with Ladder Conversion/Compilation
For the operation for executing the Online change simultaneously with the ladder conversion/compilation, 
refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)

8.8 Checking for Errors and Warnings when Compiling Programs

This section explains the method for checking errors/warnings when compiling programs.
When all or uncompiled programs are compiled, the target programs and label settings are checked and the 
results are displayed on the Output window.
The following explains the checking method and the corrective action to be taken on occurrence of errors and 
warnings.

Operating procedure

1. Double click the error/warning message displayed in the Output window.
The corresponding error location in the program is displayed.

2. Check the corresponding error location and correct the program as instructed by 
the error/warning message.

QCPU

Q

Double click

Error

Error code

Error description
8.8 Checking for Errors and Warnings when Compiling Programs 8 - 11
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8.9 Changing Operating Conditions of Compilation

This section explains the method for changing the operating conditions of compilation.

8.9.1 Changing the number of errors and warnings that stops 
compilation

This section explains the method for changing the number of errors and warnings that stops 
compilation.
If the number of errors and warnings that occurred during compilation reaches the specified value, the 
compilation is aborted.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Compile" ⇒ "Output Result".

Operating procedure

• Set the items on the screen.

Item Description
Error Set the number of errors that stops compilation (1 to 9999).
Warning Set the number of warnings that stops compilation (1 to 9999).

QCPU

Q

8 - 12 8.9 Changing Operating Conditions of Compilation
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8.9 Changing Operating Conditions of Compilation
8.9.2 Hiding warning messages

This section explains the method for hiding messages displayed in the Output window when compiling 
programs.
The registered warnings are not displayed in the Output window.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Compile" ⇒ "Output Result".
 

Operating procedure

• To register the warnings, enter the warning code and click the  button.
The registered warnings are not displayed in the Output window.

• To cancel the registration, select the warning code and click the  button.
The unregistered warnings are displayed in the Output window.

● Warning codes
Warning codes and their contents can be checked in the Output window when compiling programs.
 (  Section 8.8)

● Copying warning codes

Warning codes displayed in the Output window can be copied (  +  ) and pasted (  +  ) to 
the "Disable Warning Codes" entry field.

● Maximum number of warnings to be invalidated
The maximum number of warnings to be invalidated is 100.

Enter

Select
8.9.2 Hiding warning messages 8 - 13
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9 WRITING/READING DATA TO/
FROM PROGRAMMABLE 
CONTROLLER CPU

This chapter explains the method for writing/reading sequence programs to/from the programmable controller 
CPU or memory card.

For the overview of the data write/read operation, refer to the following manual.
  GX Works2 Version1 Operating Manual (Common)
A

A
P

PE
N

D
IX

I

IN
D

E
X

9.1    Writing/Reading Data to/from Programmable Controller CPU  . . . . . 9-2
9 - 1
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9.1 Writing/Reading Data to/from Programmable Controller CPU

This section explains the method for writing the Simple project data to the programmable controller CPU or 
memory card, and the method for reading the data from the programmable controller CPU or memory card to 
the project.

Screen display

Select [Online] ⇒ [Write to PLC] ( )/[Read from PLC] ( ).
<Write to PLC screen for the projects without labels>

<Write to PLC screen for the projects with labels>
The symbolic information is displayed for the projects with labels.

QCPU

Q

File list

Memory 

capacity

File list

Memory 

capacity
9 - 2 9.1 Writing/Reading Data to/from Programmable Controller CPU
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9.1 Writing/Reading Data to/from Programmable Controller CPU
Operating procedure

1. Set the items on the screen.

When a program (program file), device comment or device memory is selected, the range can be 
set by clicking the  /  button.
When reading data from the programmable controller CPU, and the device memory is selected, the 
detailed settings are required.
For details, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)

2. Click the  button.
When the Write to PLC function is executed, the specified data are written to the target memory. 
When the Read from PLC function is executed, the specified data are read from the target memory.

Screen button

●

Displays the illustration of the connection channel list.

●

Selects the parameters and all programs displayed in the list.

●

Selects all data displayed in the list.

●

Cancels the selection status of all data displayed in the list.

●  / 
Switches display/hide of the Related functions button.
For details of the related functions, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)

●  (Read from PLC, Delete PLC Data only)
Displays the project name of the symbolic information in the Title/Project Name column.
It is not displayed for projects without labels.

●

Updates data list, writing size, free space volume, and used space volume on the Online Data 
Operation screen.
When multiple personal computers are connected to the programmable controller CPU, update the 
target memory before reading data from the programmable controller CPU.

Item Description
Connection Channel List Displays the information on the set connection target.

Title Displays the title of the target memory by clicking the   
button.

File list −

Target Select the data to be written/read.

Target Memory
Select the memory from the list ( ) by clicking the cell under "Target 
Memory".
For details of the memory card application, refer to the following manual.

 QCPU User's Manual (Hardware Design, Maintenance and Inspection)
Memory capacity −

Writing Size Displays the total size of written data checked in "Target".
Free Volume Displays the free space volume of the target memory.
Use Volume Displays the used space volume of the target memory.
9.1 Writing/Reading Data to/from Programmable Controller CPU 9 - 3
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■ Symbolic information

The symbolic information is data that store the program configuration such as structures and labels.
To restore these data included in the symbolic information when reading a program from the 
programmable controller CPU, write/read the symbolic information to/from the programmable controller 
CPU.
Data such as structures and labels included in the symbolic information cannot be restored if only 
sequence programs are read.

The following table shows the program data included in the symbolic information.

Table 9.1-1Data included in the symbolic information

Item Included data

Symbolic information

Structures
Global labels
Local labels
Programs
Function blocks

● Compile status when the symbolic information is read
• When the symbolic information and parameters are read simultaneously, and the data in the symbolic 

information match with parameters and programs (program files) in the programmable controller CPU, the read 
data are in compiled status.

• When only the symbolic information is read, the read data are in uncompiled status.
• When the symbolic information of GX Developer or GX IEC Developer is read, the read data are in uncompiled 

status. Compile the program again after executing the Read from PLC function.
● Precautions for reading symbolic information

For the precautions for reading label programs (symbolic information) of the existing application using GX Works2, 
or reading label programs (symbolic information) of GX Works2 using the existing application, refer to the following 
manual.
(  GX Works2 Version1 Operating Manual (Common))

GX Work2

Symbolic information Compile

Sequence program A

Sequence program B

Sequence program C
Write to PLC

Sequence program A

Sequence program B

Sequence program C

Symbolic information

Programmable controller CPU
9 - 4 9.1 Writing/Reading Data to/from Programmable Controller CPU
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10 MONITORING
This chapter explains the method for monitoring the program execution status of the programmable controller 
CPU using the program editor.
For the overview of monitoring, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)
A

A
P

PE
N

D
IX

I

IN
D

E
X

10.1    Starting and Stopping Monitoring of Programs . . . . . . . . . 10-2
10.2    Starting and Stopping Monitoring of Function Blocks  . . . 10-3
10.3    Changing Operating Conditions of Monitoring  . . . . . . . . . 10-4
10.4    Monitoring Ladder Programs . . . . . . . . . . . . . . . . . . . . . . . . 10-6
10.5    Monitoring SFC Programs . . . . . . . . . . . . . . . . . . . . . . . . . . 10-7
10 - 1
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10.1 Starting and Stopping Monitoring of Programs

This section explains the method for monitoring a program.
Open the program editor to be monitored in advance.

■ Starting monitoring of programs

The following explains the method for starting monitoring of the program.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] (  ).
The monitoring starts.

■ Stopping monitoring of programs

The following explains the method for stopping monitoring of the program.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Stop Monitoring] (  ).
The monitoring stops.

● Changing current values
During monitoring, bit devices can be forced ON/OFF and the current values of devices, buffer memories, and 
labels can be changed.
For forcing bit devices ON/OFF and changing current values, refer to the following manual.

 GX Works2 Version1 Operating Manual (Common)
● ON/OFF status display

During monitoring, the ON/OFF status of bit device is displayed as 
shown on the right.
*1 Only comparison instructions that are equivalent to contacts, and 
SET, RST, PLS, PLF, SFT, SFTP, MC, FF, DELTA, and DELTAP 
instructions that are equivalent to coils are supported.

QCPU

Q

10 - 2 10.1 Starting and Stopping Monitoring of Programs
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10.2 Starting and Stopping Monitoring of Function Blocks
10.2 Starting and Stopping Monitoring of Function Blocks

This section explains the method for monitoring function block programs.
Open the function block program to be monitored in advance.

■ Starting monitoring of function blocks

The following explains the method for starting monitoring of the function block.

Operating procedure

1. Select [Online] ⇒ [Monitor] ⇒ [Change Instance (Function Block)].
The Change Instance (Function Block) screen is displayed.

2. Select the FB instance to be monitored.

3. Click the  button.

4. Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] (  ).
The monitoring starts.
The display and executable operations during monitoring are the same as those of the program 
monitoring. (  Section 10.1)

Screen button

●

Cancels the selected status of the FB instance and stops monitoring.

■ Stopping monitoring of function blocks

The following explains the method for stopping monitoring of the function block.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Stop Monitoring] (  ).
The monitoring stops.

QCPU

Q

10.2 Starting and Stopping Monitoring of Function Blocks 10 - 3
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10.3 Changing Operating Conditions of Monitoring

This section explains the method for changing the operating conditions of monitoring.

10.3.1 Changing current value display format (decimal/
hexadecimal) of word type variable 

This section explains the method for changing the current value display format of word type variable 
displayed during monitoring.

■ Changing display format during monitoring

The following explains the method for changing the current value display format of word type variable 
during monitoring.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Change Value Format (Decimal)] / [Change Value Format 
(Hexadecimal)].

■ Changing display format before starting monitoring

The following explains the method for changing the current value display format by setting the option.
The monitoring starts with the set display format.

Operating procedure

• Select [Tools] ⇒ [Options] ⇒ "Monitor" ⇒ "Ladder" ⇒ "Display Format of Monitoring 
Value" ⇒ "Decimal"/"Hexadecimal".

QCPU

Q

Decimal Hexadecimal
10 - 4 10.3 Changing Operating Conditions of Monitoring
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10.3 Changing Operating Conditions of Monitoring
10.3.2 Monitoring buffer memory and link memory

Select whether to monitor the buffer memory and link memory at monitoring.
The scan time of the programmable controller CPU can be reduced by not monitoring the buffer 
memory and link memory.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Monitor" ⇒ "Ladder" ⇒ "Operation Setting", and check or uncheck the 
"Monitor buffer memory and link memory" item.

 

10.3.3 Displaying/hiding current values

This section explains the method for displaying/hiding current values of word type variable.

Screen display

Select [Tools] ⇒ [Options] ⇒ "Monitor" ⇒ "Ladder" ⇒ "Current Value Display", and check or uncheck 
the "Display lines of monitored current value" item.

Example)

Current  

value display

Monitoring with displaying current values. Monitoring without displaying current values.
10.3.2 Monitoring buffer memory and link memory 10 - 5



10 MONITORING
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10.4 Monitoring Ladder Programs

This section explains the method for monitoring a ladder program.
Open the program editor to be monitored in advance.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ).
The monitoring starts.

● ON/OFF status display
During monitoring, the ON/OFF status of bit device is displayed as 
shown on the right.

*1: Only comparison instructions that are equivalent to contacts, 
and SET, RST, PLS, PLF, SFT, SFTP, MC, FF, DELTA, and 
DELTAP instructions that are equivalent to coils are supported.

QCPU

Q

Displays ON/OFF 

status of contact/coil.

ON :

OFF :
Displays current value of 

word device.
10 - 6 10.4 Monitoring Ladder Programs
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10.5 Monitoring SFC Programs
10.5 Monitoring SFC Programs

This section explains the method for monitoring SFC diagrams and SFC block list of SFC program.
Open the program editor to be monitored in advance.
The monitoring of the Zoom screen is same as monitoring of ladder programs. (  Section 10.4)

10.5.1 Monitoring SFC diagrams

This section explains the method for monitoring active steps, inactive steps, and steps being on hold in 
the SFC diagram.

■ Starting monitoring of the SFC diagram

The following explains the method for starting monitoring of the SFC diagram.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ).
The monitoring starts.

 

Display contents

Description

 (Blue) Active step

 (White) Inactive step

 (Yellow) A step specified as a hold step and being on hold.

● Editing SFC programs
The SFC diagrams cannot be edited during monitoring.

QCPU

Q

10.5 Monitoring SFC Programs 10 - 7
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■ Displaying start destination blocks

The following explains the method for displaying a start destination block when there is a block start 
step in the SFC diagram being monitored.

Operating procedure

• Move the cursor to the block start step, and select [View] ⇒ [Open Zoom/START 
Destination SFC Block].
The start destination block is displayed.

■ Auto scroll monitoring

The following explains the method for scrolling the screen to display active steps automatically when 
they are out of the screen during monitoring.

Operating procedure

1. Select [Online] ⇒ [Monitor] ⇒ [SFC Auto Scroll Monitor] ( ).

2. Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ).
While the auto scroll monitor function is activated, active steps are scrolled on to the screen 
automatically when they are out of the screen.  

● Another method for displaying start destination blocks

A start destination block can be displayed by double clicking the block start step while pressing the  key.

● Starting method for the auto scroll monitor function
The auto scroll monitor function also can be started by selecting [Online] ⇒ [Monitor] ⇒ [SFC Auto Scroll Monitor] 
during monitoring.

● When multiple steps are active in series
For multiple active steps in series caused by the action saving steps, active steps close to initial steps are 
displayed when the auto scroll monitor function is activated.

● Operations when setting options
When the "Open Zoom in new window" item is checked under [Tools] ⇒ [Options] ⇒ "Program Editor" ⇒ 
"SFC" ⇒ "Zoom", and the auto scroll monitor function is executed, the following message is displayed. If "Yes" is 
selected, the SFC diagram and the Zoom screen are synchronized, and the operation output/transition condition 
programs that correspond to the active steps are monitored automatically. If "No" is selected, only the SFC 
diagram is monitored.
Note that the program cannot be edited on the Zoom screen that is displayed when the auto scroll monitor function 
is activated.

 

10 - 8 10.5.1 Monitoring SFC diagrams
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10.5 Monitoring SFC Programs
10.5.2 Monitoring transitions

This section explains the method for monitoring SFC steps that do not transfer after passing the 
specified time using the transition monitoring function.

Operating procedure

1. Select [Tools] ⇒ [Options] ⇒ "Monitor" ⇒ "SFC", and set the items in the "Transfer 
Watch Monitor".

For details of the setting items, refer to Section 11.2.

2. Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ).
While the transition monitoring function is activated, the following warning message is displayed 
when a SFC step that does not transfer after passing the specified time is detected.
Note that the display of the warning message may be delayed from the specified time depending 
on the operating system of the personal computer.

• The corresponding SFC step in the SFC diagram is displayed by clicking the    
button.

• When the "Stop transition monitoring at detection" item is checked in the "Transition 
Monitoring" setting, the transition monitoring function is stopped by the detection of an error 
step, but the normal monitoring continues operating.

10.5.3 Monitoring operation outputs and transition conditions

This section explains the method for monitoring operation outputs/transition conditions of SFC steps/
transitions on the Zoom screen.

Operating procedure

1. Select [View] ⇒ [Open Zoom/START Destination SFC Block].
The Zoom screen is displayed.
10.5.2 Monitoring transitions 10 - 9
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2. Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ). 
The monitoring starts.
For details of the monitoring, refer to Section 10.4.

10.5.4 Batch monitoring all blocks, monitoring active steps

This section explains the method for monitoring the active/inactive status of all blocks and step active/
inactive status of the specified block in the list display during the execution of the SFC program.

■ Batch monitoring all blocks

The following explains the method for monitoring the active/inactive status of all blocks in the list 
display.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [SFC All Block Batch Monitor] ( ).
The SFC All Block Batch Monitor screen is displayed.

Display contents

Screen button

●  
Monitors the SFC step active/inactive status of the specified block.

 Monitoring SFC step active/inactive status of the specified block

Item Description
Block No. Displays the block number at the cursor position.
Data Name Displays the data name of the block.
Title Displays the title of the block.
10 - 10 10.5.4 Batch monitoring all blocks, monitoring active steps
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10.5 Monitoring SFC Programs
■ Monitoring SFC step active/inactive status of the specified block

The following explains the method for monitoring the SFC step active/inactive status in the list display.

Operating procedure

• Place the cursor at the block to be monitored on the SFC All Block Batch Monitor screen, 
and click the  button.
The Active Step Monitor screen is displayed.

If the program is monitored with the programmable controller CPU that is never set to RUN after 
its reset, all SFC steps are displayed as uncreated steps.
If the program is monitored with the programmable controller CPU set to STOP, the status at the 
STOP setting is displayed as the monitoring result.

 

10.5.4 Batch monitoring all blocks, monitoring active steps 10 - 11
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10.5.5 Monitoring SFC block list

This section explains the method for monitoring a SFC block list.

Operating procedure

1. Select [View] ⇒ [Open SFC Block List].
The SFC block list is displayed.

2. Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ).
The columns of the active block are displayed in blue.
When the block information is set, the ON/OFF status of the block information device/label can be 
checked on the SFC block list.
When the block information is not set, the program is not monitored.
By double clicking the block column during monitoring, the SFC diagram of the specified block is 
displayed. 

 

10 - 12 10.5.5 Monitoring SFC block list
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11 SETTING OPTIONS
This chapter explains the functions of options for setting screen display format or detailed operations of each 
function.
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11 SETTING OPTIONS
GX Works2
11.1 Basic Operations
This section explains the method for setting options.

Screen display

Select [Tools] ⇒ [Options].

Operating procedure

• Set the items on the screen.
When the cursor is placed on a setting item, an explanation of the item is displayed in the 
"Explanation" field.
Details of the setting items  Section 11.2

Screen button

●

Restores the initial settings.

●

Restores the user default settings.

●

Stores the current settings as the user default and applies them to a new project.
11 - 2  
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11.2 Option Setting List
11.2 Option Setting List

The following table shows the option setting items.

Table 11.2-1Option setting items (1/2)

Tree item Item Description Reference
Project Window  GX Works2 Version1 Operating Manual (Common)

Program 
Editor

Structured 
Ladder/ST Tool Hint

 GX Works2 Version 1 Operating Manual (Structured Project)Structured 
Ladder

Label
FB/FUN
Guided

ST

Ladder/SFC Comment  GX Works2 Version1 Operating Manual (Common)

Ladder

Device
Check double coil

Select whether to check duplicated coils 
when entering instruction. Unconverted 
ladder is not the object for duplicated coil 
check.

Section 
5.1.2

Enter device comment Select whether to enter device comment 
continuously after entering instructions.

Comment

Device Comment Select whether to display the label comment 
or the device comment at ladder editor.

Section 
2.2.4Note Select whether to display the note comment 

at ladder editor.

Statement Select whether to display the statement 
comment at ladder editor.

Device Comment 
Display Format

Set the display rows and columns for label 
comment or device comment.

Section 
2.2.5

Ladder 
Diagram

Display Connection of 
Ladder Diagram Set the number of contacts to be displayed. Section 

2.2.6
Display Instruction Help 
at symbol error 
occurrence

Select whether to automatically display 
Instruction Help when symbol errors occur. 

Section 
5.1.1

SFC

Comment
Block List Display device comment on SFC block list. Section 

5.2.10

Step/Transition Display step/transition comment on SFC 
editor.

Section 
2.3.3

SFC Diagram SFC Edit Area
Set SFC edit area when create SFC. Please 
change by "Row of SFC" after creating a 
SFC.

Section 
2.3.4

Zoom Setting of Zoom Display
Set whether to open window to each zoom or 
fix window and change display when open a 
zoom window.

Section 
5.2.8

Device Comment Editor  GX Works2 Version1 Operating Manual (Common)

Label Setting Editor

Automatic copy and 
increment when inserting 
a row

Select whether to copy the texts in the upper 
row after incrementing it when inserting a 
row. Section 

4.5.2
Copy data type/comment 
items

Select if the data type, comment, and remark 
shall be object for auto copy.

Default Length of String 
Data Type

Set the default string length for string data 
type.

Section 
4.5.1

Parameter  GX Works2 Version1 Operating Manual (Common)

QCPU

Q

11 - 3
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Table 11.2-1Option setting items (2/2)

Option tree item Item Description Reference

Monitor

Structured Ladder/ST  GX Works2 Version 1 Operating Manual (Structured Project)

Ladder

Display Format of 
Monitoring Value

Select the display format of the monitored 
value in decimal or hexadecimal.

Section 
10.3.1

Monitor Buffer memory 
and link memory

Select whether to monitor buffer memory and 
link memory during Ladder-monitoring. Scan 
time of PLC will be lengthened depending on 
the setting.

Section 
10.3.2

Display lines of 
monitored current value

Select whether to display rows of the current 
value monitor during Ladder-monitoring.

Section 
10.3.3

SFC

Watch Step Not 
Transferring within 
Watching Time

Select whether to display a warning dialog 
when detect a step that does not transfer 
even if specified time passes while 
monitoring.

Section 
10.5.2

Program/Program File 
Name Select watch target program/program file.

Target All Blocks Specify watch target block.
Specify the Block Specify watch target block.
Stop Transfer Watch 
Monitor when Detected

Select whether to detect other step that does 
not transfer while displaying warning dialog.

PLC Read/Write  GX Works2 Version1 Operating Manual (Common)

Online Change  GX Works2 Version1 Operating Manual (Common)

Compile

Basic Setting

Call Function Block

A function block will be enabled to call from 
ladder to ST or form ST to ladder. And the 
steps after compiling is reduced when a 
function block is called. −

Execution of Program 
Check

Set when you do not execute the program 
check after the build, compile+online change. 
This setting can shorten the compile time.

Output Result

Stop Build Set the number of error and warning to stop 
the compile.

Section 
8.9.1

Disable Warning Codes
Register warning codes to invalidate. The 
registered warning code shall not be 
displayed in output window.

Section 
8.9.2

Structured Ladder/ST  GX Works2 Version 1 Operating Manual (Structured Project)

Intelligent Function Module  GX Works2 Version1 Operating Manual (Common)

Cross Reference Display 
Format

Displays detail information on each data in selection of extension 
display.

(Common)
Project History Operation 

Setting Select whether to register the history after saving a project.
11 - 4  
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APPENDIX
GX Works2
Appendix 1 List of Toolbars and Shortcut Keys

This section shows the list of toolbars and shortcut keys that can be used in Simple project.

For (Common) indicated in the Reference column, refer to the following manual.
 GX Works2 Version1 Operating Manual (Common)

Appendix 1.1 Common toolbars and shortcut keys

The following explains the toolbars that are available regardless of the editing target and the 
corresponding shortcut keys.

■ "Standard" toolbar icons

The following table shows the "Standard" toolbar icons and the corresponding shortcut keys.

Table App.1.1-1 "Standard" toolbar icons and shortcut keys

■ "New Object" toolbar icon

The following table shows the "New Object" toolbar icon.

Table App.1.1-2 "New Object" toolbar

Toolbar 
icon Shortcut key Corresponding menu Description Reference

 + New Creates a new project.

(Common) + Open Opens an existing project.

 + Save Saves the project.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

− New Adds data to a project. (Common)

QCPU

Q

App - 2 Appendix 1.1 Common toolbars and shortcut keys
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Appendix 1 List of Toolbars and Shortcut Keys
■ "Program Common" toolbar icons

The following table shows the "Program Common" toolbar icons and the corresponding shortcut keys.

Table App.1.1-3 "Program Common" toolbar icons and shortcut keys

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference

− Property Displays properties of the selected data. (Common)

 + Cut Cuts the selected data.

Section 
5.1.9 + Copy Copies the selected data.

 + Paste Pastes the cut/copied data at the cursor 
position.

 + Undo Cancels the previous operation. Section 
5.1.10

 +  + Find Searches for a character string. (Common)

− Write to PLC Writes data to the programmable controller 
CPU.

  Chapter 9
− Read from PLC Reads data from the programmable controller 

CPU.

Start Monitoring Starts monitoring the window being operated.   Section 
10.1 

 + Stop Monitoring Stops monitoring the window being operated.

 +  + Build Compiles uncompiled programs.   Section 
8.5 

− Rebuild All Compiles all programs.   Section 
8.4 

−
Start/Stop 
Simulation Starts/stops simulation. (Common)

F

Appendix 1.1 Common toolbars and shortcut keys App - 3
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■ Other shortcut keys

The following table shows other shortcut keys that are available regardless of the editing target.

Table App.1.1-4 Other shortcut keys common to various programs

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference

−  + −
Switches the display of the project data list and 
the uppermost work window. −

−  + −
Closes the window displayed in the uppermost 
position. −

−  + − Moves to the next uppermost window. −

−  + Quit Closes the project being edited and exits GX 
Works2.

(Common)

−  +  + Copy Copies data in the project.

−  +  + Paste Pastes the copied data to a folder.

− Rename Changes the name of the selected data or 
library in the Project window.

−  +  + Add New Module Adds the intelligent function module data to the 
project being edited.

−  +  + Replace Replaces the character string.

−  + Cross Reference Creates the cross reference information.

−  + Device List Displays the device usage list.

−  +  + Down Searches for a device or instruction in the 
downward direction.

−  +  + Up Searches for a device or instruction in the 
upward direction.

−  +  + 
Online Program 
Change

Compiles the program and executes online 
program change.

−  + Start Watching Starts monitoring devices/labels registered to 
the Watch window.

−  +  + Stop Watching Stops monitoring devices/labels registered to 
the Watch window.

E

H

E

D

App - 4 Appendix 1.1 Common toolbars and shortcut keys
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Appendix 1 List of Toolbars and Shortcut Keys
Appendix 1.2 Toolbar icons and shortcut keys for setting labels

The following explains the toolbar icons and the corresponding shortcut keys used for setting labels.

■ "Label" toolbar icons

The following table shows the "Label" toolbar icons and the corresponding shortcut keys.

Table App.1.2-1 "Label" toolbar icons and shortcut keys

■ Other shortcut keys

The following table shows other shortcut keys that are available for setting labels.

Table App.1.2-2 Other shortcut keys for setting labels

Toolbar 
icon Shortcut key Corresponding menu Description Reference

 + New Declaration (Before) Adds a line above the cursor position.
Section 

4.5.2
− New Declaration (After) Adds a line below the cursor position.

 + Delete Line Deletes the line at the cursor position.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference

−  + 
Expand 
Declaration

Displays the comment and remarks of the 
selected line in multiple lines.

Section 
4.5.2−  + 

Collapse 
Declaration

Displays only the first line of the comment and 
remarks of the selected line.

−  + Select All Selects all lines.

− − Moves the cursor one cell to the right. −

−  + − Moves the cursor one cell to the left. −

− −
Changes the mode to the text entry mode if the 
cell is text entry enabled. −

−

 +  /

 +  /

 + 

− Selects cells in one line. −

−

Select the button and press 

the / /  
key

− The related setting screen is displayed. −

−  + −
Allows a line feed while entering a text in the 
"Comment" and "Remark" items.

Section 
4.2, 4.3, 

4.4, 4.6.1
Appendix 1.2 Toolbar icons and shortcut keys for setting labels App - 5
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Appendix 1.3 Toolbar icons and shortcut keys for setting device 
memory

The following explains the toolbar icons and the corresponding shortcut keys used for setting device 
memory.

■ "Device Memory" toolbar icons

The following table shows the "Device Memory" toolbar icons and the corresponding shortcut keys.

Table App.1.3-1 "Device Memory" toolbar icons and shortcut keys

■ Other shortcut keys

The following table shows other shortcut keys available for setting device memory.

Table App.1.3-2 Other shortcut keys for setting device memory

Toolbar 
icon Shortcut key Corresponding menu Description Reference

− Display Mode/Binary Changes display format to binary.

(Common)

− Display Mode/Octal Changes display format to octal.

− Display Mode/Decimal Changes display format to decimal.

−
Display Mode/
Hexadecimal Changes display format to hexadecimal.

− Display Mode/Float Changes display format to real numbers.

− Display Mode/ASCII Changes display format to ASCII.

− Register/16-bit Displays data in units of words.

− Register/32-bit Displays data in units of double words.

− Register/64-bit Displays data in units of 64 bits.

−
Upload Device Memory 
from PLC

Reads data in device memory from a 
programmable controller CPU.

−
Download Device 
Memory to PLC

Writes data in device memory to a 
programmable controller CPU.

− Import from Excel File Reads data from an Excel file.

− Export to Excel File Writes data to an Excel file.

 + Insert Device Enters a device.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

− Insert Row Inserts a row at the cursor position.
(Common)

−  + Find Device Searches for a device.

I

App - 6 Appendix 1.3 Toolbar icons and shortcut keys for setting device memory
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Appendix 1 List of Toolbars and Shortcut Keys
Appendix 1.4 Toolbar icons for executing sampling trace

The following table shows the toolbar icons used for executing sampling trace.

Table Appendix.1.4-1 "Sampling trace" toolbar icons

Toolbar icon Shortcut key Corresponding menu Description Reference

− Trace Setting Displays the Trace Setting screen.

(Common)Trace Start/Stop
Starts or stops sampling trace. To start 
sampling trace, the trace ready signal 
(SM800) must be ON.

− Display Trace Status Displays the Trace Data Storage Status  
screen.

− Monitor Status Displays the current sampling trace status

−

− Execution Failed Indicates the sampling trace stop status, or 
the status sampling trace has not started.

− Before Trigger Indicates the status sampling trace is  
executed but a trigger is not generated.

− After Trigger Indicates the status sampling trace is 
executed and a trigger is generated.

− Stop Indicates the status sampling trace is 
interrupted.

− Completion

Indicates the status sampling trace has 
ended normally by acquiring trace data up 
to the specified total number of samplings 
after generation of a trigger.

− Error Indicates the status a sampling trace error 
occurred during sampling trace.

− Buffer Status
Displayed when the trace data have been 
acquired up to the specified total number of 
samplings.

− Trigger Occurrence Displayed when a trigger is generated 
during sampling trace.

− Zoom Out Timing Chart
Zooms the scale of timing chart

(Common)

− Zoom In Timing Chart

− Zoom Out Trend Graph
Zooms the scale of trend graph

− Zoom In Trend Graph

− Chart/Switching Detail
Switches the trace result display on the 
Sampling Trace screen between the timing 
chart (graph) and the detailed data (value).
Appendix 1.4 Toolbar icons for executing sampling trace App - 7
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Appendix 1.5 Toolbar icons and shortcut keys in program editors

The following explains the toolbar icons and the corresponding shortcut keys used for editing programs 
in each program editor.

■ "Ladder" toolbar icons and shortcut keys

The following table shows the toolbar icons and the corresponding shortcut keys available in the ladder 
editor.

Table App.1.5-1 "Ladder" toolbar icons and shortcut keys (1/2)

Toolbar 
icon Shortcut key Corresponding menu Description Reference

Open Contact Inserts an open contact at the cursor 
position.

Section 
5.1.2

 + Open Branch Inserts an open branch at the cursor 
position.

Close Contact Inserts a close contact at the cursor 
position.

 + Close Branch Inserts a close branch at the cursor 
position.

Coil Inserts a coil at the cursor position.

Application Instruction Inserts an application instruction at the 
cursor position.

Horizontal Line Inserts a horizontal line at the cursor 
position. Section 

5.1.4
 + Vertical Line Inserts a vertical line at the cursor position.

 + Delete Horizontal Line Deletes the horizontal line at the cursor 
position. Section 

5.1.6
 + Delete Vertical Line Deletes the vertical line at the cursor 

position.

 + Rising Pulse Inserts a rising pulse at the cursor position.

Section 
5.1.2

 + Falling Pulse Inserts a falling pulse at the cursor position.

 + Rising Pulse Branch Inserts a rising pulse branch at the cursor 
position.

 + Falling Pulse Branch Inserts a falling pulse branch at the cursor 
position.

 + 
Operation Result Rising 
Pulse

Inserts an operation result rising pulse at 
the cursor position.

 +  + 
Operation Result Falling 
Pulse

Inserts an operation result falling pulse at 
the cursor position.

 +  + Invert Operation Results Inserts an operation result inversion at the 
cursor position.

Edit Line Inputs a line at the cursor position. Section 
5.1.4

 + Delete Line Deletes the line at the cursor position.

− Device Comment Edits device comments. Section 7.1

− Statement Edits the ladder statement at the cursor 
position. Section 7.2

− Note Edits the note at the cursor position.

 + Find Device Searches for a device. Section 
6.1.1

− Find Instruction Searches for an instruction. Section 
6.1.2

Address Display Displays a device actually assigned with 
compilation.

Section 
2.2.7

F
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Appendix 1 List of Toolbars and Shortcut Keys
Table App.1.5-1 "Ladder" toolbar icons and shortcut keys (2/2)

Toolbar 
icon Shortcut key Corresponding menu Description Reference

− Zoom Changes the display magnification ratio of 
the ladder.

Section 
2.2.2

−  + Insert Row Inserts a row at the cursor position.

Section 
5.1.7

−  + Delete Row Deletes the row at the cursor position.

−  + Insert Column Inserts a column at the cursor position.

−  + Delete Column Deletes the column at the cursor position.

− Ladder Conversion Converts the program being edited. Section 8.1

−  +  /  /  / −
Moves the cursor on the editing screen 
while the Enter Symbol screen is displayed.

Section 
5.1.2

−  + Jump Displays the specified row. Section 
6.1.4

−  + Comment Displays device comments.
Section 

2.2.4−  + Statement Displays statements.

−  + Note Displays notes.

 + Back to SFC Block Opens the SFC diagram corresponds to 
the program on the Zoom screen.

Section 
5.2.8
Appendix 1.5 Toolbar icons and shortcut keys in program editors App - 9
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■ "SFC" toolbar icons and shortcut keys

The following table shows the toolbar icons and the corresponding shortcut keys available in the SFC 
editor.

Table App.1.5-2 "SFC" toolbar icons and shortcut keys (1/2)

Toolbar 
icon Shortcut key Corresponding menu Description Reference

−  + Insert Row Inserts a row at the cursor position.

Section 
5.2.2

−  + Delete Row Deletes a row at the cursor position.

−  + Insert Column Inserts a column at the cursor position.

−  + Delete Column Deletes a column at the cursor position.

Step Inserts  at the cursor position.

Block START Step - with 
END check Inserts  at the cursor position.

 + 
Block START Step - with 
no END check Inserts  at the cursor position.

Jump Inserts  at the cursor position.

END Step Inserts  at the cursor position.

 + Dummy Step Inserts  at the cursor position.

Transition Inserts  at the cursor position.

Selection Divergence Inserts a selection divergence.

Simultaneous 
Divergence Inserts a simultaneous divergence.

Selection Convergence Inserts a selection convergence.

Simultaneous 
Convergence Inserts a simultaneous convergence.

 + Vertical Line Inserts a vertical line.

 + Normal Sets the step attribute to Normal.

Section 
5.2.4

 + Coil Saving Sets the step attribute to Stored Coil.

 + 
Action Saving - with no 
transition check

Sets the step attribute to Stored Operation 
(SE).

 + 
Action Saving - with 
transition check

Sets the step attribute to Stored Operation 
(ST).

 + Reset Resets the step attribute.

 + Vertical Line (Draw Line) Inserts  at the cursor position.

Section 
5.2.2

 + 
Selection Divergence 
(Draw Line) Inserts  at the cursor position.

 + 
Simultaneous 
Divergence (Draw Line) Inserts  at the cursor position.

 + 
Selection Convergence 
(Draw Line) Inserts  at the cursor position.

 + 
Simultaneous 
Convergence (Draw 
Line)

Inserts  at the cursor position.

 + Delete Line Deletes a line at the cursor position. Section 
5.2.3

 + 
SFC Step/Edit Step 
Comment Edits the SFC step/transition comments. Section 7.6
App - 10 Appendix 1.5 Toolbar icons and shortcut keys in program editors
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Appendix 1 List of Toolbars and Shortcut Keys
Table App.1.5-2 "SFC" toolbar icons and shortcut keys (2/2)

■ SFC block list shortcut keys

The following table shows the shortcut keys available in the SFC block list.

Table App.1.5-3 SFC block list shortcut keys

Appendix 1.6 Shortcut key for editing intelligent function module 
data

The following explains the shortcut key used for editing intelligent function module data.

■ Shortcut key for editing type QD75 positioning module data

The following table shows the shortcut key used for editing type QD75 positioning module data.

Table App.1.6-1 Shortcut key for editing type QD75 positioning module data

Toolbar 
icon Shortcut key Corresponding menu Description Reference

− SFC Step No. Sort Sorts the SFC block step numbers. Section 
5.2.6

−
SFC All Block Batch 
Monitor

Batch monitors all blocks in the SFC 
program.

Section 
10.5.4

− SFC Auto Scroll Monitor
Scrolls the screen to display active steps 
automatically when they are out of the 
screen during monitoring.

Section 
10.5.1

− Zoom Changes the display magnification ratio of 
the ladder.

Section 
2.3.2

−  +  + Build All SFC Program Converts all SFC programs in the project. Section 8.2

−  + 
SFC Step/ Transition 
Comment Displays the SFC step/transition comments. Section 

2.3.3

−  +  /  +  
double click

Open Step/Transition Displays the Zoom screen or the start 
destination block.

Section 
5.2.8− − Displays the start destination block.

−  + Back to SFC Block Displays the start source block.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

−  + Jump Jumps to the specified block number/data 
name. Section 

6.2.1
− Numeric key − Jumps to the selected block number.

−  +  + Build All SFC Program Converts all SFC programs in the project. Section 8.2

−  + SFC Block List Comment Displays comments of the SFC block list. Section 
5.2.10

Toolbar 
icon Shortcut key Corresponding menu Description Reference

−  + −
Selects all data on the Positioning Data and 
Block Start Data screens. -
Appendix 1.6 Shortcut key for editing intelligent function module data App - 11
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[A]
Action/Transition ............................................................5-73
Active step ......................................................................10-7
Active Step Monitor ......................................................10-11
Application Instruction ......................................................5-6
application instructions .....................................................5-6
array ...............................................................................4-10
Array Element ................................................................4-10
array element .................................................................4-18
Auto scroll monitoring .....................................................10-8

[B]
batch-compiling ........................................................ 8-6, 8-8
batch-deleting .................................................................5-32
Batch-deleting NOPs ......................................................5-32
Batch-editing Statements and Notes ..............................7-15
Batch-inserting NOPs .....................................................5-31
Batch-replacing devices ...................................................6-5
being on hold ..................................................................10-7
block information ............................................................5-77
block start step ............................................ 5-53, 5-76, 10-8
block title ........................................................................5-77
Buffer memory ................................................................11-4

[C]
Change Instance (Function Block) .................................10-3
Change SFC All ...............................................................8-3
changing .........................................................................7-24
changing the size of the text displayed ............................2-4
Changing the type ..........................................................7-17
Changing the Type (PLC/Peripheral) .............................7-24
Class ................................................................. 4-3, 4-5, 4-7
Close Branch ....................................................................5-6
Close Contact ...................................................................5-6
Coil ...................................................................................5-6
coils ..................................................................................5-6
Column .............................................................................2-6
Comment ..................................................4-3, 4-5, 4-7, 4-14
comment that is appended ...............................................7-3
Compilation .......................................................... 8-11, 8-12
Compiling ................................................................. 8-6, 8-8
Conditions ......................................................................8-12
Conditions of Monitoring ................................................10-4
Confirming Errors ...........................................................8-11
Confirming the compile status .................................. 8-7, 8-9
Consecutive entry icon .....................................................5-6
Consistency (pair) check ..................................................8-4
contacts ............................................................................5-6
control SFC type .................................................. 5-82, 5-83
converting .........................................................................8-2
Converting Ladder Blocks ................................................8-2
converting SFC diagrams .................................................8-3

Copy ............................................................................... 5-33
current values .............................................. 10-2, 10-4, 10-5
Cursor .............................................................................. 2-3
Cut .................................................................................. 5-33
Cutting, copying, and pasting ......................................... 5-33
Cutting, copying, and pasting SFC diagrams ................. 5-72

[D]
Data Name ............................................................4-15, 4-17
Data Type ..............................4-3, 4-5, 4-7, 4-14, 4-15, 4-17
data type .................................................................4-9, 4-10
Delete Column ............................................................... 5-27
Delete Horizontal Line .................................................... 5-24
Delete Line ..................................................................... 5-24
Delete Row ..................................................................... 5-27
Delete Vertical Line ........................................................ 5-24
Delete vertical line screen .............................................. 5-25
deleted ........................................................................... 7-14
Deleting .......................................................................... 7-18
Deleting a ladder block ................................................... 5-23
Deleting columns ............................................................ 5-30
deleting contacts, coils, and application instructions ...... 5-21
Deleting lines .................................................................. 4-12
Deleting lines of line statements .................................... 7-18
Deleting rows ................................................................. 5-28
Deleting SFC diagrams .................................................. 5-69
Deleting statements ....................................................... 7-10
deleting vertical and horizontal lines consecutively ........ 5-24
Detail Setting .............................................................4-3, 4-5
Device ....................................................4-3, 4-5, 4-15, 4-17
Device check .................................................................... 8-4
Device comment ............................................................ 11-3
device comment ............................................................. 11-3
Device Comment Display Format .................................. 11-3
Device Comments ............................................................ 7-2
Device instruction entry field ............................................ 5-6
device name ..................................................................... 4-3
device types for function blocks ..................................... 5-18
devices that can be replaced or batch replaced ............... 6-6
Digit .................................................................................. 6-2
Display Connection of Ladder Diagram ........................... 2-6
Display format ................................................................ 11-4
display format ................................................................. 10-4
Docking window ............................................................... 2-2
Double word ..................................................................... 6-2
drag and drop ................................................................. 5-14
drawing vertical and horizontal lines consecutively ........ 5-19
dummy coil ..................................................................... 5-76
Dummy Step .................................................................. 5-51
Duplicated coil ................................................................ 11-3
Duplicated coil check ................................................5-8, 8-4
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[E]
Edit FB Instance .............................................................5-17
Edit Line ..........................................................................5-19
editing screen ........................................................... 2-3, 5-2
END line ...........................................................................2-3
END Step ........................................................................5-65
Enter device comment screen ..........................................5-9
Enter FB instance name screen .....................................5-17
Enter line statements ........................................................7-4
Enter Note ......................................................................7-11
Enter P/I statements .........................................................7-6
Enter Symbol screen ........................................................5-6
Enter vertical line screen ................................................5-20
entering a device comment ..............................................5-9
Entering a P statements and I statements ........................7-6
Entering notes ................................................................7-11
Examples of device search ...............................................6-3
Examples of instruction search .........................................6-8

[F]
Falling Pulse .....................................................................5-6
Falling Pulse Branch .........................................................5-6
FB instance name ...........................................................5-14
FB instance names .........................................................5-17
Find Device .....................................................................6-20
function block label setting .............................................5-13
function block selection window ............................. 2-2, 5-13
function blocks ...................................................... 5-13, 5-18

[G]
GX Developer ................................................................ A-24
GX Works2 .................................................................... A-24
GX Works2 Beginner’s Manual (Simple Project) ........... A-19
GX Works2 Beginner’s Manual (Structured Project) ..... A-19
GX Works2 Version1 Operating Manual (Common) ..... A-19
GX Works2 Version1 Operating Manual 
(Structured Project) ....................................................... A-19

[H]
High Performance Model QCPU ................................... A-24
hold step .........................................................................10-7
Horizontal Line ................................................................5-19

[I]
I statement ................................................................ 7-3, 7-7
I statements ......................................................................7-6
Identifier .................................................................. 4-7, 4-14
Inactive step ...................................................................10-7
Initial ........................................................ 4-3, 4-5, 4-7, 4-14
Input FB instance screen ................................................5-14
input ladder parts ............................................................5-18

Insert Column .................................................................5-27
Insert mode .................................................5-21, 5-34, 5-38
Insert NOP batch screen ................................................5-31
Insert Row ......................................................................5-27
Inserting columns ...........................................................5-29
Inserting lines for line statements ...................................7-18
Inserting rows .................................................................5-27
Insertion ..........................................................................5-46
Instruction check ..............................................................8-4
interrupt pointer numbers ............... 5-10, 7-3, 7-6, 7-7, 7-16
Invert Operation Results ...................................................5-6

[J]
jump ................................................................................7-23
jump destination step number ................................ 2-9, 6-18
Jump to the specified statement and note ......................7-23
jump transitions ..............................................................5-64
Jumping ..........................................................................6-11

[L]
Ladder check ....................................................................8-4
Ladder Editor ....................................................................2-3
Ladder Symbol .................................................................5-6
Ladder symbol selection field ...........................................5-6
Left base line ....................................................................2-3
Line statement ..................................................................7-3
link memory ....................................................................11-4

[M]
manuals ......................................................................... A-19
Menu bar ..........................................................................2-2
Merge Processing ................................................ 7-25, 7-27
method for drawing a line ...............................................5-19
Modifying a note .............................................................7-13
Modifying a statement ......................................................7-8
Modifying statements and notes .....................................7-17
monitoring a function block program ..............................10-3
monitoring a program .....................................................10-2
Monitoring buffer memory and link memory ...................10-5
Monitoring operation outputs and transition conditions ..10-9
Monitoring SFC block list ..............................................10-12
Monitoring SFC Programs ..............................................10-7
Monitoring transitions .....................................................10-9
monitoring value .............................................................11-4
Moving statement and note lines up and down ..............7-19

[N]
New Declaration (After) ..................................................4-12
New Declaration (Before) ...............................................4-12
Normal SFC type ............................................................5-82
note ..................................................... 7-3, 7-17, 7-22, 7-23
note lines up and down ..................................................7-19
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notes ..............................................................................7-15
number of contacts ...........................................................2-6

[O]
offset values ...................................................................4-18
Open Branch ....................................................................5-6
Open Contact ...................................................................5-6
operation output/transition condition ........... 5-66, 5-74, 5-76
Operation Result Falling Pulse .........................................5-6
Operation Result Rising Pulse .........................................5-6
options ............................................................................11-2
output ladder parts .........................................................5-18
Output window ............................... 2-2, 8-6, 8-8, 8-11, 8-13

[P]
P and I statements ...........................................................7-7
P statement ......................................................................7-3
parameters for SFC programs .......................................5-81
Paste ..............................................................................5-33
Paste Data screen ..........................................................5-72
Pasting function blocks ..................................................5-14
Peripheral ...............................................7-3, 7-4, 7-11, 7-25
Personal computer ........................................................ A-24
PLC ..................................................................................7-3
pointer number ............................... 5-10, 7-3, 7-6, 7-7, 7-16
Precautions on replacing ...................................... 6-10, 6-15
Program ...........................................................................8-4
Program Check ................................................................8-4
Project window .................................................................2-2
property of SFC programs ..............................................5-82

[Q]
QCPU (Q mode) ............................................................ A-24
QCPU Structured Programming Manual 
(Application Functions) .................................................. A-19
QCPU Structured Programming Manual 
(Common Instructions) .................................................. A-19
QCPU Structured Programming Manual 
(Special Instructions) ..................................................... A-19
QCPU/FXCPU Structured Programming Manual 
(Fundamentals) ............................................................. A-19

[R]
Read from PLC ................................................................9-2
Redisplaying SFC diagrams ...........................................5-75
Replace SFC Step No. ...................................................6-18
Replacing devices ............................................................6-4
Replacing instructions ......................................................6-9
Replacing the module I/O numbers of ............................6-15
required manuals .......................................................... A-19
reset destination step number ................................ 2-9, 6-18
reset step .......................................................................5-51

Restoring ........................................................................ 5-40
Right base line ................................................................. 2-3
Rising Pulse ..................................................................... 5-6
Rising Pulse Branch ......................................................... 5-6
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Row of SFC .................................................................... 2-10

[S]
search .............................................................................. 6-3
Search and Replace ......................................................... 6-2
Searching for devices ....................................................... 6-2
Searching for instructions ................................................. 6-7
Searching for statements and notes .............................. 7-22
selection convergence ................................................... 5-59
selection divergence ...................................................... 5-57
series transition .............................................................. 5-55
Setting the structure for data type .................................. 4-15
SFC All Block Batch Monitor ........................................ 10-10
SFC block ....................................................................... 5-77
SFC block list ................................................................. 5-78
SFC comment ................................................................ 7-27
SFC editor ...............................................................2-8, 5-48
SFC step ...............................................................5-48, 5-51
SFC step active/inactive status .................................... 10-11
SFC step attribute .................................................5-51, 5-71
SFC step comment ..............................2-9, 5-51, 5-53, 7-27
SFC Step No. Sort ......................................................... 5-74
SFC step number ............................................................. 2-9
SFC step/transition comments ....................................... 2-10
Simple project ................................................................A-24
simultaneous convergence ............................................ 5-61
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[T]
Targets of compile-all and compile processing ................8-7
Title bar ..................................................................... 2-2, 2-3
Toolbar .............................................................................2-2
Transition ........................................................................5-49
transition comment ........................................2-9, 5-55, 7-27
Transition number .............................................................2-9
two- or three-dimensional array ......................................4-10
Type Selection screen ............................................ 4-9, 4-10
Types ................................................................................7-3

[U]
unconverted ......................................................................8-2
Undo ...............................................................................5-39
Using bit specification ........................................... 4-16, 4-19

[V]
Vertical Line ....................................................................5-19

[W]
Warning ..........................................................................8-11
warning code ..................................................................8-13
warning message ...........................................................8-13
word device ....................................................................10-4
Work window ....................................................................2-2
wrapping ............................................ 5-41, 5-42, 5-43, 5-44
wrapping destination symbol ..........................................5-12
wrapping lines .................................................................5-11
wrapping source symbol .................................................5-11
Write to PLC .....................................................................9-2
Writing/Reading ................................................................9-2

[Z]
Zoom ..............................................................................5-76
Zooming the editing screen ...................................... 2-4, 2-9
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